dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1771
share rss forum feed


EUS
Kill cancer
Premium
join:2002-09-10
canada
Reviews:
·voip.ms

[Excel] -2010

Before 2010 version of excel, when I would create a formula, I would be able to use the mouse scroll to scroll up/down the page (while in 'edit' mode), this seems to have gone away in the current version.
Is there any way to bring this important functionality back, either by an option, or regedit?
--
~ Project Hope ~


plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3
I have been using Excel 2010 for a long time, so let me see if I can help.

I *think* what you are talking about does work, if I am doing the same thing you are.

If I have excel open, and I am in cell G21, and I enter in "=sum(" I can then click on a cell that I want to put in. The formula bar then shows

"=sum(C6"

I can then use the wheel on my mouse to scroll down (say 30 or more rows) and then hold the shift key and click a cell, and I get this

"=sum(C6:C101"

Is that what you are talking about? Or, is it something different.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail


EUS
Kill cancer
Premium
join:2002-09-10
canada
Exactly that, yes, mouse wheel is inactive while creating/editing a formula.


plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3
reply to EUS
Ok. I think I see what you are talking about, and I get the same issue that you are talking about.

If I already have a formula in a cell, and I click on the top part of the spreadsheet (to edit the formula), the mouse does not work.

Example: My current formula in Cell G21 reads

"=SUM(C6:C51)"

Now, if I click on cell G21, and then put the mouse at the top bar (to edit it), and I take away the C51), so I am left with

"=SUM(C6:"

I then want to use the mouse again to edit it (just like I did to create it). No matter what I do, while I'm in "edit" mode in the top bar, the scroll on the mouse does not work. I can click anywhere in the spreadsheet, and then use the arrow keys / shift key / ctrl key to select specific cells.

So, I DO have that problem!

However, if you press F2 (to edit the formula in line), then the scroll wheel of the mouse does work as expected.

It appears it has to do with the edit being done in the edit bar at the top.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail


EUS
Kill cancer
Premium
join:2002-09-10
canada
Hmm, I just tried using F2, mouse scroll still not functioning.


plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3
Its a little tricky to get the mouse to work with F2 edit. I had to try it a few times to get it work, but if you edit the formula right, it does work. However, I do see that sometimes when you click in a cell, Excel thinks you're done with the edit, and want to go to that cell. To get the mouse to work for me from F2 edit, I had to remove the full formula (was just left with the () ), and then I was able to click the first cell, then use the mouse without problems to select another 30 cells, and then click to end the formula.

Still does not explain why the problem happens with the edit bar at the top. I would think it would work the same way.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail


EUS
Kill cancer
Premium
join:2002-09-10
canada
Reviews:
·voip.ms
reply to plencnerb
I have discovered something.
In options > advanced > Do you have "allow editing directly in cells" checked? When I do enable this option, I get the same behavior as you; F2 allows mouse scroll.
However, I kinda need this option disabled, so that when working with linked files, I can double-click the cell, and have the linked file open automatically.
This behavior is new with 2010, 2003 and before did not act this way, mouse scroll was always available.
--
~ Project Hope ~


plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3
I do have that option checked. I think that is by default, as I know I have not made a change to that option (or any others) on that screen.

You mention that 2003 and before did not have this problem. Not sure if you have access to Excel 2007. I know 2007 was the first version where the Ribbon came into play. I have Office 2007, but it would be kind of a process to test it out (remove office 2010, install office 2007, patch 2007, test, remove office 2007, install office 2010, patch 2010). Just wondering if it also "broke" in 2007 as well.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail


EUS
Kill cancer
Premium
join:2002-09-10
canada
Reviews:
·voip.ms
Yes that option is enabled by default.
Unfortunately, I do not have access to v'07, we went from XP/Office 2003 to Win7/Office 2010, half the office is still on Office 2003, to scale expenses.
--
~ Project Hope ~