dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3341
share rss forum feed

BarzonCL

join:2012-06-29
chile

[HELP] Very Slow Internet connection w/Cisco 800 serie Router

Hi guys, After trying all to solve this issue with a Cisco 891 Router, I try to find some solution for this problem.

First, this Cisco router is new, a 800 series router. I connect this directly to the gateway of the ISP (Cisco managed switch). The router comes with a basic configuration from the Cisco reseller for 'PLUG AND USE', the router works fine, and the network too, but I having problems with the bandwidth/speed of the internet. When I connect directly my laptop to the ISP gateway, I get a very nice connection of 9,6Mbps/8Mbps average... But when I connect the Router to the gateway, and my laptop to the router for make tests, the speed is only 0.2% of the original 10Mbps dedicated line... Only the average is 0,4 Mbps... Wow! is very slow and a big change of speed! I tried different configurations, and altered the MTU of the different interfaces, What or Why the router is causing this extremely low speed?

I using 1 fastethernet for making the link with the ISP gateway and the Gigabitethernet for connect to the LAN switch and connect all the other laptop/pc to this switch. NO Valid Vlan used or configured, only 2 ports/interface are used of the Cisco 891 router.

The actual configuration, or the important portion is here:


Current configuration : 5677 bytes
!
! Last configuration change at 14:03:33 CL Fri Jun 29 2012 by admin
! NVRAM config last updated at 13:56:10 CL Fri Jun 29 2012 by admin
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname ROUTER_H
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
enable secret 5
!
aaa new-model
!
!
aaa authentication login userauthen local
aaa authorization network groupauthor local
!
!
!
!
!
aaa session-id common
!
!
!
clock timezone CL -3
!

no ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.201 192.168.1.254
ip dhcp excluded-address 192.168.1.250
ip dhcp excluded-address 192.168.1.253
!
ip dhcp pool POOL_LAN_H
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 200.5.9.9 200.5.14.2
lease 7
!
!
ip cef
ip name-server 8.8.8.8
login on-success log
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
vtp mode transparent

!
!
!
!

!
!

!
!
!
!
!
interface Loopback0
ip address 90.90.90.1 255.255.255.0
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface FastEthernet4
!
!
interface FastEthernet5
!
!
interface FastEthernet6
!
!
interface FastEthernet7
description LAN_TEST
duplex full
speed 100
!
!
interface FastEthernet8
description INTERNET
ip address 200.1.1.1 255.255.255.248
ip nat outside
no ip virtual-reassembly
duplex full
speed 100
crypto map clientmap
!
!
interface GigabitEthernet0
description LAN_H
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
duplex full
speed 100
!
!
interface Vlan1
description LAN
no ip address
ip tcp adjust-mss 1392
!
!
interface Async1
no ip address
encapsulation slip
!
!
ip local pool ippool 10.10.10.100 10.10.10.150
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 10 interface FastEthernet8 overload
ip route 0.0.0.0 0.0.0.0 200.113.175.113
!
ip access-list extended SPLIT_TUNNEL
permit ip 90.90.90.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
!
access-list 10 permit 192.168.1.0 0.0.0.255
ip local pool ippool 10.10.10.100 10.10.10.150
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 10 interface FastEthernet8 overload
ip route 0.0.0.0 0.0.0.0 200.113.175.113
!
ip access-list extended SPLIT_TUNNEL
permit ip 90.90.90.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
password 7
transport input telnet ssh
line vty 5 15
transport input telnet ssh
!
scheduler max-task-time 5000
ntp server 200.27.106.116
end


Any idea or suggestions?

Bink
Villains... knock off all that evil

join:2006-05-14
Castle Rock, CO
kudos:4

Re: [HELP] Very Slow Internet connection w/Cisco 800 serie Route

I'd start by not hard coding the duplex and speed of all interfaces-unless you know this is hard coded on the other end.

elnino

join:2006-08-27
Akron, OH
said by Bink:

I'd start by not hard coding the duplex and speed of all interfaces-unless you know this is hard coded on the other end.

I second this. Since the Internet side is a 'plug and use' type setup, they most likely have their side set to auto/auto. LAN should also be set the same

BarzonCL

join:2012-06-29
chile
Yes, all the network of the ISP gateway are forced at 100Mbps duplex full and they requires our side of the network forced too.

I tested with my forced LAN of the laptop at 100Mbps and connected directly to the gateway of the ISP, the speed is the optimal with 10Mbps/10Mbps down/up and international connectivity with 6Mbps/6Mbps the best rate. With cisco the cisco router 0,2 Mbps...

HELLFIRE
Premium
join:2009-11-25
kudos:19
reply to BarzonCL
Check the troubleshooting steps here for some ideas.

I'm also questioning the tcp adjust mss on your VLAN1 config, is this a DSL connection?

Also, can you define what the "ISP Gateway" is? Is it a device that is also doing DHCP and NAT'ing?

Regards