dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2874
share rss forum feed

Gunni

join:2005-12-06
Bethesda, MD

[ActionTec] Actiontec MI424WR Wireless & wireless printing

I have been dealing with a problem I am experiencing connecting to my printer which had been working just fine. The link to that thread is here:

»Brother Printer "offline"..

However, I am beginning to suspect the problem is not with the printer but with my network. I have spent the better part of two hours testing all the connections and trying to carefully and logically describe this problem so that one of your router/network gurus might be able to see something which I am missing.

The hardware:

My iMac (Mac1)
Wife’s iMac (Mac 2)
MacBook Air (MBA)
All running OXS 10.7.4.

What I have been running for about two years, problem free, is a Verizon-supplied Actiontec MI424WR Wireless Broadband Router Revision E connected to Mac1 via an ethernet cable; the other two Macs connected via their Airport cards to the Wireless router.

Last week, before the problem with the printer began, this LAN was working just fine. I could use AirDrop between any of the computers & I could print from any of the computers. From one day to the next, I could no longer print and Air Drop stopped working. All the details of the printing problem and efforts to solve it are available via the above URL on the All Things Macintosh forum here.

Trying to fix the printer I noticed this:

With Mac1 CONNECTED TO THE ROUTER VIA AN ETHERNET CABLE, and with the Finder preferences for all computers set to show everything in the Finder sidebar here are the results:

Mac1 > Finder sidebar > Devices. The Mac1 shows but the Shared category does not even appear in the Sidebar. Checking the Print & Scan pane of Sys Prefs, the printer shows green dot/idle. Sending a print job to the printer results in that dot turning to yellow/in use. However, the printer icon appears in the dock with a lightning symbol in a yellow circle and opening it reveals: The printer is not connected.

Mac2 > Finder sidebar > Devices. The Mac2 shows. Under Shared > Mac1, Mac2, and the printer show. The printer prints.

MBA > Finder sidebar > Devices. The MBA shows. Under Shared > Mac1 and Mac2, and the printer. The printer prints.

However, with Mac1 CONNECTED TO THE ROUTER VIA WIFI and the ethernet cable disconnected everything works just fine; here are the results:

Mac1 > Finder sidebar > Devices. The Mac1 shows. Shared > Mac2 & MBA show, but no printer shows; Print & Scan Preferences Pane shows my Brother HL-2270DW with a green dot and “idle” and the printer will print.

Mac2 > Finder sidebar > Devices. The Mac2 shows. Shared > Mac1, Mac2, and the printer; and the printer accepts print jobs from this computer.

MBA > Finder sidebar > Devices. The MBA shows. Shared > Mac1 and Mac2, and the printer, and the printer accepts jobs from this computer.

SO, what all this comes down to is one question: why, when Mac1 is connected via the ethernet cable will the printer not show under Shared and not accept and print jobs from Mac1 which it previously did for several years???

It is driving me nuts. Yeah, I know, it’s not a long drive.

Thanks if you have the chance to look at this and make any sense out of it.


Gunni

join:2005-12-06
Bethesda, MD

Problem solved:

After days of poking around, with settings, following advice found on the MacRumors Forum, I went to Sys Prefs > Print & Scan > + > IP and in the Address blank typed in the address which my router showed for the printer (192.168.1.10), then went to the Print Using drop down menu and selected the Brother HL-2270DW series CUPS driver, and hit Add.

Closed the Print & Scan pane, tried and successfully printed a document.

What a journey, just to get the bloody printer working again.

However, learned a lot about printers and perhaps I can help someone else with the same problem.