dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
share rss forum feed


LowInfoVoter
Vote early, vote often, vote democrat.

join:2007-11-19
USA

1 recommendation

reply to Hitman66610

Re: [Windows] Cannot get network shares working with Boxee Box

before you screw around with all that, you need to ask yourself: is your stuttering occuring because other computers on your network are eating up LAN (not internet) bandwidth?

if you still get stuttering when nothing else is using the LAN, your problem isn't because of QOS. people use QOS primarily to make sure traffic aimed at the internet gets prioritized.


Hitman66610
Pan-National Aquisitioner
Premium
join:2010-01-08
Oakville, ON
I do believe it has something to do with torrents. I also use other applications which use idle internet time like BOINC and whatnot.
--
Xbox Gamertag: THE GREEN GH0ST

bdnhsv

join:2012-01-20
Huntsville, AL
It sounds like you'll need to figure out all the major protocols running in your LAN and decide how to prioritize them. Do you have questions as to how to discover the protocols in your local network?


LowInfoVoter
Vote early, vote often, vote democrat.

join:2007-11-19
USA
reply to Hitman66610
so then turn off the torrents and play video. does it stutter? if so, it's not the torrent.

also, those torrents cant possibly eat up all your LAN bandwidth. you need to dissociate your internet traffic with your LAN traffic. focus on your lan. assuming you have 3 MBps of torrent activity on your lan, on a 100Mbps pipe, that only takes up maybe 1/4 of the pipe. that's does not congestion make.


Hitman66610
Pan-National Aquisitioner
Premium
join:2010-01-08
Oakville, ON
Yes, it is still stuttering after I turn off torrents and whatnot. The computer that the files are coming from is wireless, so that means that it's MAXIMUM 54mbps speed, not accounting for what other bits of traffic might be coming from that computer.
--
Xbox Gamertag: THE GREEN GH0ST


LowInfoVoter
Vote early, vote often, vote democrat.

join:2007-11-19
USA
the first thing to do is to figure out if/where the latency becomes the biggest issue.

using your network map, id start with "gary". ping the linksys continually (ping xxx -t, control+c to stop and see results). if everything is optimal, very, very, very few packets should drop (interference may claim some) and your pings should average 1 to 2 ms. if this isn't happening between gary and the linksys, test from another wireless workstation to make sure it isn't just gary's problem.

if you're getting low pings and few (VERY VERY VERY VERY VERY FEW) timeouts, your wireless router and its configuration are good to go. then start testing the next device in the route. do a continuous ping on the dlink. since it's wired to the linksys, there shouldn't be much difference in the pings, but it's still necessary to test. finally, if things remain optimal, ping the boxee (which i assume is hosting the files). the key is that all these pings need to show you that the path is not showing signs of latency.

hows it look?


Hitman66610
Pan-National Aquisitioner
Premium
join:2010-01-08
Oakville, ON
Here is the rundown of what I got (btw Stashbox is the wireless computer which the media is coming from):

Gary to D-Link:
4 packets, 0% loss
58ms, 4ms, 4ms, and 4ms

Gary to Linksys:
4 packets, 0% loss
5ms, 31ms, 4ms, and 3ms

Gary to Boxee:
4 packets, 0% loss
11ms, 14ms, 9ms, and 5ms

Gary to Stashbox:
4 packets, 0%
7ms, 3ms, 3ms, and 3ms

Stashbox to Gary:
4 packets, 25% loss
3686ms, 3543ms, and 2160ms

Stashbox to Linksys:
0% loss
1163ms, 869ms, 567ms, and 543ms

Stashbox to D-Link:
0% loss
183ms, 428ms, 129ms, and 20ms

Stashbox to Boxee:
0% loss
729ms, 8ms, 1162ms, and 19ms
--
Xbox Gamertag: THE GREEN GH0ST

bdnhsv

join:2012-01-20
Huntsville, AL
4 packets is probably not enough to properly diagnose what's happening, but even so I see a huge difference in your results from all other devices compared to communications with your stashbox. Can you hard wire your stashbox to your router and try your tests again?


LowInfoVoter
Vote early, vote often, vote democrat.

join:2007-11-19
USA
yeah, i should have said to ping devices for about a minute using "ping xxx -t". you press control+c to end the continuous ping and see the results.

said by bdnhsv:

hard wire your stashbox to your router and try your tests again?

yup yup yup

that latency you're seeing is why your videos are stuttering


Hitman66610
Pan-National Aquisitioner
Premium
join:2010-01-08
Oakville, ON
I can't hard wire because of the distance between them. I'm also not in the financial position to get another powerline adapter at the moment. But here are the ping results:

Gary to D-Link:
53 packets, 0% loss
all 3-6ms

Gary to Linksys:
63 packets, 0% loss
all 3-5ms

Gary to Boxee:
70 packets, 1 lost, 1% loss
all 6-9 ms, one randomly timed out in the middle

Gary to Stashbox:
See picture. I did this one twice because it was so messed up the first time. The picture is from the first time.
2nd time:
61 packets, 0% loss
Min 4ms, Max 60ms, average 9ms



Stashbox to Gary:
53 packets, 0% loss
pings all over the map, from 4ms - 219ms

Stashbox to Linksys:
50 packets, 0% loss
mostly 1ms to 3ms, except every 6 or 7th one it would go to 12ms or so. In the middle, there was an instance of 1ms, but the next one was 1848ms

Stashbox to D-Link:
61 packets, 0% loss
all 1-3ms, except a random 430ms, a 51ms, a 10 ms, and a 14ms

Stashbox to Boxee:
(Let this one go longer since it's the important one)
140 packets, 0% loss
Min 3ms, max 239ms, average 8ms


LowInfoVoter
Vote early, vote often, vote democrat.

join:2007-11-19
USA
is it possible to unplug and move stashbox so that you can directly wire it to your DLINK? at this point, the wireless adapter is in question.

the other way to test is to use a different wireless adapter on stashbox. if you have one.