dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3313
share rss forum feed

whyamihere

join:2008-10-01
Tyler, TX

WRT54GL won't show printer in DHCP table-but printer works

Had a several hr power outage (though everything's on surge protectors & UPS). Everything came back on normally after I reset router & restored a BU config file w/ proper settings, ISP PW, etc.
Except the HP printer. Gave error (seen several times in past) "error -Ink System Failure". That's apparently HP's catch all err msg for anything that's wrong.

Apparently, ethernet cable from router TO printer was loose after my "troubleshooting"? After lot of (other) unnecessary troubleshooting, reset router, restored BU config file, tried a diff router to printer ethernet cable. Printer worked - both from wired desktop & wireless laptop.

Reconnected old ethernet cable (need the longer one) from router to printer. Router's port light for printer cable is solid green - good. Printer now works w/ old router to printer cable - from desktop & wireless laptop. STILL not showing in DHCP client table.

Printer STILL not listed, though printer's own display shows it had an IP 192.168.1.110 (obviously has one, if printing). But wired desktop, Linksys voip ATA, & a wireless laptop WERE in DHCP table.
No other devices are showing same IP address as printer's display shows - good.

So, reset router ONE more time - held reset button > 30 sec; other devices lost connection, so knew router was reset. Restored BU router config file - again. " Restore Successful."

This time - logging into router UI w/ PW I've set, it wasn't showing the VOIP ATA or Printer. But, had a VOIP dial tone, so it WAS assigned IP from router - just not in DHCP table.
Unplugged ATA from router for few sec - plugged back. Very quickly, VOIP ATA showed up in DHCP table w/ proper IP. But printer's still is NOT (though it's printing).

Not sure why all other devices ARE in DHCP table EXCEPT printer. Closed / reopened router UI couple times. Refreshed DHCP table couple times. Printer works - still not in DHCP table. Only real reason I care, is NEXT TIME I have to troubleshoot printer, need to know it's actually registered w/ the router. If doesn't show in DHCP table, can't tell for sure what might be wrong.

Short of flashing router firmware w/ same version as installed - (NO IDEA it would have any effect) - not sure why router isn't showing printer or what to do to correct. Reboot PC? (try) & del printer port / IP address from printer settings & see if router assigns new one & then shows in DHCP table...??

Any other ideas? Thanks.

scubascythan

join:2005-05-14
Printer needs to release and renew ip for WRT54 to see it in it's dhcp table. Normal behaviour.

Same thing happens to me after I reboot my main router. My secondary AP router had an IP of *.30, after the main reboots it maintains that IP and everything including devices connected to it work but it won't show up on the table until I reboot the secondary or release/renew IP on it.

whyamihere

join:2008-10-01
Tyler, TX

1 edit
reply to whyamihere
Ok, thanks. How do I get the printer to "release" its IP?

Maybe in Admin mode > Printer properties (w/ printer off), try to delete the port now shown for printer? Never had to manually force a device to release an address.

If disconnecting printer power should cause "releasing" its IP... well, done that several times, for extended periods.

I'm guessing once it does, & if printer is connected to router, the router will auto renew a new IP for it? Seems the way it works for other devices.

Obviously, this (HP) printer doesn't "release" its IP after extended power outages - the way my OTHER devices do, as they had no real problems after the outage.

BTW, after further checking, think this printer is on Static IP ("Manual"). If so, router isn't assigning an IP & wouldn't show in DHCP table. No idea yet... but POSSIBLE that the problem was printer ethernet cable connector got loose when I was originally resetting router after outage. It "seemed" to come out too easily today, when looking at it. I'll have to double check / just get new one.

Man - if that was it, what a headache over a cable.


Thane_Bitter
Inquire within
Premium
join:2005-01-20
Reviews:
·Bell Sympatico
Lease time varies, Linksys' default is 3600 minutes (60 hours) so it could take a few days before it shows up in the lease table (assuming it is asking for a DHCP lease and not set up for a static address).

Power cycling will not help, however if you changed the DHCP settings on your router (the scope) this should force any system which is online at the time a new address. Given that you have everything running smoothly and use VOIP I can't recommend it. Actually using static (or reserved) IP addresses is a good idea for printers and other devices which are shared by other machines. It makes finding them, and troubleshooting much easier. Unfortunately out of the box with stock Linksys firmware you don't have the ability to set up reserved DHCP leases, however your router does support 3rd party firmware which does (such as DD-WRT and Tomato). Again you probably don't wish to upgrade firmware at this time as it will require you to completely reconfigure the router from scratch while you are trying to navigate around a completely different GUI.

If you want the printer to use DHCP, give it a static IP address, one that is different from the settings of your own network (i.e. 10.12.11.9), then after it runs with that for a minute or so, revert back to DHCP and connect it back into your router/switch. Doing so should force it to ask for a lease (since the existing information isn't helpful for that network).

Hey, remember the old adage, "if it ain't broke, don't try to fix it", if everything (but the lease entry in the log) is working, might be best to let it alone for a few days and see if it does show up.

whyamihere

join:2008-10-01
Tyler, TX
Thanks. BTW, on Linksys WRT54GL, there's Refresh button for DCHP client list, which apparently immediately picks up any devices just connected to router.

Ultimately, not sure what got it to working again. Ran a test w/ HP's "new" Print & Scan Dr." utility. At the time (after much troubleshooting / steps) when still wasn't printing, their utility found "no problems."

I believe after I unplugged printer to router cable once more & made sure it was locked in, started working. But went thru bunch of steps before that.

With static IP, had nothing to do w/ router DHCP, lease time, etc. If cable connection was bit loose, utility SHOULD'VE found it, but not banking on that. Never the less, started working & still going.

Useful site I found on clearing HP printer errors (listed by models / series):
»www.out-of-warranty.com/ Search is at page bottom.
Here's common err msg for HPs:
»www.out-of-warranty.com/ink-syst ··· c18a-hp/