dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2694
share rss forum feed

vandergraff2

join:2005-10-17
Los Gatos, CA

WDS with E2000/WRT160N and Tomato unstable

I have an E2000 as my main router and 2 WRT160N connecting as WDS devices.

The E2000 is running 1.28.9054 MIPSR2-beta E2000 Std and the WRT160N's are running 1.28.9054 MIPSR2-beta K26 vpn3.6

I set up the 3 using the FAQ here »www.polarcloud.com/tomatofaq

It works - some of the time.........

For a time everything connects and devices can connect to the closest access point and then one of the WRT160's stops working. I can still see it listed as a wds0.x device on the device list of the E2000 and it still show an RSSI level - but it no loger allows devices connected to it to access the network. When it stops working the TX/RX rate is no longer shown in the E2000 Device list for the problematic wds device. At this poiint I can also no longer log into the tomato menus on the WRT160 problem device - even from a device that is connected wired or wirelessly to it - presumably because DHCP isn't working.

I found going to the Basic - Network settings and then saving without making any changes on the E2000 fixes the issue most of the time - sometimes it takes a couple of tries. When I do this it says some services are restarting.

All devices are set up as Access Point + WDS. Radio band is 2.4 GHz, Wireless mode is auto, security WPA2 personal, channel 6 and width 40Mhz on all devices.

WAN and DHCP server is turned off on the WRT160N's. The WRT160N's Default Gateway and Static DNS are set as the IP address of the E2000.

The E2000 is set to connect to MAC addresses of both WRT160N's while the WRT160N's are only set to connect to MAC address of the E2000.

The WRT160Ns are set to have IP addresses 192.168.2.2 and 192.168.2.3 with the E2000 having an IP address of 192.168.2.1

All three are set to use Spanning-Tree Protocol

Any ideas what I can do to make this more stable. When it works it is great providing excellent coverage around our property - but as it is it is not stable enough for family usage.

scubascythan

join:2005-05-14

1 edit
Try using 20Mhz channel on all, and check if channel 1/6/11 is the least congested in your house. Could be interference is knocking it out of sync.

Btw, if your WRT160 stops working you can still access it through a wired connection. You just need to set a static IP on your computer and have the gateway point to your WRT160.

If that doesn't work can use nas4not/scripts to keep the WDS uplink or force a reboot.

»www.linksysinfo.org/index.php?th···e.37941/

vandergraff2

join:2005-10-17
Los Gatos, CA
Thanks - yes channel 6 is clear. Actually we are on an acre so pretty much all the channels are clear.

I was able to connect to the WRT160N's using a wired link and by setting a static ip (I didn't put that detail in the original post - but I think it confirm DHCP isn't working when the problem manifests itself).

I'll try 20MHz channels. However I think that will limit the connection speed which I think is already halved on devices connecting wirelessly to the WDS stations.

I have been running just one of the WDS stations for the last 24 hours and it seems more stable and covers 90% of the areas I am trying to reach.

I'll also have a look at the link you sent - thanks again.

vandergraff2

join:2005-10-17
Los Gatos, CA
OK - one week later.

It seems stable with just one WDS station + main router.

I can live with this as it does cover pretty much all the areas I wish to cover.

Strange how adding the second WDS station seemed to make both WDS connections unstable.