dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
8187
share rss forum feed


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast

1 edit

[IPv6] Comcast Speedtest

Not sure how many of those running IPv6 saw this. Comcast now has an IPv6 only speedtest page up.

»ipv6.speedtest.comcast.net/

Many of the locations are throwing erros for me so I suspect that those servers listed aren't dual stack.

Denver, CO works as a test point for sure if any other IPv6ers want to give it a try.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
Strange, I can't connect to the site. I can ping it though.

Oedipus

join:2005-05-09
kudos:1
reply to whfsdude
Works for me.


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
Click for full size
said by Oedipus:

Works for me.

Yeah most locations work fine for me. I'm using native so it's not a routing issue but rather some locations (eg. Chicago, IL) throw a "Download Test Error."


mb

join:2000-07-23
Washington, NJ
reply to whfsdude
Several servers work for me, but if you look closely at the center of the results box it indicates an IPv4 server.


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
said by mb:

Several servers work for me, but if you look closely at the center of the results box it indicates an IPv4 server.

This just appears to be a glitch in the graphics department. I actually checked with tcpdump because I wondered that myself.

19:30:46.373778 IP6 2001:558:1010:5:68:87:73:52.80 > 2601:a:3a80:3c:717f:e7f5:1ccd:54e.60391: Flags [.], seq 12865201:12866409, ack 1257, win 16, options [nop,nop,TS val 3015573738 ecr 590397015], length 1208

^ Just a snapshot of some of the data occurring. Also, notice the v4 encode on the v6 address. Makes sense for servers. Easy on the IPAM.

2001:558:1010:5:68:87:73:52 | 68.87.73.52


tipstir

join:2004-11-14
Boca Raton, FL
kudos:1
reply to whfsdude
Works for me when I had them on the phone 2 weeks ago..



First ran this got 67m down..


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
said by tipstir:

Works for me when I had them on the phone 2 weeks ago..

Miami, FL works for me too.

Try Washington, DC or Chicago, IL.


RR Conductor
NWP RR Inc.,serving NW CA
Premium
join:2002-04-02
Redwood Valley, CA
kudos:1

2 edits

1 recommendation

reply to whfsdude
I can get some servers to work, while others won't. The closest server to my location, San Jose (150 miles south of me) just fails with a "download file error", the same with Salt Lake City and Portland. However, I can get Seattle, Pima, Denver and Albuquerque to work.

Edit-Pima seems like a strange place to put a test server, it's a TINY town way out east of Phoenix and Tuscon, literally all by itself in the desert. Well, whatever works I guess.


keenan424

join:2003-01-13
Santa Rosa, CA
Pima, AZ is not 7,450 miles from Redwood Valley either.


LMoreland

join:2010-07-28
Littleton, CO
reply to whfsdude
Works Great but it shows the results as IPV4




RR Conductor
NWP RR Inc.,serving NW CA
Premium
join:2002-04-02
Redwood Valley, CA
kudos:1

2 edits
reply to keenan424
said by keenan424:

Pima, AZ is not 7,450 miles from Redwood Valley either.

Lol Nope Their tests also show being 50 miles from San Jose, it's 170 miles south of Redwood Valley, Comcast clearly doesn't know "The way to San Jose" LOL

bman212121

join:2005-06-09
reply to LMoreland
I would be more concerned that you are routing through the north pole


ropeguru
Premium
join:2001-01-25
Mechanicsville, VA
reply to whfsdude
Not getting it to work here. Can tracert and ping just fine. Page will not load though.


Smuuth
Tanstaafl
Premium
join:2001-03-22
Aurora, CO
reply to whfsdude
Most of the servers work for me:




Although Aurora, CO is not 7000 miles from Denver, CO!
--
It's not the destination, it's the journey.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
Reviews:
·Comcast
reply to ropeguru
said by ropeguru:

Not getting it to work here. Can tracert and ping just fine. Page will not load though.

Do have native Comcast IPv6 or tunnel broker IPs?


ropeguru
Premium
join:2001-01-25
Mechanicsville, VA
Tunnel broker through Sixxs.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
Probably explains it. I have a tunnel thru Hurricane Electric and I can not load the page either. Ping and trace work fine.

aveiga

join:2012-09-11
United State

2 recommendations

Folks,

As an administrator for the Comcast SpeedTest platform, I'd like to reach out to you all to provide some insight into this as well as to solicit some of your feedback. Unfortunately we had some minor issues with DNS records preventing this initial deployment from functioning. Those should now be fixed. I am working to correct the IPv4 mislabeling. Please rest assured that you are getting your test via IPv6, as this test is setup to only provide AAAA records and prevent IPv4 tests. I am also working to correct the misreported location data, though coming in via tunnels may not be correctable at this time. We are diligently working to improve this platform even further.

That said, I am certain there will still be some bugs to be ironed out. I welcome any and all feedback regarding the current test platform, as well as reports of any issues you may encounter. I will try and check back in this thread as frequently as I can, but please send me a private message if you encounter a specific bug so that I can work to rectify it as soon as possible.

We will be looking to announce this service formally at comcast6.net in the future, once we've corrected the outstanding issues. Thank you all for being early adopters and helping to move IPv6 forward.

-aveiga, Comcast IPv6 Engineer


Jtmo
Premium
join:2001-05-20
Novato, CA
Internet Explorer cannot display the webpage

derekivey

join:2006-03-30
San Jose, CA
kudos:1

1 edit
reply to whfsdude
Doesn't seem accurate. I'm on Verizon Fios (50/25) and using a HE tunnel. The test shows my IPv6 address. There's no way this is accurate, especially through the tunnel...



ropeguru
Premium
join:2001-01-25
Mechanicsville, VA
reply to aveiga
Still not working here on a SiXXs tunnel. Can trace route and ping ok.

nslookup ipv6.speedtest.comcast.net
Server: UnKnown
Address: 2001:4830:1621::2

Non-authoritative answer:
Name: ipv6.speedtest.g.comcast.net
Address: 2001:558:1030:8:69:252:23:68
Aliases: ipv6.speedtest.comcast.net


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
reply to aveiga
Thanks for keeping us informed. I do wonder why one poster can reach the site via an HE tunnel, but I cannot.


ropeguru
Premium
join:2001-01-25
Mechanicsville, VA
said by graysonf:

Thanks for keeping us informed. I do wonder why one poster can reach the site via an HE tunnel, but I cannot.

Did you ever have any luck reaching the speedtest? I haven't.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
No, I have not, not on an HE tunnel.


Mike Wolf

join:2009-05-24
Beachwood, NJ
kudos:4

1 edit
reply to aveiga
Just tested it and the test results still come up as IPv4. Also it's an honor to help the engineers out


RR Conductor
NWP RR Inc.,serving NW CA
Premium
join:2002-04-02
Redwood Valley, CA
kudos:1

1 edit
Here as well-



I love the distance too, I'm 170 miles northwest of San Jose, not 7,950 miles


NetDog
Premium,VIP
join:2002-03-04
Parker, CO
kudos:80
reply to whfsdude
Sweet it worked for me..




I do like the fact that I am 7000mi from the server, should be more like 20 miles..

aveiga is this a bug or a feature?


kilpatds

@oppositelock.org
reply to whfsdude
Also via HE tunnel...

$ telnet ipv6.speedtest.comcast.net 80
Trying 2001:558:1030:8:69:252:23:68...
Connected to ipv6.speedtest.comcast.net.
Escape character is '^]'.
GET / HTTP/1.1
Host: ipv6.speedtest.comcast.net:80

^]

telnet> quit
Connection closed.
That was over 3 minutes waiting there. So ... something the web server's doing is causing the problems.