dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
567
share rss forum feed

TuxRaiderPen

join:2009-09-19

MySQL SSL and local-infile settings

In an attempt to consolidate distro's used down internally I am looking to replace development and testing servers from a mish mosh of RH and CentOS to Kbuntu 12.04 deriviatives.

I have some testing servers setup but MySQL is being a problem child with 2 issues.

1) SSL settings

I need to be able to replicate the db to the production servers which will be housed off site, I want to use SSL for this and for remote client (developer) connetions.

I have done what was done in the past for the older servers and followed along with 2 HOWTWO's with no success.... it still is disabled.

I generated keys, added ssl and the key locations to my.cnf, no joy.

mifosforge.jira.com/wiki/display···n+Ubuntu

»www.howtoforge.com/how-to-set-up···-squeeze

I erased the generated keys and PEM's when I decided to try it a gain with a different procedure.

I disabled apparmor thinking it was an issue.

No joy.

2) LOAD LOCAL INFILE via phpmyadmin

Some of the data I need to import into our db(s) comes from exports in a CSV like format, we need extra columns for our internal use and improvement of the data in general... so we use myphpadmin and/or just php to upload the file and import via LOAD DATA to account for the new columns...

Unfortunately via myphpadmin we get "Errror #1148 used command not allowed with the version of MySQL"

The solution is:

local-infile
*OR*
local-infile = 1

in my.cnf in the [mysqld and [mysql] areas...

Did that, restarted mysql (more times than I can count) , myphpadmin still fails with this error.

Even with apparmor disbabled, doubtful its even related, no joy.

via CLI I can scp the file to the server and then do:

:~$ mysql -umyuser -pmypass --local-infile=1 mydb
 

Thats not a viable option for the long haul process of automating this import process... temporarily while play its fine, if all the software works as it should, which means theres little to convert other host, user, pass etc... this automation process will run with out user review except for the normal bad data (original host allows embedded CR/LF in the data! URRRGRH! )....

I just can't get mysql to accept this via my.cnf

Distro is basically the minimal kubuntu with tasksel LAMP Server install process. It may be kubuntu based, but there is no X server. The box is buired in some cabinent some place, and SSH is the only access.

Server version: 5.5.24-0ubuntu0.12.04.1 (Ubuntu)

The only things that have been done manually is to add things like wget, screen, some Perl stuff for CPAN use, build essential for building perl modules etc.. All the LAMP stuff is what comes from the tasksel process.

Any clues? ? Ideas? Hammer? C4? Cemtex? ?

--
1311393600 - Back to Black.....Black....Black....