dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2800
share rss forum feed


phil_z06

@rr.com

Netgear WRN1000 and DHCP Server Trouble

Environment: Windows 2003 Server with DHCP enabled in a small private network that contains 3 clients (2 Win7 and 1 WinXP). The IP of the DHCP server is 192.168.1.1.

Recently had DSL service installed. The DSL modem is a Westell 6100 with a default IP of 192.168.200.1. If I plug directly into the Westell I get an IP from its DHCP (192.168.200.4) and can access the Internet. I then added in the Netgear WRN1000 wireless router and plugged it directly into the Westell. I released and renewed my IP and still received 192.168.200.4 and was able to access the Internet. I then plugged in the DHCP server to the Netgear and released and renewed my IP. I received an IP of 192.168.123.101, which is correct because of the DHCP scope that is configured. So, to gain access to the Internet while still using a private IP I configured the Netgear to use a LAN IP of 192.168.123.x and disabled DHCP on the Netgear. I can get to the Netgear GUI, and DHCP still works via a wired and wireless connection, but no Internet. I then enabled the bridged ethernet connection setting on the Westell and disabled DHCP on the Westell by following these instructions:
»AT&T Southeast Forum FAQ »What is the proper way to configure a Westell modem with a generic router?
I still get no Internet connection. If I change the Netgear back to its default IP of 192.168.1.1 and hard code my IP to the 192.168.1. subnet I can get to the Internet.

I thought about disabling DHCP on the Windows 2003 server and letting the Netgear handle DHCP, but the Windows 2003 Server is also an application server. The app it serves up is hard-coded to the 192.168.1.1 address, and I have no way of changing it. If I change its IP then none of the client PC's will be able to use their software (its a small Dr office that uses a practice management software on the server). I'm sure I don't have a setting correct in all of this, but I've spent the last day banging my head against a wall. I'm officially stuck. Can anyone decipher this and give me a hand? Thanks!!!



aefstoggaflm
Open Source Fan
Premium
join:2002-03-04
Bethlehem, PA
kudos:7
Reviews:
·PenTeleData
·Verizon Online DSL

I am not sure, but I am taking an educated guess to what the fix is.

Why not have the Netgear at 192.168.1.2 and then have your computer act as a DHCP Server handle out 192.168.1.* with the Default Gateway of 192.168.1.2 ?
--
Please use the "yellow (IM) envelope" to contact me and please leave the URL intact.



phil_z06

@cincinnatieye.com
reply to phil_z06

That's a good thought, but unfortunately, the DHCP server needs to stay at the 192.168.123.1 address (it's also an application server and the client software is hard-coded to use that address). I thought that if I changed the Netgear's address to the same subnet (192.168.123.x) that I'd be able to get out to the Internet, but it's not that simple I guess. I think I'm going to shut everything down tonight, reset the Westell DSL modem and Netgear wireless router to defaults, and then try everything all over again.



aefstoggaflm
Open Source Fan
Premium
join:2002-03-04
Bethlehem, PA
kudos:7
Reviews:
·PenTeleData
·Verizon Online DSL

said by phil_z06 :

That's a good thought, but unfortunately, the DHCP server needs to stay at the 192.168.123.1 address (it's also an application server and the client software is hard-coded to use that address). I thought that if I changed the Netgear's address to the same subnet (192.168.123.x)..

Ok, sorry my error.

#1 Have the Netgear router at 192.168.123.2

#2 Have the Windows computer DHCP Server at 192.168.123.1

#3 Have the Windows computer DHCP Server handle out 192.168.123.x range IP Addresses:

a) But skipping/excluding 192.168.123.2

b) And having the Default Gateway of 192.168.123.2 handed out.
--
Please use the "yellow (IM) envelope" to contact me and please leave the URL intact.


phil_z06

@cincinnatieye.com

Thank you. I will try this tonight and post back afterwards to let you know if it worked.



phil_z06

@rr.com

Well, I didn't have any luck. I reset all hardware to default and started over. When that didn't work I reset the hardware again and followed the 3 steps above (including a and b) and that didn't work either. I then replaced the netgear with a non-managed switch (non-wireless and not a router). I still can't get to the Internet, so it has to be a setting on the Westell. I set up the bridged connection on the Westell, and I thought that maybe I could change the internal IP of the Westell to a 123.x address, but you can't change the internal IP. I called the phone company (cincinnati bell) and they were of no help at all. Anymore ideas?



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

2 edits

said by phil_z06 :

Well, I didn't have any luck. I reset all hardware to default and started over. When that didn't work I reset the hardware again and followed the 3 steps above (including a and b) and that didn't work either. I then replaced the netgear with a non-managed switch (non-wireless and not a router). I still can't get to the Internet, so it has to be a setting on the Westell. I set up the bridged connection on the Westell, and I thought that maybe I could change the internal IP of the Westell to a 123.x address, but you can't change the internal IP. I called the phone company (cincinnati bell) and they were of no help at all. Anymore ideas?

I am not sure what you mean by "I set up the bridged connection on the Westell", but if you actually put the Westell "modem" into a true bridge mode (and do the PPPoE authentication in the Netgear router if your ISP requires PPPoE), you won't have to worry about assigning it a LAN IP address, because it will be invisible to your network, and it will pass the ISP's public IP address to the Netgear router's WAN interface. Besides that, you would not want the Westell's LAN interface to be in the same IP subnet as the Netgear router's LAN subnet anyway, because the Netgear router won't do any routing (meaning that it won't pass traffic between its LAN and WAN) if it's WAN and LAN interfaces are on the same IP subnet.

I suspect that your problem is that you really don't have the Westell "modem" in bridge mode, and unfortunately, the newer SBC inspired "modems" that AT&T is currently using do have major configuration limitations. You may have to buy a real bridge modem and use that instead of your current Westell "modem". I have had good luck in the past using a Zoom 5615 ADSL2(+) modem with AT&T ATM based aDSL service. However, if you have a U-verse branded AT&T IPDSLAM based DSL circuit (as opposed to a standard ATM based circuit), you will be stuck with using an AT&T supplied "modem", and trying to find a way to put it into true bridge mode.

Here is a screen shot (taken from the »AT&T Midwest/Ameritech FAQ ) that shows how to put an AT&T/SBC supplied Westell 6100 into bridge mode (set it to "PPP is on the computer, gateway, or router" mode):

»/r0/download/1···_ppp.png

Unfortunately, that information is somewhat dated, and the newer Westell modems may not have that exact setup page. And since you say that yours has a factory default LAN IP address of 192.168.200.1 (not a factory default value that is used by any AT&T supplied "modem" that I am familiar with), that would make it unlikely that you would find that exact setup page. However, you should be able to find something that accomplishes the same task.
--
We can never have enough of nature.
We need to witness our own limits transgressed, and some life pasturing freely where we never wander.


phil_z06

@cincinnatieye.com

I finally got it working last week. After setting the IP of the Westell modem to a 192.168.123.x address, I had to wait 5-10 minutes or so for the bridge to come back up. (I already had DHCP turned off on the Westell). I guess I was just impatient before. I would see that the bridge was down for a few minutes and assume that it wasn't coming back up, but this time it did. Once that IP changed I simply changed the gateway address that the DHCP server was handing out to the IP of the Westell modem. I then changed the DNS address to the IP of the Westell also. This worked perfectly. All clients are able to get an IP from the DHCP server, they can see each other on the network, and all can access the Internet now. Thanks everyone for their input!