dslreports logo
    All Forums Hot Topics Gallery


how-to block ads

Search Topic:
share rss forum feed



Motorola SB6121 won't work with Routers

I'm trying to fix this problem for someone who just got Teksavvy installed yesterday.

They bought a SB6121 from Newegg.

They get internet access when they connect the 6121 directly to their laptop. But when they connect 6121 to Router, they get no internet access.

We tried power cycling, although we'll try that again tonight.

We also Factory Reset the Router. We tried another Router also, same results.

We can connect to the Routers, but with no internet access. Plug directly from laptop to 6121, internet access.

What does this look like to you guys?


Scarborough, ON
·Rogers Hi-Speed
·Bell Sympatico
The modem "learns" the MAC address of the first device that was connected to it and won't allow anything else get an IP address.
You must power cycle the modem (by disconnecting the power cord for a few seconds) and make sure the first device you connect after that is the router.
Providers: voip.ms, freephoneline, smartcall.ro through asterisk. Hardware: Vonage VDV21, Moto VT2x42, Linksys SPA series, Grandstream HT series, Panasonic KX-TGP5x0


reply to SB6121
Thanks, he told me that he did turn off the power for a minute. But I don't know if he did a proper power cycle.

I guess the modem binding to his laptop's nic address is mostly likely what is wrong here?

There's also a config page in the SB6121 that has a factory reset option. I was thinking of trying that, if the proper power cycle doesn't work.

reply to SB6121
A power cycle of any time should be fine, the modem can have 2 devices connected/remembered anyway.
The problem might be with the router, it has to be setup for WAN DHCP.
It would help if we knew the router model.

Teddy Boom
k kudos Received
Toronto, ON
reply to SB6121
Rogers DHCP server remembers the MAC of anything connected to the modem. They will sometimes give out two IPs, allowing two different devices to be connected to the modem, but it is sometimes only one IP. That means you connect your computer, your computer's MAC is in Rogers DHCP server. When you connect the router, Rogers won't accept the router's MAC, and you get nothing.

If you leave the modem turned off for 5 minutes, or if you factory reset the modem, Rogers will forget everything about the above, and you can connect new devices.

Alternatively you can clone your computers MAC into the router, and to Rogers the two devices will look the same. That way you can switch between them without having to reset every time.


reply to SB6121
Thanks everyone. The modem is powered off now and which should be ample time to unbind the MAC once home from work.

The router seems fine as he is concurrently running Bell FIBE 16 through it and it's just plug and play with default dynamic settings after a factory reset.

As for the router, it's an ASUS RT-N10 it might actually be the RT-N10+, which would be great because DD-WRT can MAC clone if needed.

If the above doesn't work, we will log-in to the Motorola SB6121 Configuration Page and Factory Reset the modem.

Thanks everybody.

TSI Martin
Chatham, ON
If the laptop continues to be the only device that gets an IP address follow the follwing.

From modem to pc
launch a command prompt
type : ipconfig /release
Once IP is release, unplug power for modem
disconnect the coad cable, wait 5mins.
While modem is off plug RJ45 to router.
turn modem back on, plug coax back in
Wait for booting of modem & log into your router
check status & note the IP you receive.

If this still doesn't work, please let us know.
Feel free to send me a PM TSI Martin See Profile or post in the »TekSavvy Direct forum.

TSI Martin (Escalations / Social Media) - TekSavvy Solutions Inc.
Authorized TSI employee ( »»TekSavvy FAQ »Official support in the forum )
Follow me on Twitter : @TSIMartin


reply to SB6121
THANKS everyone! Problem solved! It's working now!

The modem was turned off all day until home from work.

It seems everyone was right in their suggestions above.

Hopefully this thread will help people out in the future.

Nepean, ON
reply to SB6121
Every time you switch the device that your cable modem is connected to you need to power cycle your modem.