dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
18340
share rss forum feed

spkay

join:2005-11-10
Princeton, MA
reply to Oregonian

Re: [Troubleshooting] MiFi 4620L Firmware Won't Update

Maybe just because i'm a software guy i'm more comfortable downloading the full update file and then running a local install. Mine worked fine, when I restarted it was all up to date.



Oregonian
Premium
join:2000-12-21
West Linn, OR

Where did you find the full update file?


jcharr1

join:2007-05-16
Monterey, LA

Yes, I'd love to know that too. I tried looking for it but never found anything.



Anon

@comcast.net
reply to spkay

lol what are you talking about? Please make more sense. What firmware are you on? Did you do OTA update? Or did you download the firmware somewhere that we all don't know of and manual updated the mifi?



Anon

@comcast.net
reply to spkay

Btw I'm pretty sure many of us thought of that already...so please stop praising yourself. We are stuck on trying to find the manual firmware file itself hence why we can't fix this problem yet.


jb11464

join:2010-05-30
South Plainfield, NJ

There is no available executable file from Verizon as of Thursday.
I spoke to Level 2 about sending out a file and installing via usb, but
they said that this was not what they were working on. All I could get from them was that they were working on the OTA problem and
that they do not have an ETA.

Basically they said to ignore the update notice.

I pointed out that during the "update" the green download bar indicated the firmware was being downloaded, but if you monitored the WWAN traffic status before, during, and after the file was supposedly downloaded, you would see that there was no activity - let alone 200Kbps of download traffic.



Oregonian
Premium
join:2000-12-21
West Linn, OR
Reviews:
·Comcast
reply to Oregonian

said by Oregonian:

I don't think that I have tried the USB cable to laptop route for the update. I've been trying to do it OTA. I will give it a try and report back.

Well, I tried the USB update route with no success.

I disabled wireless on my laptop and installed the 4620L USB drivers. I then tethered the 4620L to the laptop using USB. All good so far - internet access was still available. I logged into the 4620L and went to software update. As usual, it found the update and then I selected "Install". When the unit rebooted it still shows the old software version and shows that the update failed.

So I am back to waiting on Verizon or Novatel for an update that will work.


pdxsk

@auburnwa.gov

I posted a few weeks ago. Today, I have nine (9) more 4620L's to deploy in my organization. Now, when I try to do OTA update, in the admin pages and 'check for update', nothing comes up. The 3.20.03.01 doesn't show up. Maybe Verizon stopped trying to push it in preparation for a better, functional update?


jcharr1

join:2007-05-16
Monterey, LA

said by pdxsk :

I posted a few weeks ago. Today, I have nine (9) more 4620L's to deploy in my organization. Now, when I try to do OTA update, in the admin pages and 'check for update', nothing comes up. The 3.20.03.01 doesn't show up. Maybe Verizon stopped trying to push it in preparation for a better, functional update?

The strange thing is I've noticed that the update has stopped showing up on one of our mifis but it still shows up on the other one.

jcharr1

join:2007-05-16
Monterey, LA

Actually I have to take that back. Now neither of them are showing the update.



pdxsk

@auburnwa.gov

We're doing about 40 of these 4620L Mifi's at my company. I've been watching closely since my first post weeks ago. Last week, the update did show up...this week it does not.

I see Verizon still has the instructions on how to update to the 3.20.03.01 here: »support.verizonwireless.com/syst···20l.html if you look at the "Software update instructions", you'll see them mention that firmware version exactly.


jb11464

join:2010-05-30
South Plainfield, NJ

As an FYI, Novatel level 2 support said update will be out by month end, and the new version will be 3.20.03.10



Anon

@comcast.net
reply to pdxsk

Isn't that just the same exact thing we're all doing? OTA update basically?


jb11464

join:2010-05-30
South Plainfield, NJ

yup. They are combining the original .01 upgrade which has the
problem, along with the upgrade which was to follow, hence the .10 version.



Holbrook

@embarqhsd.net

All good information that gives me hope. Neither Verizon nor Novatel support has even acknowledged my e-mail questions about port forwarding. They didn't happen to mention whether the extra .09 version points include a fix for that, did they?



Anon

@comcast.net
reply to Oregonian

Its the end of the month and yet no update =[


jb11464

join:2010-05-30
South Plainfield, NJ

1 recommendation

For what it's worth...
Called Novatel Support Level 2 who now says new version is
3.20.10, is completed, and should be out by the end of November.
Also was told that notification of update will appear on MiFi unit itself, and can be installed directly from the unit without Web Interface.



Oregonian
Premium
join:2000-12-21
West Linn, OR

Thanks for the update.



pdxsk

@auburnwa.gov

All,

My organization ordered more 4620L's from Verizon. They don't sell them any longer...the 4620LE is what they sell they told us.

We received the 4620LE units...they are literally 4620L's, but with a double size battery! All they did was take 4620L's, put in a larger battery, then a double height battery door. The little label says "4620LE", but the firmware and management pages still show 4620L...hahaha.

Last week, I was unable to update the firmware as in the past. However, today I am not successfully getting, over the air, the update to 3.20.11. A few little things I've noticed are that now the unit, when connected to 4G, says "4G LTE Verizon" when it used to not have the LTE section. It also displays the MDN (phone number) of the device when you go to the information section on the device, where in the past it just gave you a URL for connecting to the unit.

Glad the update is finally working..I have faith now that the units will update. I am a little miffed though that the 40 or so 4620L's we bought the past few months now have the wimpy battery and anyone buying now gets a "4620L", but rebranded as a 4620LE with extended battery...

Cheers.



pdxsk

@auburnwa.gov

Correction to my last post, I mis-typed. We are getting 3.20.11 now. I used the word "not" in my post above..sorry. The update is now working for both our 4620L units and our new 4620LE units.



pdxsk

@auburnwa.gov

Here's the release notes on 3.20.11 from the Verizon website: »support.verizonwireless.com/pdf/···620l.pdf



Oregonian
Premium
join:2000-12-21
West Linn, OR
reply to Oregonian

Today I too was successfully able to update to firmware version 3.20.11.

Finally!



Oregonian
Premium
join:2000-12-21
West Linn, OR
reply to pdxsk

Looks like some worthwhile updates.

Thanks for posting.



Jim_in_VA

join:2004-07-11
Cobbs Creek, VA
kudos:4
reply to Oregonian

is that pushed to the Jet?



Oregonian
Premium
join:2000-12-21
West Linn, OR
Reviews:
·Comcast

I still had to go into the web interface and have it check for updates but then I didn't really give it time to find the update on its own. I just turned it on and told it to update. Worked for me the first time I tried it after many unsuccessful tries at the previous version of the update.



pdxsk

@auburnwa.gov
reply to Jim_in_VA

I did setup a 4620LE today, where it did just come 'over the air' to the device and it prompted me to update.


pioneer56

join:2008-03-21
Michigan
reply to Oregonian

Had to check a couple times, but it finally found the update and installed.


jcharr1

join:2007-05-16
Monterey, LA
reply to Oregonian

One small but nice change I noticed is that 1xRTT now actually shows up on the screen as 1X now instead of 3G. For some reason, one of my Mifis updated fine OTA, but the other I had to download and install over USB.


pioneer56

join:2008-03-21
Michigan
reply to Oregonian

Did anyone else notice that it is hard to turn the power back on when it is plugged into the charger without pressing the power button too long and restarting the unit or powering it off again? It doesn't do it when on battery only though.


jcharr1

join:2007-05-16
Monterey, LA

Yeah, I noticed that too. I thought mine were broken at first. It turns out that that it just takes a good bit longer between when you press the power button until it actually powers on if it's plugged in. If it's been plugged in for a while on the battery screen, then pressing the power button makes it come on immediately like normal. The delay happens if you either plug it in and immediately try to turn it on, or if it's plugged in, turn it off, and then immediately try to turn it back on again when the battery display comes up. Weird.