dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4854
share rss forum feed

sirovc2

join:2012-10-01
London, ON

Help!! SPA2102 can't recieve incoming calls

Hi all,

I've been at this for hours and am getting frustrated. I can make outgoing calls on my new VOIP (Freephoneline.ca)... no problem, works great. Incoming call however, go right to voicemail.

This is how I am set up: Modem (Teksavvy Internet) --> ATA (SPA 2102) --> Router (Netgear WNR2000)

Is this right or do I have the ATA and router in wrong order?

I have tried the static IP... I dont even get a dial tone. I forwarded my ports as per these instructions: »portforward.com/english/routers/ ... efault.htm

I still cant get it to work...

Should the ATA be running in bridged mode with this setup to bypass the router on the ATA?
I'm so confused, not the greatest with this stuff but can follow good directions.

Any help is much appreciated


Kyawa
Premium
join:2006-01-26
Middletown, MD
Need more info. Most modems from ISP are also routers. I also understand that the 2102 is also a router. Then, your Netgear is a router. You can't have 3 routers enabled. What about IP addresses for all of these devices?

sirovc2

join:2012-10-01
London, ON
I have everything set to DHCP... so not static IP. I tried the static IP route and the didn't work period. At least with DHCP I can make outgoing calls, but no incoming.

The modem is a Motorola SB5101
Too many routers, any thoughts on how to rectify. I thought switching the ATA to bridged mode would bypass the router at the ATA?


Kyawa
Premium
join:2006-01-26
Middletown, MD
You can only have one device set to DHCP. This is probably your problem. I'm not real familiar with the voicebox or your modem but you'll need to choose which device you want to use DHCP on and then disable DHCP on the other 2. It might be easiest to disable DHCP on the voice box and Netgear. If you need help with that, let me know.

sirovc2

join:2012-10-01
London, ON
I think if I choose Bridge on the ATA that will disable the router their... not sure on my Netgear though


Kyawa
Premium
join:2006-01-26
Middletown, MD
Correct. On the Netgear, just disable DHCP by going to the setup and the tab Lan Setup and unchecking the Use Router as DHCP server. Wire Modem to SPA 2102 to Netgear. If you have any hardwired PC's, connect them to the Netgear. Set up your wireless on the Netgear as well.

sirovc2

join:2012-10-01
London, ON
Thx. will give it a try


Kyawa
Premium
join:2006-01-26
Middletown, MD

1 edit
You need to make sure that the Netgear and Linksys LAN IP's are in the same subnet as well. A quick Google search found that the SPA2102 is 192.168.0.1. Set your Netgear to 192.168.0.200. You do that in the same place as disabling DHCP.

I don't think you need to do anything to the modem.

sirovc2

join:2012-10-01
London, ON
reply to sirovc2
Thanks. going to try tonight when i get home... fingers crossed


Kyawa
Premium
join:2006-01-26
Middletown, MD
I reread the thread and I don't want to confuse you. Again, I don't know how the VOIP SPA2102 works. Don't you have to put in your unique info to identify you? There has to be a way to identify you. Are you getting voice service from the same cable company that's providing your internet? I need to understand this so I can give you better definitive info.

sirovc2

join:2012-10-01
London, ON
no the internet company is a seperate provider. I am using freephoneline.ca for the voip. i do have a user name, password, etc. that i input into the ATA

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo

1 edit
May I suggest that you visit the VOIP Tech Chat forum? Someone there will be able to help you.

In the meantime I suggest you connect your modem to your router and then both your ATA and your PC to the LAN ports of your router. Then you can check whether your ATA is registered to your provider. You will not be able to receive phone calls until you achieve that.

Modem -> Router -> ATA and PC

--
DPC3825 - WRT610N - Panasonic KX-TGP500 - Asterisk 1.8.11.0 with Asterisk GUI on Virtual Server
Anveo - Voxbeam - Localphone - Numbergroup - Callcentric - VoIP.MS - UKDDI


Kyawa
Premium
join:2006-01-26
Middletown, MD
Just make sure you disable DHCP on the ATA and enable it on your Netgear. The LAN IP address philosophy still holds true. I did see where some ATA usere were using port forward. I have to believe Freephoneline gave you setup instructions.

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo
If you have the router connected to the modem and then the ATA connected to the router you don't need to worry about the DHCP on the ATA. Also, there is probably no need to worry about forwarding ports.

@OP what sort of router do you have?
--
DPC3825 - WRT610N - Panasonic KX-TGP500 - Asterisk 1.8.11.0 with Asterisk GUI on Virtual Server
Anveo - Voxbeam - Localphone - Numbergroup - Callcentric - VoIP.MS - UKDDI

sirovc2

join:2012-10-01
London, ON
reply to sirovc2
Thanks for all the tips and support. I got it sorted out last night.

I ended up tweaking the setup and now have it as follows:

Modem --> Router (Netgear) --> ATA (SPA 2102)

DHCP is on both the router and ATA... but I tweaked the audio configuration preferred codec from G729a to G711u and that seemed to fix the problem.

I can now recieve incoming calls... for the record very happy with this service and can now say goodbye to my phone bill.