dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
6233
share rss forum feed

rikahs

join:2012-10-01

VPN issues with Bell Sagemcom 2864

Hi,
Need help!!
At home I have Bell Fib 25 service with Sagemcom 2864 modem/router combo. All home devices work without issues.
I also now have a work laptop, windows 7 running Cisco Anyconnect VPN utility which I am forced to use by work. This laptop and VPN works everywhere in the world! hotels, other locations etc.
But when I connect to home network, internet ok, then I start VPN via Cisco Anyconnect, it establishes the VPN, no error message. But I cannot start any work application, like Outlook, SAP etc.. You can see how I am being a ping pong between Bell support and my work help desk, they are simply pointing to each other. My work system is a security freak so there is literally nothing I can do changing settings etc. I strongly suspect something is blocking on my router but Bell tells me that there is nothing blocking. I seem to remember my old work XP machine worked fine but I guess with this new combination (Windows 7 + Cisco Anyconnect + Sagemcom) something is not compatible.
PLEASE HELP !!


secotton

join:2005-03-30
North York, ON

Best thing I can suggest you try is changing the IP range you use at home.

What can happen, is lets say your IP range you use at home is 192.168.0.1, and this is the same range where a lot of the servers are at your office are, your client (Windows 7 laptop running VPN) gets confused thinking the servers may be on your own network, and not on the remote network (VPN).

Not exactly sure how to do this on the Sagemcom, but connect to it and see if there's a place to change the IP address on the local network. The most common 'defaults' are 192.168.0.x / 192.168.1.x / 192.168.2.x - the first two typically being used by businesses as well. Try changing it to 192.168.80.x or something, or better yet, 10.10.0.x. It can all be done without any special rights on your laptop - all it'll need is a reboot


rikahs

join:2012-10-01

Hi,
on my connection hub page, it says:
Start: 192...2.10 and end 2.254. Should I change start to 2.2? (it says router IP is 2.1)


secotton

join:2005-03-30
North York, ON

No - that's the DHCP range. If you can change the router IP, it would probably do the trick.

One other thing you should probably try, is from work, try


secotton

join:2005-03-30
North York, ON
reply to rikahs

Bingo - found it. Change the 'Router IP Address'. I found another thread with a screen shot - second screen shot found here --> »Sagemcom f@st 2864 and DMZ

By changing the Router IP Address, it should typically change the DHCP range as well, but you may have to do that as well before you save your changes.

I'd suggest you try 10.10.10.1, keep the same subnet mask (255.255.255.0), and set your DHCP to be 10.10.10.10 to 10.10.10.100 (no need for any more than 100 computers or so to be able to get an IP), then save the settings, wait for a bit to make sure the changes are applied to the Sagemcom. You'll need to reboot your computer once this is done to be able to connect back to the internet.


rikahs

join:2012-10-01

well, still not working....
I managed to change the router IP to 10... as suggested, the work laptop got the new IP after reboot, even put the work laptop IP to the DMZ, no change in status....

still no VPN... Internet works fine

Grrrrrr.

Pls help!!


droidman4

join:2005-12-12
Ottawa, ON
reply to rikahs

This could be related to the PPPoE overhead.

If the network you are connecting to is really anal about security they are probably blocking path MTU discovery , causing this to fail since the PC and server both expect the MTU to be 1500 when its actually 1492 and since some VPN solutions don't fragment, we'll that could easily explain your problem.

I had a similar problem with an application that used SIP, it broke if there was any fragmentation and showed the same symptoms you described. Once we allowed ICMP type 3 and 4 messages through the firewall, the program started working properly.

Tell that to your network admin, he should be able to test rather easily. If the above is your problem then there is nothing Bell can do about it, it has to be resolved by your admin.



Frank_IT
Premium
join:2003-11-01
Montreal
reply to rikahs

There is something wrong either with your cisco anyconnect or the ip range..

My mom use her laptop with anyconnect, and the sagemcom at home everynight to connect at work and its working..

but.. their office use 10.x.x.x ip's and her dhcp range at home is 192.xxx...

so check with your IT guys.. and ask them
--
Rogers - iPhone 4s 32gb


urbang33k

join:2010-02-13
Canada
kudos:1
reply to rikahs

For what it's worth, we use Nortel Networks Contivity VPN for access to work servers and I have no issues with my sagemcom.

NOW, I dont pretend to have nearly as much experience with VPNs as some of the other people in this thread. My question, directed more at the other VPN gurus here, would it be beneficial for the OP to establish a PPPoE session on his work laptop through his wireless interface (windows 7 - setup a new internet connection wizard), so that his work laptop gets a public ip for this?

Although if his laptop is so locked down, he may not be able to create one.
--
Opinions and ideas expressed in my post are my own and in no way represent those of Bell Canada Enterprises, Bell Canada, Bell TV, Bell Internet, Bell Mobility, Bell Technical Solutions, Expertech, or any other partners under the BCE umbrella.



anon

@bell.ca
reply to rikahs

Did it ever worked in this configuration? If not, what’s new? The laptop, Bell 25 connection, work from home with the laptop?

Your private (home) network should not be a problem even if you have the same subnet as your employer is using. Once a VPN connection is established everything goes through the tunnel and you can’t reach anything on your local network (otherwise it would be a security risk). When you make a VPN connection you get a new IP, new DNS servers, a new gateway (VPN server) and the routing table (laptop) changes.

Problem could be with the DNS or modem. Those from your help desk should have asked you (over the phone while you were trying to connect from home) to run ipconfig /all, route print, tracert (i.e. goole.ca and IP of goole.ca) before and after you connected your VPN client to troubleshoot your connection and pinpoint the possible problem.