dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
8062
share rss forum feed


Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2
Reviews:
·magicjack.com
·Skype

1 edit

2 recommendations

HCC GPU app close to going live IT HAS LAUNCHED

From WCG tech knreed

quote:
We have approved this beta to be released to production so we will be launching soon.
Have your GPUs standing by. This is going to be a game changer when it comes to team tasks completed and credits awarded.


basher99
Premium
join:2004-02-26
Pekin, IL

Re: HCC GPU app close to going live

interesting indeed... i only every got a few of the beta WUs over the last couple months but they seemed to fly



bbrcat
Cancer Sucks
Premium,MVM
join:2000-12-09
No.Conway,NH
kudos:3
reply to Nanoprobe

said by Nanoprobe:

From WCG tech knreed

quote:
We have approved this beta to be released to production so we will be launching soon.
Have your GPUs standing by. This is going to be a game changer when it comes to team tasks completed and credits awarded.

Bring it on !!!
--
Team
Discovery


Tychicus
Children are our most precious resource
Premium
join:2002-01-18
Helena, MT
reply to Nanoprobe

Does anyone know if this will work with an sli setup? I am currently running two 560 ti's.
--
Team Discovery



basher99
Premium
join:2004-02-26
Pekin, IL
reply to Nanoprobe

If my information is not outdated... and seti is any indicator... you must have SLI turned off so both cards can crunch... But my info is pretty old and I dont have any dual+ card rigs



glennaxl
Premium
join:2007-02-16
Zion
kudos:1
reply to Tychicus

said by Tychicus:

Does anyone know if this will work with an sli setup? I am currently running two 560 ti's.

Technically, it can run depending on BOINC version and driver version. For best results, you should disable it through the Nvidia cotrol panel; You don't have to remove the SLI bridge.


Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2

1 recommendation

HCC GPU APP HAS LAUNCHED. WOOOOOT



glennaxl
Premium
join:2007-02-16
Zion
kudos:1

Cannons are now pointed to HCC GPU



glennaxl
Premium
join:2007-02-16
Zion
kudos:1
reply to Nanoprobe

Re: HCC GPU app close to going live IT HAS LAUNCHED

anyone willing to try this as im going to bed now?

HCC GPU only app_info
runs 2 instance and .5 CPU

<app_info>
    <app>
        <name>hcc1</name>
<user_friendly_name>HCC1 6.56 Cuda</user_friendly_name>
    </app>
    <file_info>
        <name>wcg_hcc1_img_6.56_windows_intelx86__nvidia_hcc1</name>
        <executable/>
    </file_info>
    <file_info>
        <name>hcckernel.cl.6.56</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>hcc1</app_name>
        <version_num>656</version_num>
        <platform>windows_intelx86</platform>
<plan_class>nvidia_hcc1</plan_class>
        <avg_ncpus>0.5</avg_ncpus>
        <max_ncpus>0.5</max_ncpus>
        <coproc>
            <type>CUDA</type>
            <count>.5</count>
        </coproc>
        <file_ref>
            <file_name>wcg_hcc1_img_6.56_windows_intelx86__nvidia_hcc1</file_name>
            <main_program/>
         </file_ref>
        <file_ref>
       <file_name>hcckernel.cl.6.56</file_name>
        </file_ref>
    </app_version>
</app_info>
 


glennaxl
Premium
join:2007-02-16
Zion
kudos:1

1 edit
reply to Nanoprobe

HCC GPU Only app_info.xml (NVIDIA) - 2 Instances per GPU

<app_info>
    <app>
        <name>hcc1</name>
<user_friendly_name>Help Conquer Cancer</user_friendly_name>
    </app>
    <file_info>
        <name>wcg_hcc1_img_6.56_windows_intelx86__nvidia_hcc1</name>
        <executable/>
    </file_info>
    <file_info>
        <name>hcckernel.cl.6.56</name>
        <executable/>
    </file_info>
    <app_version>
        <app_name>hcc1</app_name>
        <version_num>656</version_num>
        <platform>windows_intelx86</platform>
<plan_class>nvidia_hcc1</plan_class>
        <avg_ncpus>1.0</avg_ncpus>
        <max_ncpus>0.783972</max_ncpus>
        <coproc>
            <type>CUDA</type>
            <count>.5</count>
        </coproc>
        <file_ref>
            <file_name>wcg_hcc1_img_6.56_windows_intelx86__nvidia_hcc1</file_name>
            <main_program/>
         </file_ref>
        <file_ref>
       <file_name>hcckernel.cl.6.56</file_name>
   <open_name>hcckernel.cl</open_name>
        </file_ref>
    </app_version>
</app_info> 
 

For ATI (not 100% sure as i don't have one),
replace
<plan_class>nvidia_hcc1</plan_class>
 
with
<plan_class>ati_hcc1</plan_class>
 

and

replace
 
<type>CUDA</type>
 
with
<type>ATI</type>
 


glennaxl
Premium
join:2007-02-16
Zion
kudos:1

1 recommendation

reply to Nanoprobe

1 instance results
Elapsed (Ave): 215 secs
CPU (Ave): 212 secs

2 instance results
Elapsed (Ave): 313 secs
CPU (Ave): 310 secs

+/-50% increase in results per day and points per day!



Slava
Premium,MVM
join:2001-02-04
Fair Lawn, NJ
reply to Nanoprobe

said by Nanoprobe:

This is going to be a game changer when it comes to team tasks completed and credits awarded.

This really will be a game changer, it will make many of us go out and get new video cards to get a little extra crunching in. this will also shift our focus for TDPH in focusing more on video cards then processors. It will also be a fairly cheap upgrade we can do to most of our TDPH blades that will really ramp things up.

In all this will be fun to see how it will develop and where we will go from here if it all works out.

Thank you for the update Nano.


Slava
Premium,MVM
join:2001-02-04
Fair Lawn, NJ
reply to Nanoprobe

By the way, is there a certain download that we have to make to have the GPU start to process tasks or does this automatically happen?

Where would we be able to see this (the GPU at work and crunching tasks)?

If you will, can you take a moment to walk us through?

Thanks, Slava


JimF
Premium
join:2003-06-15
Allentown, PA

1 edit
reply to glennaxl

Thanks very much. It works on an AMD card also (Radeon HD 7770), but I had to replace:
wcg_hcc1_img_6.56_windows_intelx86__nvidia_hcc1

with:
wcg_hcc1_img_6.56_windows_intelx86__ati_hcc1

(that is, just replace "nvidia" with "ati" on this line too).


Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2
Reviews:
·magicjack.com
·Skype

1 recommendation

reply to Slava

said by Slava:

By the way, is there a certain download that we have to make to have the GPU start to process tasks or does this automatically happen?

Where would we be able to see this (the GPU at work and crunching tasks)?

If you will, can you take a moment to walk us through?

Thanks, Slava

First thing is to check the list of non-compatible cards. You can find it here.
If you have any of the listed video cards in your computer they will not work.

Next I would highly recommend that if you're running a boinc version 6 that you update to the latest version 7.0.36. You can find the links for the 32 or 64 bit versions here. Version 6 had by far the most problems during beta testing. If you're still running a version 6 finish the tasks you have in cache, uninstall it and the install version 7. There some changes in version 7 that are a little different but they're very minor and I'll cover that later.

If you have a card that will work log on to WCG and click on the MY Grid tab. On the upper left side of the page select Device Manager. Select the device name that you want to run GPU tasks and open the profile of that device. Select only HCC from the available projects. Scroll down and put a check mark in the box next to If my computer can process work on my graphics card, then please send me work to run on my graphics card for the projects that I have selected above.

Next scroll down to Advanced options. If you want to receive both GPU and CPU tasks select yes from the Allow research to run on my CPU? option. I recommend you set that option to no for starters so you can get used to how your machine runs while it's processing GPU tasks. You can always change it later but be advised that running both will raise your power consumption and and temperatures. Scroll down to the bottom and hit the save button and you're done.

This note is for teamies that are running multiple crunchers using the same profile. If, for instance you're using the default profile option for all of your machines including the 1 (or more) that will be running GPU tasks you'll need to use a different profile (home, school, work) setting for your GPU crunchers because if you have selected the no option to run CPU tasks on your GPU crunchers and all of your machines use the same profile option then they will all stop receiving CPU tasks even if they are not running GPU tasks. I hope this is not too confusing. All it basically means is that you'll need separate profiles for GPU and non GPU crunchers.

That's basically it. If you have any questions fire away.

Just a FWIW. If you're looking to upgrade or purchase video cards this GPU app is better suited to run on ATI cards. It's not that they are better than Nvidia. The difference is ATI has much better driver support for OpenCL, which is the platform that the WCG GPU app runs on. I've heard rumors that Nvidia will be having better OpenCL support in the future but I don't know when that will be.
--
If Obama wins, America loses. Especially your children and grand children.
Government is not the solution. Government is the problem. Ronald Reagan
»boincstats.com/signature/-1/user···/sig.png



MacBridger
Late to the party
Premium
join:2001-01-11
Morgantown, WV
Reviews:
·Verizon Online DSL
reply to Nanoprobe

Nice breakthrough. It's convinced me to throw my old P4 back into the fray. I'm not sure how much she'll churn out, and it will only run when not in use. It is nice to be running multiple processes again. Yes, I am overdue for a new build...
--
The Goober (Formerly Mac Bridger)
Fight Cancer! Join DSLR's Team Discovery



basher99
Premium
join:2004-02-26
Pekin, IL

With my one GTX 560 i have seen my points gained double for the 1 day of gpu crunching so far... I wonder how long it will take to level out...

Rig:
AMDFX 4100 @ 4.32Ghz
8GB ram
GTX 560 driver 301.42



lilhurricane
Crunchin' For Cures
Premium,Mod
join:2003-01-11
Purple Zone
kudos:57
Reviews:
·Comcast

1 edit

2 recommendations

reply to Nanoprobe

..just a lil thank you - to all posting info for the team

I've been watching/reading/observing... and this is very exciting stuff.

I see MgKnight See Profile, Bob Sanchez See Profile, WLiley See Profile, JMartin See Profile, Old_Grouch See Profile and danny9 See Profile amongst others...

...just smiling down on us and nodding their heads...this will - indeed (as David so appropriately said earlier) ... be a game changer.

We'll need to incorporate some of this into our FAQ, so I hope anyone with desire to assist will please do so..
--
~Safe Hex~ Team Discovery ~ Project Hope ~ Like A Hurricane~



MacBridger
Late to the party
Premium
join:2001-01-11
Morgantown, WV
Reviews:
·Verizon Online DSL
reply to Nanoprobe

All the GPU units I've received have ended up with computation error. Any chance I'm doing something wrong? The list of unsupported GPU's list Geforce GT 420... I'm running a 430... Is the entire 4xx series toast or is it something else?
--
The Goober (Formerly Mac Bridger)
Fight Cancer! Join DSLR's Team Discovery



Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2
Reviews:
·magicjack.com
·Skype

1 recommendation

reply to Nanoprobe

Just a heads up for anyone using Windows XP. If you're using or planning on getting an ATI card do not use any driver version above 11.8. Seems there is no APP SDK support for XP in drivers above version 11.8 and without that runtime package your GPU will not run the tasks. If needed you can find the drivers here.



Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2
Reviews:
·magicjack.com
·Skype
reply to MacBridger

said by MacBridger:

All the GPU units I've received have ended up with computation error. Any chance I'm doing something wrong? The list of unsupported GPU's list Geforce GT 420... I'm running a 430... Is the entire 4xx series toast or is it something else?

Couple of suggestions.
If you're running it overclocked set it back to stock.
Make sure you have the latest drivers.
Make sure you're running a version 7 of boinc. Preferably 7.0.36
--
If Obama wins, America loses. Especially your children and grand children.
Government is not the solution. Government is the problem. Ronald Reagan
»boincstats.com/signature/-1/user···/sig.png



MacBridger
Late to the party
Premium
join:2001-01-11
Morgantown, WV
Reviews:
·Verizon Online DSL

Yes, I got 7.0.36 from Cal. I've never modded the card in any way. I am running XP SP3. Driver update was just released for it, so I'll try that and let you know. I'm itching to put this puppy to use!
--
The Goober (Formerly Mac Bridger)
Fight Cancer! Join DSLR's Team Discovery



Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2

Hope you get it working and they didn't leave your card off the unable to perform list by accident.



Tychicus
Children are our most precious resource
Premium
join:2002-01-18
Helena, MT
reply to Nanoprobe

I monitored my cards and it seems that I am up and downloading results with or without SLI enabled. Did not see any diff in time needed to complete a task.
--
Team Discovery



MacBridger
Late to the party
Premium
join:2001-01-11
Morgantown, WV

1 recommendation

reply to Nanoprobe

It seems to be working after updating the drivers. I have two tasks running, so it looks good.



glennaxl
Premium
join:2007-02-16
Zion
kudos:1
reply to Nanoprobe

I don't personally recommend 7.0.36 as this version is so conservative in getting tasks base on my experience.

I'm currently using 7.0.28



Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2

Switched to 7.0.28 and got a third app_info that works. Quadrupled the out put of my 7970. Thanks Glenn.


JoelC707
Premium
join:2002-07-09
Lanett, AL
kudos:5
reply to Nanoprobe

Sorry to sorta hijack the thread here but I have a couple of questions about this I was wondering if someone can help me out on.

What advantage does upgrading the client to 7.x give? I've been running the WCG client that's still on 6.10.58 and I appear to be crunching GPU WU's just fine but I haven't really looked into it to be sure.

What chance is there in AMD/Intel CPU+GPU devices in being able to crunch? No CPU+GPU chip is on the "not allowed" list but just because it's not "not allowed" doesn't mean it is going to work. I've done some preliminary digging and the Intel HD 2500 graphics DO support OpenCL. I can tell you the client does not currently see the Intel GPU but maybe I need Intel's SDK for OpenCL? It is enabled in the BIOS/UEFI and shows up in device manager.

My reason for asking this is while I have an add-in GPU, that graphics portion of my CPU (i5-3450) is sitting there unused. I had two thoughts on this. Since I have it set to not process GPU work while I'm using the computer (it REALLY drags down performance), I thought it could use the Intel GPU to help out.

Then, if that doesn't work as well as I'd hoped I could do some kind of hybrid SLI or whatever they call it now where it renders with the embedded graphics at low utilization or something and uses the add-in GPU for more intensive work. This isn't exactly what hybrid SLI or whatever was intended to address but if I could do normal surfing or whatever with the Intel chip and let boinc have the ATI card all to itself, that would be ideal.



Nanoprobe
Looking for cures in memory of Mom
Premium
join:2003-05-11
Crab Nebula
kudos:2

1 edit

Using the onboard graphics for surfing and a dedicated GPU for crunching is the best way to go if you have lag issues while running the tasks. IMHO.



Slava
Premium,MVM
join:2001-02-04
Fair Lawn, NJ

Click for full size
Click for full size
Click for full size
Click for full size
Total game changer!

I just made the install on my test PC running windows 8. Had to tinker a little. First thing I had to do was install Java 32/64 bit. Next I had to install newest driver as with whatever was on here it was coming back as computational error. After software was updated it is really going though the units like a knife going through hot butter.
Adding a few screen shots here, sorry for not taking the screen shots of the errors from earlier before everything was set up to run smooth.