dslreports logo
site
    All Forums Hot Topics Gallery
spc
Search Topic:
uniqs
5867
share rss forum feed


bakoma

@purdue.edu

Remote Desktop to home on Comcast

Remote Desktop to home on Comcast

My home ISP is Comcast. The connection is like: Comcast Modem->Router(Netgear wtg614v10)->PCS(XP)

I have one of the XPs [IP=10.0.0.5] enabled for remote desktop.
At home, I used another PC and tested mstsc /v:10.0.0.5, it worked.

Then on router, I port forwarded external port 70.71.72.73:3389 to 10.0.0.5:3389. Say my external IP(70.71.72.73), then I did a test mstsc /v:70.71.72.73, it did not work however. I can ping IP(70.71.72.73), it works. I tested port 3389 on IP(70.71.72.73) with »www.canyouseeme.org/, it has no connectivity.

BTW, I usually map my drive at work, say \\90.91.92.93 when my laptop(XP3) is connected to RoadRunner(different from work place). But when I take my laptop home and the previously mapped drive is not accessible and no longer accessible at \\90.91.92.93.

I am a company IT Admin with hardware/software for many years, but just stuck with Comcast at home. Can anybody give me a clue?


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
Reviews:
·Comcast
Most home type routers will not allow you to connect to the public IP and port of a port forwarded service from within the LAN.

As for the filesharing problems, the list of ports Comcast blocks on their network »customer.comcast.com/help-and-su···d-ports/

shows that both NetBios and SMB ports are blocked making Microsoft filesharing broken. Configure and use a VPN or other solution if you need to do that.


pflog
Bueller? Bueller?
Premium,MVM
join:2001-09-01
El Dorado Hills, CA
kudos:3
reply to bakoma
It may be that Comcast blocks the RDP port for residential connections, though I thought they did not.

Can you double check your firewall and forwarding settings? Some routers require you to both forward the port AND add it as an allowed port.

*Edit* And as graysonf See Profile said, if you're testing from an internal host, most commercial routers are not smart enough to allow connections to the external IP on the router from the LAN side.

But if you checked with an external web site, it sounds to me like the port forwarding and/or firewall rules are not working properly (or comcast is blocking that port, but I doubt it).

Oedipus

join:2005-05-09
kudos:1
reply to bakoma
I can attest that CC does not block RDP on their residential service. Sounds like your router is giving you the grief, though by the sounds of things it is configured correctly. That is, of course, assuming you're not trying to access the WAN IP from the LAN. you would need to configure a loopback or reflexive policy in order to do that.

AVonGauss
Premium
join:2007-11-01
Boynton Beach, FL
reply to bakoma
Comcast definitely does not block port 3389, though I would strongly recommend using another port as scanners regularly check for that port.


workablob

join:2004-06-09
Houston, TX
kudos:4
Reviews:
·Comcast
reply to bakoma
I used to do that.

However, I have moved to LogMeIn.com and I would recommend you do the same or use another similar free provider such as teamviewer..

There is zero router config involved.

Plus, you can have unlimited free connections for all the computers you want.

AND, it is much more secure via AES 256 bit encryption.

Dave
--
I may have been born yesterday. But it wasn't at night.


JigglyWiggly

join:2009-07-12
Pleasanton, CA
RDP works for me on Comcast.

To workablob, logmein sucks. No linux server support.
Pass


ArrayList
netbus developer
Premium
join:2005-03-19
Brighton, MA
for linux, use ssh + xserver


workablob

join:2004-06-09
Houston, TX
kudos:4
Reviews:
·Comcast
reply to JigglyWiggly
said by JigglyWiggly:

RDP works for me on Comcast.

To workablob, logmein sucks. No linux server support.
Pass

I assume you mean there is no support for remote controlling an MS host with Linux.

»www.makeuseof.com/tag/logmein-li···mputers/

LogMeIn far from sucks IMHO.

To each his own.

Dave
--
I may have been born yesterday. But it wasn't at night.


jubangy
Premium
join:2005-03-26
Corry, PA
reply to workablob
1. Teamviewer is not to bad either.

2. from insode your lan, you would have to connect to the private ip address of your rdp machine, not public.

3. Also make sure any software firewalls on your machine are set up right.

Also just for good measure must mention, the public ip does not go in the port box, just the 3389 does


bakoma

@purdue.edu
reply to workablob
I did use Webex, Logme, or Teamviewer. But I my new job does not allow me to install any software or run non-designated .exe.


bakoma

@purdue.edu
reply to ArrayList
One odd thing is that my router shows it IP as 192.168.7.2, while my IP on whatismyip.com is something like 70.71.72.73. I definitely tried mstsc /v:70.71.72.73 since 192.168.7.2 is reserved and not public.


baoqiao

@purdue.edu
reply to pflog
I forget to mention that I disabled my firewalls on either side. And I have exactly the same router used at other 2 other locations, they both allow NAS/RDP penetrating seamlessly. those working sites are MCI(T1) and RoadRunner.

Thanks for replying.


OldCableGuy

@planetcr.net
reply to bakoma
If your router is getting a 192 IP that's the problem, you're either not getting a public IP from Comcast, or your router is not directly connected to the internet.

Oedipus

join:2005-05-09
kudos:1

1 recommendation

reply to bakoma
Yeah, it kinda sounds like you're double NAT'ing.


NetFixer
Freedom is NOT Free
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage
reply to bakoma
What cable modem are you using? Comcast has started supplying cable gateways (modem/router combination boxes) to many users instead of simple cable modems. If you have one of those cable gateway "modems", you will probably need to put your wtg614's WAN interface into the cable gateway's software DMZ in order to try to get around the cascaded NAT problem. You could also try port forwarding the RDP port to the wtg614's WAN in the cable gateway box if RDP is the only outside access that you think that you would ever want to allow.
--
We can never have enough of nature.
We need to witness our own limits transgressed, and some life pasturing freely where we never wander.

Netkeys

join:2000-12-08
Fort Lauderdale, FL
Reviews:
·Comcast

1 edit
reply to baoqiao
Maybe your new employer is blocking your ports.

You might want to run Shields Up to check if the ports are blocked by your employer.

»www.grc.com/x/ne.dll?bh0bkyd2

LogMeIn can use a web browser but needs to load a plugin to work. Not a seperate program or exe file.

taz291819

join:2002-08-31
Huntsville, AL
Another vote for LogMeIn. Works like a champ.


beachintech
There's sand in my tool bag
Premium
join:2008-01-06
kudos:5
reply to bakoma
Sounds like you have a gateway device with a router already in it, then your router, then your computer. What model modem/gateway?
--
Ex-Tech at the Beach.
I speak for myself, not my former employer.


JJJohnson

join:2001-08-25
Fort Collins, CO
reply to bakoma
It's not blocked; I've been able to use remote desktop into my machines with no problems. I've used it do connect to Win XP Pro, W2i3 Server and Win7 Pro systems at home.

It's just a matter of correctly configuring your own router/firewall to port forward correctly. On my ZyWALL I have to both forward the ports and create a firewall rule to allow the traffic. If you want to be able to connect to more than one machine then you'll have to map a different external port for each machine.

What I do is allow external (password protected) access to the web configuration of the firewall. If I'm somewhere where I need RDP access into my LAN, I'll log in and grant that IP address permission. The RDP access itself is also password protected, as all machines require a user login for access. I'll later remove the firewall rule when it's no longer needed.


chong67

join:2001-11-18
Jonesboro, GA
reply to bakoma
I use logmein at work to get into my computer at home.

Since it is https, I will never get caught.

I love it.

AVonGauss
Premium
join:2007-11-01
Boynton Beach, FL
They may not be able to easily see what you're doing in the session, but I wouldn't count on them not knowing you're using it if they have a mildy competent admin.

Oedipus

join:2005-05-09
kudos:1
reply to chong67
said by chong67:

I use logmein at work to get into my computer at home.

Since it is https, I will never get caught.

I love it.

As an admin, I can say that we admins can definitely tell if someone is using logmein on our network.