dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1354
share rss forum feed

Haselmaier

join:2006-03-13
Fort Collins, CO

Faster Download Speeds With g Than With n

I have a Netgear WNR3500L wireless router. I assume it's v1 because on the back it doesn't have "v" anything. Firmware version V1.2.2.44_35.0.53NA.

When my laptop is connected to the router via g I get 22+Mbps download speed from my cable modem. When my laptop is connected to the router via n I get 10Mbps download speed.

This router allows a couple of different n settings - one for n and one for n or g. In both cases Win7 reports a faster connection to the router than when in g only. Be that as it may, when the laptop-router connection is faster than g I get a slower download speed.

I'm mostly trying to figure out where I should be focusing my troubleshooting efforts - on the router or on the laptop. Has anyone seen any behavior like this? I have done a little fiddling with the laptop card's settings - such as 802.11n Channel Width - but it hasn't resulted in improved results.

Thanks.

Jim



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

The simplest troubleshooting method would be to either test your notebook on another "n" network, or try another "n" wireless device with your router in order to find out if the problem is with the router or the notebook.

Without spending money on new equipment just for testing, you could perhaps visit a friend/neighbor and ask if you could connect your notebook to their WiFi network. They might also be amenable to trying their notebook/phone/tablet on your network to test your router.
--
We can never have enough of nature.
We need to witness our own limits transgressed, and some life pasturing freely where we never wander.


Haselmaier

join:2006-03-13
Fort Collins, CO

1 edit

D'Oh!!!!!

Why didn't I think of that? Thanks.................

I did a g/n test with another machine I have. Exact same results.

I'm off to dig into the router................. This really ticks me off to a pretty significant extent. This seems like a pretty basic thing for a router to be able to do - at least one that claims mixed mode operation.

Thanks for the suggestion!

Jim

P.S.: Someone in another forum suggested I experiment with different channels. After doing so I found one that delivers the
high throughput. Thx.



mozerd
Light Will Pierce The Darkness
Premium,MVM
join:2004-04-23
Nepean, ON
reply to Haselmaier

Your issue is YOUR wireless Client.

Find out which wireless client your laptop or whatever is using then determine if its compatible AND CAPABLE with your N wireless router.

COMPATIBILITY and CAPABILITY has many meanings. Your wireless client may be compatible with the b,g technology that the Netgear WNR3500L wireless router provides BUT may not be compatible with the N technology your wireless Client has chosen to support ASSUMING that your wireless client supports some form of N. In the N world N clients are not all equal. So if in fact your wireless Client does have N support then it all depends on which N and has that N capability been activated. In MS Windows You can check which wireless clients your laptop is using by going through device manage.
--
David Mozer
IT-Expert on Call
Information Technology for Home and Business



tucker8235

@bellsouth.net
reply to Haselmaier

Are you removing the wireless network and re-adding it when you change the network speed? I found that mine stuck at the g speeds even though it claimed it was at n speeds. Delete all wireless profiles and the join the n network.



zombiex1

@sky.com

This is interesting as I am having an almost identical issue. I get 3mb (adsl) with my netgear 934g router but if I plug in an N type router it drops to 1mb. I've tried 5 different routers including the new Sky hub, same thing happens. To test its not the desktop I've plugged in my laptop directly to the the main telephone socket (the desktop is on an extention) and still get the same issue. I have started a thread on this. SKy are scratching their collective heads on this one.
Al



zombiex1

@sky.com
reply to tucker8235

Sorry should have said. Its the line speed I'm talking about not the wifi speed.