dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
363
share rss forum feed

marvista

join:2006-10-06
Del Mar, CA

Problem with SPA2102 and new Dlink router version. NAT?

Click for full size
I am having trouble getting an SPA-2102 to work with a new Dlink router, and can't figure out what is going wrong.

I have this unlocked SPA2012 set up to work with google voice through simonics, and have had no issues with it working reliably.

However, I have had frequent problem with the internet going down, and its not clear where the problem is, but I'm running out of things to try and thought I would try replacing the router. So I'm trying a Dlink DIR615 version I1 to replace a Dlink DIR615 version B2.

My problem is that this SPA2012 will not work with the newer Dlink router. I've checked all the setting at least 3 times, and everything is the same. I've gone back and forth between routers multiple times, and its consistent. I also have another SPA2012 from a VOIP provider that is locked so I can't see its settings, but it works fine with both routers. I have tried forwarding ports (5060-63) to the SPA, no difference either way on either router.

I turned on debug and when it works with the older router the log entries look like this:

[0];tag=60519a048f7ec28ao0
To: Sandy ;tag=2007794180
Call-ID: e743145a-cf509a4e@192.168.15.104
CSeq: 44333 REGISTER
Expires: 3600
Contact: ;expires=3600
P-NAT-Refresh: 25
X-Real-Contact: sip:GVnnnnnnnnnn@99.107.233.194:5060
Server: GVGW
Allow: ACK, INVITE, BYE, CANCEL, REGISTER, REFER, OPTIONS, INFO
Content-Length: 0

[0]RegOK. NextReg in 3570 (1)
[1]RegOK. NextReg in 3570 (1)


When things fail with the newer router the log entries looks like this

[0]->199.30.56.194:5060(530)
[0]->199.30.56.194:5060(530)
REGISTER sip:gvgw1.simonics.com SIP/2.0
Via: SIP/2.0/UDP 192.168.15.104:5060;branch=z9hG4bK-e7c8f9b3
From: Sandy ;tag=54044038e2d7336fo0
To: Sandy
Call-ID: e743145a-cf509a4e@192.168.15.104
CSeq: 44323 REGISTER
Max-Forwards: 70
Contact: Sandy ;expires=3600
User-Agent: Linksys/SPA2102-5.2.3
Content-Length: 0
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
Supported: x-sipura, replaces

RSE_DEBUG: getting alternate from domain:gvgw1.simonics.com
[0]RegFail. Retry in 30
RSE_DEBUG: getting alternate from domain:gvgw1.simonics.com
[1]RegFail. Retry in 30


I can't find any description of what "getting alternate from domain" means, although I did see one mention of it and NAT. One difference between the working and non-working logs is "P-NAT-Refresh", although whether that is cause or effect I don't know.

Also the older router has some options for NAT Endpoint Filtering that are not on the newer router, although I don't recall ever changing them from the defaults. They are set to "UDP Endpoint Filtering:Address Restricted" and "TCP Endpoint Filtering:Port and Address Restricted".

I don't know enough about NAT to say whether that's significant, or whether things could be fixed with NAT settings on the 2102. Or anything else.

SPA config is attached also.

Thanks for any suggestions.