dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2
share rss forum feed


neonhomer
KK4BFN
Premium
join:2004-01-27
Edgewater, FL
reply to koitsu

Re: [hard drive] Cloned drive... now hanging issues

The only error the drive had was a "C5 - Current Pending Sector" with a count of 2 and "C6 - Uncorrectable Sector" with a count of 1. I had a couple of screenshots that I used when sending to Dell, but I can't find the damn things.

Bad thing was the old drive went out already. Ugh...

I'm trying to avoid a wipe and reload.

As for the AF... I ran Toshiba's Align tool (Paragon) on the drive, and it says that it does not need (or support) it.

Oh... I ran chkdsk on the drive as well... It supposedly fixed the issues it found. I'm waiting to see if the problem pops up again. So far, I haven't used my system enough today to see if it is doing again.

--
"F is for Fire that burns down the whole town...
U is for Uranium...... Bombs...
N is for NO SURVIVORS!!!!!" Sheldon Plankton

Keep Calm and Carry On



koitsu
Premium,MVM
join:2002-07-16
Mountain View, CA
kudos:23

That information helps a lot -- thank you very very much!

Attribute 0xC5 is what I referred to as "suspect" or non-readable LBAs. That means you had (actively) 2 LBAs which couldn't be read. So Spinrite telling you there were no errors is hilarious -- there were absolutely 2 LBAs (1024 bytes total) it couldn't read. These LBAs have not been remapped yet -- they're "pending" to be analysed by the drive, which as I described, is only done when a write is issued. Macrium should have told you the same. How a program handles an I/O (read) error is up to its code -- most tend to fill the unreadable portion with zeros. There is the possibility that the firmware on the drive is buggy (have seen this many times) and that the number (2) should actually be zero.

Attribute 0xC6 is a counter that tracks the number of sectors which when reading or writing to, failed. For reading, this means the ECC portion of the sector couldn't be read or couldn't be used to auto-correct the data. For writing this means a sector which is just downright screwed -- as in dust on the platter, a magnetic substrate anomaly (surface damage), or something along those lines.

Anyway, my point is (with attribute 0xC5) that there's a chance the lost/unreadable 1024 bytes of data could have resided in something like a device driver file, or something "key" to the OS itself thus causing you the problems you're having now. The only solution is a checksumming filesystem, or since there isn't one for XP, reinstallation. :-( I know, it sucks. This problem affects most OSes though, barring those with checksumming filesystems.

If you're at all concerned about the health of your current drive (the Toshiba), please install HD Tune Pro (trial version is fine; please do not use the Free version) and provide me a screenshot of the Health tab and I can tell you if there's anything anomalous there. You may need to resize the window to make sure all the attributes are shown.

Sorry I can't be of more help.
--
Making life hard for others since 1977.
I speak for myself and not my employer/affiliates of my employer.