dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
645
share rss forum feed

Balplanman

join:2006-08-30
Newtown, CT
kudos:1
Reviews:
·Charter

Uverse Newbie with Internet Questions

We had Uverse installed this week after many years with Charter cable. The TV works great and voice quality for Vonage is much improved.

However, the 12D/1U internet is peculiar. I am 4100 feet from the VRAD with an INID and 25K connection. I use Firefox and sometimes see delays bringing up a site, but this varies all over the place. Anywhere from a second to never. The spinner may hang with either CCW or CW rotation meaning that the problem occurs at various points in the process. Not repeatable, sometimes it works fine with a site and then an hour later it can't bring that site up. As an example, I logged in to ATT.com, entered my password and the next screen appeared and never progressed from there -- but most of the time this site works fine.

In an attempt to diagnose the problem I saw mention of UVrealtime so I went to that site and attempted to download the program. The download failed multiple times over a span of about 15 minutes, sometimes failing to start and other times stopping after partial download. An hour later it downloaded nicely.

I tried 3Dtracert and it shows packet losses mostly in ATT's network. So I tried the tracert on DSLreports, see:
»/pingtest/b888···/2960098

This shows the same thing, with losses in the ATT machines but says things are OK. I looked at reports from other Uverse users and most are similar so it's hard to say this is causing my problem.

But it is a problem. Viewing even short videos on Youtube is near impossible because often they either don't start or they hang part way through. File download failures as noted above are a particular concern.

I contacted ATT chat and they sent the tech back to check the installation. I attempted to download the UVrealtime file and it hung several times and then transferred successfully (all of which he saw), along with the 3Dtracert results and the XP tracert results. He made a screenshot and contacted his supervisor; they will look into it.

I'd like to figure out how to pin this down better since from the tech's perspective the installation is fine with no local problems apparent.

Any help would be appreciated.



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

In a trace route, packet loss on intermediary routers is common, and often not a problem. And if the destination ignores ping packets, even a trace which shows 100% packet loss is not a problem. So the best approach is to trace route to multiple sites and compare the results.

I should think 67 ms first hop latency is a bit high, even for interleaved. Here is a trace route showing typical first hop latency for an ADSL2+ connection set to interleaved, and what happens when the destination blocks ICMP (the standard Windows trace packet type):

C:\Dig>tracert www.msn.com
 
Tracing route to us.co1.cb3.glbdns.microsoft.com [131.253.13.140]
over a maximum of 30 hops:
 
  1     1 ms     1 ms    <1 ms  homeportal [192.168.42.1]
  2    26 ms    25 ms    26 ms  173-228-7-1.dsl.static.sonic.net [173.228.7.1]
  3    25 ms    24 ms    25 ms  gig1-4.cr1.lsatca11.sonic.net [70.36.243.13]
  4    24 ms    24 ms    25 ms  0.xe-5-1-0.gw.pao1.sonic.net [69.12.211.1]
  5    25 ms    33 ms    24 ms  0.xe-6-0-0.gw3.equinix-sj.sonic.net [64.142.0.185]
  6    26 ms    26 ms    26 ms  8075.microsoft.com [206.223.116.17]
  7    27 ms    30 ms    27 ms  ge-0-1-0-0.sjc-64cb-1b.ntwk.msn.net [207.46.40.221]
  8    27 ms    31 ms    26 ms  xe-7-2-1-0.by2-96c-1a.ntwk.msn.net [207.46.40.138]
  9    50 ms    48 ms    49 ms  ge-5-2-0-0.co2-64c-1a.ntwk.msn.net [207.46.40.84]
 10    48 ms    47 ms    48 ms  xe-0-0-0-0.co2-96c-2a.ntwk.msn.net [207.46.43.67]
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
...
...
 30     *        *        *     Request timed out.
 
Trace complete.
 

For comparison, here is a trace to Google:
C:\Dig>tracert www.google.com
 
Tracing route to www.google.com [74.125.224.116]
over a maximum of 30 hops:
 
  1    <1 ms    <1 ms    <1 ms  homeportal [192.168.42.1]
  2    26 ms    25 ms    23 ms  173-228-7-1.dsl.static.sonic.net [173.228.7.1]
  3    25 ms    24 ms    25 ms  gig1-4.cr1.lsatca11.sonic.net [70.36.243.13]
  4    25 ms    24 ms    24 ms  0.xe-5-1-0.gw.pao1.sonic.net [69.12.211.1]
  5    25 ms    25 ms    25 ms  0.xe-6-0-0.gw3.equinix-sj.sonic.net [64.142.0.185]
  6    26 ms    26 ms    27 ms  eqixsj-google-gige.google.com [206.223.116.21]
  7    26 ms    31 ms    26 ms  216.239.49.168
  8    27 ms    27 ms    27 ms  64.233.174.109
  9    26 ms    26 ms    26 ms  nuq04s08-in-f20.1e100.net [74.125.224.116]
 
Trace complete.
 

The MSN site loads fine.

A 67 ms first hop latency can indicate trouble anywhere between the modem/RG (CPE) and the first IP device (in traditional ADSL/ADSL2+, the aggregation router; not sure about IPTV/IPDSLAM network topology).

--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum

Balplanman

join:2006-08-30
Newtown, CT
kudos:1
Reviews:
·Charter

1 edit

Thanks for the reply. I agree that tracert is not a good tool for tracking down this type of problem.

The DSLreports tracert gives times from their starting point to my modem and I don't understand how they get 67ms as the first hop time. Measured with 3Dtracert from my end the first hop time averages 31ms but has a 38ms variance, see this screenshot:
»img840.imageshack.us/img840/9250···2401.jpg

XP's built in tracert shows similar times to those from 3Dtracert, i.e. about 30ms delay for the first hop.

Note the download attempts for Uvrealtime which fail at varying points in the process (but will work at other times). This is one manifestation of the problem. The other is intermittent very slow loading of sites - many seconds to never loading until I click again. And sometimes clicking a second time doesn't work.

I then ran 3Dtracert to the Uvrealtime site for a couple hours and saw over 200 lost responses (out of 1500 tracerts) at each of several hops - since we're both using Uverse all hops seem to remain in the ATT system. That is, the stalled downloads from Uvrealtime remain in ATT's system from end to end.

Uvrealtime shows about 4400 corrected blocks in the last 24 hours. To this newby, it seems unfortunate but not unreasonable -- the system is recovering errors without difficulty once or twice per minute.

I like the way the TV and Vonage phone work with Uverse and would really like to move away from Charter. But, the Uverse internet needs to work much more reliably than it presently does for us to stay with it.

EDIT: We don't use the phone a lot but now have seen difficulty with the phone as well as internet. We had one call drop while talking and two calls that didn't ring and went to voice mail.

I expected TCP to ensure that packets aren't permanently lost so I don't understand how or why downloads stall and sites don't come up without me seeing errors. I have gotten 502 and 504 Gateway errors on occasion while accessing DSLreports, errors which apparently are sometimes caused by lost packets.

Any thoughts on a (preferably free) tool to help locate the problem? Or will ATT handle this for me?