dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
52931
share rss forum feed

ejt2012

join:2012-11-10

How to setup xbox live for Uverse NVG510

I haven't seen very much helpful info for this problem on the internet, so I am going to put this step by step info up here to help people so they don't have to struggle with tech support for 3 hour to no avail like I did.

Step 1:

You have to access your modem. Start up a web browser (any one will do). Next go to the address bar and type 192.168.1.254 and hit enter. This will take you to the main interface for your box where you may access a number of settings for your modem. You will also be prompted to provide an access code which will be located on the box itself and labeled "access code"

Step 2:

Now, in order to allow for the changing of your NAT type from strict or moderate to open, you have to click on "Firewall." From here you have to click on the NAT/Gaming option which will take you to a page which gives you 3 registers: Hosted Applications, Application Hosting Entry, and Manage Custom Services.

Step 3:

Under Manage Custom Services, you have to click the Custom Services option. Here, there will be an empty Service Entry page with the options: Service Name, Port Range, Base Host Port, and Protocol.
Now, in order for your NAT type to change from moderate or strict to open for xbox live, which will allow you to connect to parties and games reliably, you have to create 4 individual custom services, and add them to the list.

Step 4:

You have to create 4 services, and I will layout the creation process below:

For the First one:

Service Name: Port 88 UDP
Global Port Range: 88-88
Base Host Port: 88
Protocol: UDP

Then click add,

For the next one:

Service Name: Port 3074 UDP and TCP
Global Port Range: 3074-3074
Base Host Port: 3074
Protocol: Both

Then click add,

For the next one:

Service Name: Port 53 UDP and TCP
Global Port Range: 53-53
Base Host Port: 53
Protocol: Both

Then click add,

For the last one:

Service Name: Port 80 TCP
Global Port Range: 80-80
Base Host Port: 80
Protocol: TCP

Then click add.

Now that you have all 4 custom services created they are in a list in front of you. Go down and click the return to NAT/Gaming button. This will bring you back to the page with the three registers.

Step 5:

This step requires you to be connected to xbox live through the modem on your xbox 360 system. On the modem module, under the register titled Application Hosting Entry, you have to open the drop down menu titled "Needed by Device." Under this there should be Several IP addresses or names. You have to check what the IP address of your 360 system is and then make sure that for each entry you select this address for adding the service. Select the xbox system ip and then move up to the drop down menu labelled "Service." This will bring up a huge list of stuff that you will not care about. You need to scroll down until you find the four services you created, which will have a star next to their name. Ensuring you have the xbox system IP selected, select each of the custom services and then add them to the list.

Now that all 4 of these services are added to the list, your xbox will recognize the ports as open and the NAT type as open. This will allow full connectivity to all aspects of xbox live with no trouble caused by a moderate or strict NAT type.

I hope this will help many people who are confused as to how to allow xbox full open NAT and the full xbox live experience while connected to the ATT Motorola NVG510 Uverse box.



ILpt4U
Premium
join:2006-11-12
Lisle, IL
kudos:9

You can also select your 360 for "IP Passthrough" mode on the NVG510, which would then open all ports to the 360, and actually pass the public IP straight to the 360, so there would actually not even be a NAT


krayzed896

join:2013-02-01
Modesto, CA
reply to ejt2012

This really helped! Thank you so much for this, I literally registered just to thank you, for making this simple tutorial!



SomeJoe7777

join:2010-03-30
Houston, TX
kudos:7
reply to ejt2012

Ports 53 and 80 are not necessary. You only need to open port 3074 for TCP & UDP, and port 88 for UDP.



Forosnai

join:2011-09-30
kudos:2
reply to ejt2012

2 mins for a web search > 3 hours on the phone. »www.att.com/esupport/article.jsp···4ptb8-GR



Nuckfuts
Premium
join:2003-10-18
Joliet, IL
reply to SomeJoe7777

said by SomeJoe7777:

Ports 53 and 80 are not necessary. You only need to open port 3074 for TCP & UDP, and port 88 for UDP.

According to Xbox LIVE he is right and I use this config also.

»support.xbox.com/en-US/xbox-live···box-live

If you have a firewall or network hardware, such as a router, you might need to make a configuration change in order for your PC or Xbox 360 console to communicate with Xbox LIVE. This configuration change is sometimes called “opening ports” or "port forwarding."
-------------------------------------------------------------------
Xbox LIVE requires the following ports to be open:

Port 88 (UDP)
Port 3074 (UDP and TCP)
Port 53 (UDP and TCP)
Port 80 (TCP)

Note If you cannot chat with someone using Video Kinect, you might need to open port 1863 (UDP and TCP).


SomeJoe7777

join:2010-03-30
Houston, TX
kudos:7

I am aware of what Microsoft says in their support articles. It's flat wrong. 53 and 80 are used for outbound-initiated conversations only (i.e. DNS client and HTTP clients run on the XBox, not servers), and therefore do not need inbound ports opened.

If you don't believe me, reconfigure your firewall to close ports 53 and 80 to the XBox and then join a game. You will see that your NAT type is still listed as Open, and that all game features work properly just like they did before.



Nuckfuts
Premium
join:2003-10-18
Joliet, IL

I am not saying I do not believe you but you might confuse some people since you did not explain that in the first place but thanks for correcting me. I was just going by what MS recommends.



DeadManSlave

@sbcglobal.net
reply to ejt2012

I tried that and when I get to adding in the ports I made it lets me put in 53 and 80 and then on the other 2 it says pinhole conflict detected and wont let me do anything. WTF??



chelgar

@sbcglobal.net
reply to ejt2012

Thank you for this tutorial! It is the first one that finally fixed my problem!!!


rorywisaac

join:2013-05-05
reply to ejt2012

I just tried it but I received a notification of "pinhole conflict detected XXX" Can anyone help me out with this problem?


s2Legion

join:2013-05-12
Colchester, CT

This is a great thread!

I tried using www.portforward.com to try to do this for my customers on some of my repairs, but the NAT would still stay moderate.

This will help me out along with all the other Techs I will tell about this in the CT area.

Thanks


beck121295

join:2013-05-22
Lombard, IL
reply to rorywisaac

I followed everything but could not add 3074 or 88 like the others. I found a solution that might have been all I needed to do in the first place.

On the Xbox in Network Settings, identify the IP address of your Xbox. Next, on your NVG510 page on the computer, under Firewall>NAT/Gaming select the drop down arrow next to Service, select Xbox 360 Live. Now select the drop down arrow next to Needed by Device and select the IP address of your xbox. Click ADD. Done.



Odawgsmash

@sbcglobal.net

This. I reconnected the cable from my xbox to the router and it showed the ip address in the dropdown menu. It all worked after that.



jimbo549

@sbcglobal.net

This didn't work for me. I tried all the steps listed. I open the ports manually following step by step the instructions above and I chose XBOX Live 360 in the hosted applications list. But, my xbox still shows moderate NAT settings.

Its really weird. Every time I turn the XBOX on and try to connect to live it won't connect. I think test the connection and it says it can't connect to the network. I think reboot the router and it connects. EVERYTIME I turn on the XBOX I have to reboot the router first to get it to connect to live.

Any advice?



silverjpd6

@sbcglobal.net

That is the same problem I am having! I did the steps listed above as well as making my allocation mode set to passthrough. Very Confused!



goody

@sbcglobal.net
reply to ejt2012

I followed the tutorial and when I went through with the xbox live connection test it still says my nat is moderate. I don't know what else to try. any ideas?



HaloCodPlaya

@cox.net
reply to ejt2012

THANK YOU SO MUCH!


CamSmith

join:2013-07-30

How can I open the same port for 2 Xbox's? Every time I try it says... Pinhole conflict detected XXX. Any suggestions?



whamel
billhamel .net
Premium
join:2002-05-09
Hinsdale, IL
kudos:10
Reviews:
·Verizon Broadban..
·AT&T U-Verse
·Comcast

said by CamSmith:

How can I open the same port for 2 Xbox's? Every time I try it says... Pinhole conflict detected XXX. Any suggestions?

Use DMZ mode to one xbox and the other xbox to port forwarding/triggering to the 2 ports listed, which is port 3074 Both UDP and TCP and port 88 UDP.
--
Bill - Hinsdale, IL - »www.billhamel.net


JMichael

@sbcglobal.net
reply to ejt2012

I am unable to find my Xbox's ip address and/or name in the "Needed by Device" drop box. I am connected to Xbox Live and have a solid four bar connection. Is there any way to mediate this problem?



Rush2112

@sbcglobal.net

My problem is that once I set Allocation mode to passthrough my Xbox 360 doesn't change it's NAT settings really, instead it won't even connect to the internet. And when I switch Allocation mode back to 'Off', it will connect back to the internet.

Bottom-line is that my NAT is still not Open.

I have a wireless connection if that means anything. Does anyone know what the deal is?



whamel
billhamel .net
Premium
join:2002-05-09
Hinsdale, IL
kudos:10
Reviews:
·Verizon Broadban..
·AT&T U-Verse
·Comcast

said by Rush2112 :

My problem is that once I set Allocation mode to passthrough my Xbox 360 doesn't change it's NAT settings really, instead it won't even connect to the internet. And when I switch Allocation mode back to 'Off', it will connect back to the internet.

Bottom-line is that my NAT is still not Open.

I have a wireless connection if that means anything. Does anyone know what the deal is?

What router equipment you use?
--
Bill - Hinsdale, IL - »www.billhamel.net


whamel
billhamel .net
Premium
join:2002-05-09
Hinsdale, IL
kudos:10
Reviews:
·Verizon Broadban..
·AT&T U-Verse
·Comcast
reply to JMichael

said by JMichael :

I am unable to find my Xbox's ip address and/or name in the "Needed by Device" drop box. I am connected to Xbox Live and have a solid four bar connection. Is there any way to mediate this problem?

Go to "Settings -> "System Settings" -> "Network Settings" on the XBOX menu, then click "Configure Network". Don't change the settings, but you can see your IP address, labeled "IP Address" under "IP Settings".
--
Bill - Hinsdale, IL - »www.billhamel.net


je6801

@sbcglobal.net
reply to ejt2012

Thank You Very Much!!!!



alex0904

@sbcglobal.net
reply to ejt2012

i did that but it says theres a pinhole error XXX or something like that