dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4814
share rss forum feed

jcremin

join:2009-12-22
Siren, WI
kudos:2

UBNT Disconnect Issue

I have never been a fan of UBNT as an AP because they are so dammed difficult to troubleshoot compared to Mikrotik. However, I do have one AP that I've been having issues with a few clients randomly disconnecting from for not apparent reason. I turned on the client log file and found the following when it just happened a few minutes ago. Can anyone translate for me what might cause the below issue?

Nov 19 16:36:31 wpa-supplicant: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Nov 19 16:36:31 wireless: ath0     New Access Point/Cell address:Not-Associated
Nov 19 16:36:31 wireless: ath0     New Access Point/Cell address:00:27:22:2A:EA:A3
Nov 19 16:36:31 wpa-supplicant: Associated with 00:27:22:2a:ea:a3
Nov 19 16:36:31 wpa-supplicant: WPA: Key negotiation completed with 00:27:22:2a:ea:a3 [PTK=CCMP GTK=CCMP]
Nov 19 16:36:31 wpa-supplicant: CTRL-EVENT-CONNECTED - Connection to 00:27:22:2a:ea:a3 completed (reauth) [id=0 id_str=]
 


CMack

join:2004-07-30
canada

can you post the connected client list?


Newbie

join:2011-04-18
reply to jcremin

Also what firmware are you on? They had a nasty re-keying issue with 5.2.1.


jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to jcremin

Click for full size
said by Newbie:

Also what firmware are you on? They had a nasty re-keying issue with 5.2.1.

said by CMack:

can you post the connected client list?

See attached screenshot. That should answer both questions.

The only potential issue I have is the noise floor. However, I have tried every channel, one by one, and while many of them have much better noise floors, the signals and/or performance is MUCH worse. I've been unhappy with this AP since the day I installed the RocketM2. I wonder if I should just rip it down and put a RB411AH back up there and try one of the MIMO 802.11n cards to see if that works better.

The only thing I really have to compare it with was a RB411AH with an XR2 running in 802.11b mode, which almost never dropped a single ping, but I wanted more than the 5mbps that it could supply. Right now with the Rocket M2 in a 10 mhz channel and with the few clients that are on this antenna, I'm getting about 10 megs on average. Once in a while it might peak at 14 or 15 megs, but that's pretty rare.

scobywhru

join:2006-12-29
Fresno, CA
reply to jcremin

Looks like it just disconnected from noise, the SNR isn't enough to have a reliable link, -77 noisefloor only gives 27db on a -50 link, I believe the RM2 has to have 30db for the highest speed. -50 is also a bit loud for a link but shouldn't be a problem as long as it doesn't get louder. Have you been able to identify where the noise is coming from? What antenna are you using with the RM2? What does the airview show for frequency usage? You might be able to find a cleaner piece of frequency by using an offset. With a link RX at 3.25mbps it is eating up a lot of airtime vs a 65.


jim_p_price7

join:2005-10-28
Henryetta, OK
reply to jcremin

Saw those same entries in a log file with a P2P link that kept disconnecting. Drove me crazy until I tried WEP instead of WPA. Problem went away, not sure why.


Newbie

join:2011-04-18
reply to jcremin

I dont believe i've seen a noisefloor like that with 10mhz CW... That is pretty tough.

The only thing I can think of that could improve the situation is possibly a shield kit if you do not have one.


johnk

join:2007-11-19
reply to jim_p_price7

said by jim_p_price7:

Saw those same entries in a log file with a P2P link that kept disconnecting. Drove me crazy until I tried WEP instead of WPA. Problem went away, not sure why.

Bingo.

I have seen this same issue in noisy situations.

For me, with WEP, everything was fine. With WPA2, I had random disconnects.
(once a day).

In my case, I had traffic shaping turned on the client.
When I turned it off, it solved the problem. Here is a thread on it:
»forum.ubnt.com/showthread.php?t=63545

So I think what happens is that with WPA and WPA2, there are timeouts
during the connection process. If a response isn't received in X milliseconds,
then the client disconnects.

With a high noise situation, these timeouts may happen with higher probabilty
(since there are more re-transmits happening). Likewise when you turn on
traffic shapping (since it slows down sending of packets).

At least that is my theory. I could be wrong, it wouldn't be the first time.

I consider this a bug. Not sure what Ubiquiti thinks.

John


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
reply to jcremin

Im gonna guess its noise, you are seeing its effects more, because you moved from the very robust 11b modulations to g/n modulations. Have you tried enabling airmax? Used channel shifting? I had one 10mhz AP that didnt work on any standard channel well, I shifted it down to 2464mhz and its perfect now.

If you go back to mikrotik, the 2 chain .11n stuff works well with ubiquiti, use 5.5.2, get rid off all the B rates, even the 6,9, rates in G mode go too. If your clients are all N clients, just enable N mode! Even better.

I found in noisy environments using channel shifting on mikrotik works well to slip in between noise just like you can with the RocketM

It took me a while, but I took a Mikrotik AP 411AH with a MIMO N card and 39 customers in terrible shape with mixed G/N clients and managed to get it working very well in the right channel/firmware/settings (RTS). Got calls from customers saying their voip has never worked better!

Sometimes you just have to spend a few hours with an AP

--
OptionsDSL Wireless Internet
»www.optionsdsl.ca


wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

Is there a reason why you aren't using Airmax?


jim_p_price7

join:2005-10-28
Henryetta, OK
Reviews:
·HughesNet Satell..
reply to johnk

said by johnk:

said by jim_p_price7:

Saw those same entries in a log file with a P2P link that kept disconnecting. Drove me crazy until I tried WEP instead of WPA. Problem went away, not sure why.

Bingo.

I have seen this same issue in noisy situations.

For me, with WEP, everything was fine. With WPA2, I had random disconnects.
(once a day).

In my case, I had traffic shaping turned on the client.
When I turned it off, it solved the problem. Here is a thread on it:
»forum.ubnt.com/showthread.php?t=63545

So I think what happens is that with WPA and WPA2, there are timeouts
during the connection process. If a response isn't received in X milliseconds,
then the client disconnects.

With a high noise situation, these timeouts may happen with higher probabilty
(since there are more re-transmits happening). Likewise when you turn on
traffic shapping (since it slows down sending of packets).

At least that is my theory. I could be wrong, it wouldn't be the first time.

I consider this a bug. Not sure what Ubiquiti thinks.

John

Correct - I too had traffic shaping on the affected link.

jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to scobywhru

said by scobywhru:

Looks like it just disconnected from noise, the SNR isn't enough to have a reliable link, -77 noisefloor only gives 27db on a -50 link, I believe the RM2 has to have 30db for the highest speed. -50 is also a bit loud for a link but shouldn't be a problem as long as it doesn't get louder. Have you been able to identify where the noise is coming from? What antenna are you using with the RM2? What does the airview show for frequency usage? You might be able to find a cleaner piece of frequency by using an offset. With a link RX at 3.25mbps it is eating up a lot of airtime vs a 65.

Most of my clients on almost all of my Mikrotik AP's have FAR less than 27db SNR, and none of them seem to have this problem other than some that are -80's signal, which is to be expected. It doesn't make sense to me why this tower (which has about the best overall signals of any AP on my network) would act up but not the ones that have twice as many clients, many with signals in the -70's and -80's.

I haven't yet tried doing an offset, partially because my own office runs on the connection and it is tough to mess with it during the day, when we've got VoIP phones and such, and partially because every change seems to take an eternity compared to doing it on an MT system.

If it is truly noise, I can't tell where it is coming from. The noise floor never changes more than a dB, and neither side seems to change at all whenever I have the disconnect issue. The part that seems most suspicious to me is the fact that when I change frequencies, signals get worse as noise floors get better. Makes me think that there's something wrong with the Rocket or the antenna. It's the same kind of thing I see on a 900mhz with a bandpass filter. Obviously the frequencies outside of the filter range have bad signals because the filter is doing it's job, but the noise floors are also better for the same reason.

jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to Newbie

said by jim_p_price7:

Saw those same entries in a log file with a P2P link that kept disconnecting. Drove me crazy until I tried WEP instead of WPA. Problem went away, not sure why.

Strange. Not sure why that would affect it.

said by Newbie:

I dont believe i've seen a noisefloor like that with 10mhz CW... That is pretty tough.

Same here. It's the only 2.4 AP on my entire network that has a noise floor reading that bad, and is WAY worse than the Mikrotik I had in place beforehand. And I'm not in a big city. I'm in a small village with a population of around 900 people. I have AP's that can see a LOT more and don't have nearly the troubles this one does.

jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to jim_p_price7

said by johnk:

In my case, I had traffic shaping turned on the client.
When I turned it off, it solved the problem. Here is a thread on it:
»forum.ubnt.com/showthread.php?t=63545

said by jim_p_price7:

I too had traffic shaping on the affected link.

The only traffic shaping I'm using is simple queues on a PPPoE concentrator, so nothing on the AP or CPE.

jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to wirelessdog

said by Inssomniak:

Im gonna guess its noise, you are seeing its effects more, because you moved from the very robust 11b modulations to g/n modulations. Have you tried enabling airmax? Used channel shifting? I had one 10mhz AP that didnt work on any standard channel well, I shifted it down to 2464mhz and its perfect now.

If you go back to mikrotik, the 2 chain .11n stuff works well with ubiquiti, use 5.5.2, get rid off all the B rates, even the 6,9, rates in G mode go too. If your clients are all N clients, just enable N mode! Even better.

I found in noisy environments using channel shifting on mikrotik works well to slip in between noise just like you can with the RocketM

It took me a while, but I took a Mikrotik AP 411AH with a MIMO N card and 39 customers in terrible shape with mixed G/N clients and managed to get it working very well in the right channel/firmware/settings (RTS). Got calls from customers saying their voip has never worked better!

Sometimes you just have to spend a few hours with an AP

Yeah, the "robustness" is the reason I used to use B-mode across my whole network. Since swapping this AP out for the Rocket, I have also migrated all the rest of my 2.4ghz AP's to a 10mhz 11g channels. I haven't seen the same thing on any of the rest of them, so unless there's a big difference between 11g and 11n where n is yet another step towards being susceptible to interference.

I'm pretty seriously considering swapping it back out to Mikrotik. I've never liked UBNT as an AP and I figured I would give it a try. Nothing but headaches to try to troubleshoot things. I'll spend a bit more time experimenting with this AP to exhaust all my options, but I'm assuming that in the end, I'll probably end up back with MT as the AP.

said by wirelessdog:

Is there a reason why you aren't using Airmax?

I did have it enabled awhile ago. Shut it off to see if it made a difference. Same speed, same latency, same disconnects. Didn't seem to help or hurt me much in this situation.

jim_p_price7

join:2005-10-28
Henryetta, OK
reply to jcremin

@Jcremin - Just for kicks, try a switch to WEP. I can't explain it, but that worked miracles for me and I don't know why.


jcremin

join:2009-12-22
Siren, WI
kudos:2

said by jim_p_price7:

@Jcremin - Just for kicks, try a switch to WEP. I can't explain it, but that worked miracles for me and I don't know why.

If I get a chance, I'll give it a shot tomorrow and report back. Except for my office, the rest of the accounts are residential and I'm at the time of day they are most likely to start hopping online, so I don't want to disrupt things right now.

And this issue isn't super urgent. It has been happening for awhile now and I tinker with it here and there. It does affect our office, though, and I hate getting a dropped call when the VoIP cuts out for a few seconds.

wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

Are you using all M series clients?


jcremin

join:2009-12-22
Siren, WI
kudos:2

said by wirelessdog:

Are you using all M series clients?

Yes, every single client is either an NSM2 or an NB2.

wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

RTS on or off?


OHSrob

join:2011-06-08
reply to jcremin

What signal level are you picking up other devices on the same tower.

If its stronger then -45 you will have signal overload when the other radios transmit if your using airmax.

Also throw airview on for a half hour or so and watch the noise floors peak.

Post the screenshot when your done of you can.

Don't run airview if you have a rocket titanium they have a firmware bug that breaks them. Ubiquiti is apparently working on it. (I thought it was a joke when I heard about it).

Also I've had great Luck with the 8mhz channel option in high noise. It dropped the noise on one site I have from -77dbm to -85dbm.

Edit: also if your on wpa-aes switch to wpa2-aes.

I did some work for one wisp he has a similar issue with rekeying, wpa2-aes fixed it. But his noise was -92 and he was on 5.2.


jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to wirelessdog

said by wirelessdog:

RTS on or off?

Off. I played around with RTS and CTS quite awhile ago, and it seemed to cause as many goofy things as it helped. For instance, older UBNT devices wouldn't let me connect to them if RTS/CTS was enabled and I was using WPA encryption. Goofy I know, but it created enough headaches that I finally abandoned it.

wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

I would focus on getting Airmax to work properly. You need some type of polling...


jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to OHSrob

said by OHSrob:

What signal level are you picking up other devices on the same tower.

If its stronger then -45 you will have signal overload when the other radios transmit if your using airmax.

Also throw airview on for a half hour or so and watch the noise floors peak.

Post the screenshot when your done of you can.

Don't run airview if you have a rocket titanium they have a firmware bug that breaks them. Ubiquiti is apparently working on it. (I thought it was a joke when I heard about it).

Also I've had great Luck with the 8mhz channel option in high noise. It dropped the noise on one site I have from -77dbm to -85dbm.

Edit: also if your on wpa-aes switch to wpa2-aes.

I did some work for one wisp he has a similar issue with rekeying, wpa2-aes fixed it. But his noise was -92 and he was on 5.2.

I know I don't have very many people on this AP, but won't AirView kick them off while it is running? I know that just spending some time flipping through channels a few times causes the phone to start ringing. If I were to run Airvew for more than 30 seconds or so, I'd probably want to do it at like 4am to avoid pissing off customers.

I suppose the 8mhz channel might be another thing to try. And I am on WPA2-AES. I wanted to make sure to allow for the full modulation if possible.

If I end up waking up in the middle of the night, maybe I'll try running some scans and see how they look.


Inssomniak
The Glitch
Premium
join:2005-04-06
Cayuga, ON
kudos:2
reply to jcremin

said by jcremin:

said by wirelessdog:

RTS on or off?

Off. I played around with RTS and CTS quite awhile ago, and it seemed to cause as many goofy things as it helped. For instance, older UBNT devices wouldn't let me connect to them if RTS/CTS was enabled and I was using WPA encryption. Goofy I know, but it created enough headaches that I finally abandoned it.

Really?

RTS is seen as a requirement if you ask me. And works well if you ask me.
--
OptionsDSL Wireless Internet
»www.optionsdsl.ca

wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

RTS is inferior to Airmax but one or the other is certainly needed.


jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to wirelessdog

said by wirelessdog:

I would focus on getting Airmax to work properly. You need some type of polling...

How important is it with only 8 clients? Most only have packages of 768k, and 1 meg, and I think one of them has a 1.5 meg service. Low bandwidth, small number of clients. I have a single polarity 2.4 ghz AP running 11g in a 10mhz channel in a more populated town with 16 clients on it, and virtually not a dropped ping. Like I said, I tried Airmax on and off, and it didn't seem to help any.

jcremin

join:2009-12-22
Siren, WI
kudos:2
reply to Inssomniak

said by Inssomniak:

RTS is seen as a requirement if you ask me. And works well if you ask me.

What settings do you use? I can always try turning it on again and see what happens.

said by wirelessdog:

RTS is inferior to Airmax but one or the other is certainly needed.

I've tried various polling protocols across my network (Airmax, nstreme) and some cases it helps, but it seems like most simply make the AP more susceptible to interference.

What RTS settings do you use? My assumption would be that you want one or the other, and not both, correct?

wirelessdog

join:2008-07-15
Queen Anne, MD
kudos:1
reply to jcremin

In noisy and high-usage environments Airmax seems to work fine. Back when I was using RTS I was using 256. More recently I tried 64 some say 1 which didn't work for me. Anything I have non-canopy uses Airmax now.


jcremin

join:2009-12-22
Siren, WI
kudos:2

Are you only using RTS or are you setting CTS as well?