dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1679
share rss forum feed

Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..

1 edit

Incredibly slow RDP

EDIT: Configuring RDP to listen on an alternate port (> 50000) seems to have been the cause of my problem. Back to standard 3389 and all is now well.

Really strange issue with slow RDP here. First day after switching from 75/2 to 45/4 was amazing -- loading webpages with animated ads via RDP was no longer a painful thing to do! But since that first day, RDP has been horribly slow, to the point where loading ANYTHING is a painful thing to do.

At first I assumed it was related to upgrades, since HU hasn't been enabled in my area yet so I figure sometime in the near future they'll be doing work to enable that, but today I just ran some tests and I don't think that's it anymore. Here's what I've tried:

1) Speed test while sitting at home PC = normal speeds -- so I'm definitely capable of high speeds

2) Speed test while remoted from work PC to home PC = 2.24mbit down, 0.51mbit up -- such a slow upstream makes RDP painful!

3) Speed test while remoted from home laptop to home PC = normal speeds -- so the problem isn't RDP specifically since this works

4) Repeated test #2, but disconnected RDP session immediately after starting = normal speeds

5) Repeated test #2, but minimized Firefox immediately after starting = normal speeds

So if I hide the test by either disconnecting or minimizing, things are fine. So my only guess is that my encrypted RDP sessions are being mistaken for P2P traffic, and the throttle is being applied?

Does this seem plausible? Any other ideas as to what the cause could be?


jack man

join:2011-03-25
Reviews:
·Start Communicat..

I work via RDP every day and have not seen any issues since the Extreme plus upgrade come up for my line.

Questions -- how are you connecting into the work RDP? Possibilities I know of are direct (ie work computer has a public IP), VPN (IPSec or PPTP or other), MS Direct Access or RD Gateway.

Generally, I work with an IPSec VPN. I do also sometimes connect with a PPTP VPN or my companies RD Gateway.

I have not seen any issues with any of these...


Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..

said by jack man:

I work via RDP every day and have not seen any issues since the Extreme plus upgrade come up for my line.

I'm trying to connect in the other direction. I'm at work and sometimes need to access my home computer to test something from an off-site location.

What you described is one test I didn't run earlier -- and so I just tested connecting from my home computer to my work computer (which does require connecting to an ipsec vpn), and that's working at full speed.

So Home -> Work is fine, but Work -> Home is dead slow.


mozerd
Light Will Pierce The Darkness
Premium,MVM
join:2004-04-23
Nepean, ON

said by Ree:

So Home -> Work is fine, but Work -> Home is dead slow.

You work network is the problem. Check with your work IT department and find out what is going on.

The easy thing to do is to make sure that at work you've cleared all caches, reboot and try again. If the problem still persists troubleshooting starts at the work network, router, switch, cables, ISP, workstation and your IT group manages that.
--
David Mozer
IT-Expert on Call
Information Technology for Home and Business

Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..

said by mozerd:

You work network is the problem. Check with your work IT department and find out what is going on.

Don't think that's it. Speedtest from work computer shows 150mbps up and down, so the work computer's internet connection is obviously fine.

I also just tested connecting from my work PC to 3 different off-site VPS servers I run, and all 3 connections run at full speed.

I just realized I'm running RDP on an alternate port at home though -- maybe the unknown port is being throttled by work or Rogers. I'll put it back to 3389 later and see if that changes anything.

Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..

said by Ree:

I just realized I'm running RDP on an alternate port at home though -- maybe the unknown port is being throttled by work or Rogers. I'll put it back to 3389 later and see if that changes anything.

Apparently that was it. And apparently the throttle is on Rogers' side. Just re-tested to confirm Work -> Home was still slow as shit (and it was).

Then I reconfigured Home to listen on 3389 and re-tested, and surprise surprise I got full speeds back!

So to find out who to blame, I then configured one of my VPSes to listen on the alternate port Home was previously using. Connected Work -> VPS, and all was fast.

So it seems like Work is happy to connect to an alternate port, which can only mean that Rogers is not happy to accept connections on an alternate port.

Who knows maybe Rogers thought it was malware since the port I chose wouldn't be normally used by anything legitimate, but if that's the case it would be good if they made that "feature" known!

resa1983
Premium
join:2008-03-10
North York, ON
kudos:10

said by Ree:

said by Ree:

I just realized I'm running RDP on an alternate port at home though -- maybe the unknown port is being throttled by work or Rogers. I'll put it back to 3389 later and see if that changes anything.

Apparently that was it. And apparently the throttle is on Rogers' side. Just re-tested to confirm Work -> Home was still slow as shit (and it was).

Then I reconfigured Home to listen on 3389 and re-tested, and surprise surprise I got full speeds back!

So to find out who to blame, I then configured one of my VPSes to listen on the alternate port Home was previously using. Connected Work -> VPS, and all was fast.

So it seems like Work is happy to connect to an alternate port, which can only mean that Rogers is not happy to accept connections on an alternate port.

Who knows maybe Rogers thought it was malware since the port I chose wouldn't be normally used by anything legitimate, but if that's the case it would be good if they made that "feature" known!

Rogers throttling more real-time traffic against CRTC ITMP rules.. Big shock there. My complaint seems to have died at Enforcements since Rogers announced in March they were killing throttling by the end of the year.

Ree9, you may have to play whack a mole with the port #s til the end of December, as they do tend to randomly start throttling a port you've used with RDP for a while.
--
Battle.net Tech Support MVP

Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..

said by resa1983:

Ree9, you may have to play whack a mole with the port #s til the end of December, as they do tend to randomly start throttling a port you've used with RDP for a while.

Good call. I was hoping this wouldn't be the case, but I just tried connecting to home from work again this morning, and it's slow as shit again.

Wonder if it's possible to change ports without rebooting by restarting a service or something...


creed3020
Premium
join:2006-04-26
Kitchener, ON
kudos:2
Reviews:
·TekSavvy Cable

RDP port is set in the Windows registry but it would be easier to setup your router with a static internal port of 3389 and then keep cycling the external port to something random. That could be scripted with PowerShell.

Either way you shouldn't have to play games to get good, stable performance.


zavar

join:2004-11-29
Kitchener, ON

An alternate is to RDP via an SSH session. I have SSH setup on my router and then use Putty to initiate the session. Doing this I haven't experienced any speed issues.


Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..
reply to creed3020

said by creed3020:

RDP port is set in the Windows registry but it would be easier to setup your router with a static internal port of 3389 and then keep cycling the external port to something random. That could be scripted with PowerShell.

Yeah I know how to set it, just didn't know how to make the change effective without rebooting (don't want to interrupt whoever might be using it at home). Turns out you can make the change effective without rebooting by disabling remote desktop and then re-enabling it (via the standard GUI dialogs). Of course you have to be at the local computer though (since you can't re-enable it remotely after disabling it!), so that's not too helpful.

And yeah, I used to control the port via port forwarding rules when I was with Teksavvy and using my own router. Now with the DPC3825 I don't seem to have that ability.

said by zavar:

An alternate is to RDP via an SSH session. I have SSH setup on my router and then use Putty to initiate the session. Doing this I haven't experienced any speed issues.

I used to connect to a VPN server at home before RDPing in, and I never had speed issues with that setup either. Makes me wonder if 1723 isn't ever throttled, so that's what I'm using as my RDP port now. If it gets throttled again, I may have to go back to the VPN setup.