dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1
share rss forum feed

Ree

join:2007-04-29
h0h0h0
kudos:1
Reviews:
·Start Communicat..
reply to creed3020

Re: Incredibly slow RDP

said by creed3020:

RDP port is set in the Windows registry but it would be easier to setup your router with a static internal port of 3389 and then keep cycling the external port to something random. That could be scripted with PowerShell.

Yeah I know how to set it, just didn't know how to make the change effective without rebooting (don't want to interrupt whoever might be using it at home). Turns out you can make the change effective without rebooting by disabling remote desktop and then re-enabling it (via the standard GUI dialogs). Of course you have to be at the local computer though (since you can't re-enable it remotely after disabling it!), so that's not too helpful.

And yeah, I used to control the port via port forwarding rules when I was with Teksavvy and using my own router. Now with the DPC3825 I don't seem to have that ability.

said by zavar:

An alternate is to RDP via an SSH session. I have SSH setup on my router and then use Putty to initiate the session. Doing this I haven't experienced any speed issues.

I used to connect to a VPN server at home before RDPing in, and I never had speed issues with that setup either. Makes me wonder if 1723 isn't ever throttled, so that's what I'm using as my RDP port now. If it gets throttled again, I may have to go back to the VPN setup.