dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1864
share rss forum feed

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

[WIN8] Homegroup question

I just got a Win8 laptop. I already have a Win7 desktop. Each system has 3 users with passwords. I would like each user to be able to access their own files on the other system, but not to be able to access the other two users' files. How can I set that up?

I set up the Win8 system with local accounts. I don't have any sort of Microsoft account, nor do I want one. I don't want a cloud solution, either.

Thanks...


Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3

I think there is an option to make User files private. I do remember seeing that option in the User Accounts section of Control panel.
--
Shooter Ready--Stand By BEEP ********


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to Bob4

One way that has worked since NT 3.1:

1) Use the same usernames and passwords throughout.

2) Don't use "homegroups" [yes, I genuinely didn't use homegroups in NT 3.1: they did not exist]

3) If the "simple file sharing" option still exists, turn it off. Simple file sharing is too complicated.


Shootist
Premium
join:2003-02-10
Decatur, GA
kudos:3

said by dave:

One way that has worked since NT 3.1:

1) Use the same usernames and passwords throughout.

2) Don't use "homegroups" [yes, I genuinely didn't use homegroups in NT 3.1: they did not exist]

3) If the "simple file sharing" option still exists, turn it off. Simple file sharing is too complicated.

1) Yes that is what I do.
2) Yes that is what I do.
3) Yes it certainly is.

In my first reply I was mistaken. There is NO Private setting in 7 as there was in XP. You'll need to do it with either encryption or permissions.
--
Shooter Ready--Stand By BEEP ********

Bob4
Account deleted

join:2012-07-22
New Jersey
reply to dave

OK, what is a homegroup supposed to do? (Maybe that's why I'm confused.)


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

Or maybe I should try the second choice here??

dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to Bob4

I'm not entirely sure, since I never felt the need for one (having grown up with the old-fashioned way). I think it permits access to shared public directories, the access being restricted to computers that know the homegroup password (i.e., which have joined the homegroup) and without requiring keeping all usernames and passwords in sync.

i.e., coarser-grained access control than individual usernames, but better than the 'everyone is a guest' model of simple file sharing.

Yes, the thing you want is 'use user accounts and passwords'. The bit about making them the same everywhere is so you never have to type them - there's a quiet handling of authentication if the username+password on your machine happens to work on the one you're connecting to.


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

2 edits

OK, I switched to the 'use passwords' setting, but it still doesn't work the way I want. Here's want I want:

Computer A             Computer B
Win7 Win8
Admin 1 Admin 1
User 1 User 1
User 2 User 2
Printer

• I want each person to be able to access their files on both the local PC and on the networked PC (passwords are the same).
• Users cannot access other user's files.
• Ideally, the admin should have access to all files, locally and via the network (I can live without the network access if I have to).
• Also, computer A has a printer which needs to be accessed from computer B.

I don't see why this is so difficult. No matter what I try, people have access to what they shouldn't or access via the network isn't available when it should be.

e.g., Admin 1 files are accessible to everyone on computer B, but they shouldn't be. So I turned off sharing, then Admin 1 can't access the files via the network.

Help, please! I'm ready to shoot myself in the head because it would be much less painful than dealing with this networking.

dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS

1 edit

What shares did you create?

I'm at a loss to explain why this is so difficult, since in my experience it isn't. Consistent user names and passwords; create shares on that which needs to be shared; ensure permissions are appropriate, the end.


Bob4
Account deleted

join:2012-07-22
New Jersey

I think it's because the computers belong to the same homegroup. I've come to the conclusion that homegroups are for wide-open access between users, which is not what I want.

So, it's time to get rid of the homegroup and try again.


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

4 edits

I killed the Homegroup, and now access is working exactly the way I want.

Only minor problem is that sometimes when the Win8 laptop goes to access the Win7 desktop, Win8 says that it can't access the Win7 system. The computer name shows up in Explorer, but clicking on it produces an error message. After about 30 to 60 seconds, then I can access it.

Are there any obvious settings that would cause this:



'Diagnose' doesn't find any problems.

There are no problems accessing files in the 'other' direction.


plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3

If I remember correctly, there was a modification made to the way Windows stores cached credentials (or maybe it was persistent connections) in regards to how things worked in Windows XP and how they worked in Windows 7 (and I would assume, in Windows 8 as well).

Does this happen just after a reboot of one or both systems? Or if you don't access the share for a long time, and then go back to access it again?

Now, I may be thinking of something else, but I kind of recall working with the AD team at my last company, and them having to change the login scripts for the drive mappings because of the way Windows 7 functioned compared to XP. I believe they had to verify that all drives being mapped were "persistent" so that the connection would remain open. If they did not do that, the users would get some kind of error (don't remember if it was the same as you got), but then if they tried it again, all was good.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail



norwegian
Premium
join:2005-02-15
Outback

1 edit
reply to Bob4

Try using the IP address of the computer, not the computer name - it seems there is a DNS resolution issue on the internal network - people were having this issue 2 or 3 years ago with Win 7.

This seems to have an explanation on what you see - »answers.microsoft.com/en-us/wind···657fe45c

Answer 11 off this link seems to help too, give it a try
»social.technet.microsoft.com/For···fb92082/

quote:
For what it's worth department. I tried ALL the above suggestions to no avail but in my case the following worked for my situation.

Go to Control Panel
Go to Credential Manager on each Windows 7 machine on the network
Under Windows Credentials, type in the name of each machine, username and password

It sounds too simple but it worked for me. The shared files and folders popped right up after this!
Although not for others, that's 2 options for you to test.

Some of the more tech people here maybe able to explain why or why not of this though.

--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online
reply to plencnerb

said by plencnerb:

Does this happen just after a reboot of one or both systems? Or if you don't access the share for a long time, and then go back to access it again?

It's NOT a one-time thing. There seems to be some sort of timeout. Once the connection is established, I can access the files OK. But after I leave it idle for some period of time (say, 5 minutes), the delay comes back.

Again, this is only on the Win8 system accessing the Win7 system. Win7 accessing Win8 has no delay.

Bob4
Account deleted

join:2012-07-22
New Jersey

I think I solved the problem. I uninstalled Classic Explorer (part of Classic Shell) on the Win8 system, and the problem went away. I'll keep my fingers crossed and hope that was the cause.


Bob4
Account deleted

join:2012-07-22
New Jersey

Nope, the problem wasn't solved. I'm still getting timeouts, but only when using the Win8 system to access files on the Win7 system.



plencnerb
Premium
join:2000-09-25
Carpentersville, IL
kudos:3

Click for full size
Again, I'm not one who has ever used a homegroup, I like to do it the "old school" way using usernames and passwords, and shares.

With that being said, how are you mapping your drives? There are of course many ways to do it in Windows 7 (and I would guess Windows 8 as well).

If this is something you always want to have connected, I would go into Windows Explorer, and click on the button for "Map Network Drive". I know in Windows 7, that is option near the top of the screen.

The screen that comes up when you do that is shown above (again, from Windows 7). I would then put in the full name of the share as shown below

• \\192.168.0.1\sharename
OR
• \\mymachinename\sharename

Then, make sure the box "reconnect at login" is checked. Also, if you want to connect using a different set of credentials (which would probably be the case unless you have the same username and password on the box you are trying to connect to), check that box as well. When you do that, you will be presented with a 2nd dialog box, where you will enter in the username and password that you want to use to connect. Make sure you enter the information for that box in the following format

Username: mymachinename\username
Password: password

Or

Username: 192.168.0.1\username
Password: password

Again, while the homegroup concept is suppose to make things easier on the end user and remove all these steps, it may be worth a shot to give this a try and see if it works.
You may also want to verify how your shares are setup as well (permissions and all that), on both the share itself, and the directories in the share for the user that is connecting in.

--Brian
--
============================
--Brian Plencner

E-Mail: CoasterBrian72Cancer@gmail.com
Note: Kill Cancer to Reply via e-mail

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

I'm not mapping entire drives, or even mapping any shares explicitly. I have the following on both PCs:

• No homegroup
• "Use user accounts and passwords to connect to other computers"
• "Turn on password protected sharing"

So when I connect to another PC by looking at the 'Network' hierarchy in File Explorer, I'll see:

Network
I7-860
Users
Bob
Documents
Pictures
User2
User3
Public
P850-ST3N02

Login is automatic, and access is restricted based on the user's permissions (e.g., User2 can't access Bob's files). This works fine and is exactly what I want, except the Win8 computer refuses to connect initially, and displays the 80070035 error. There's no delay on the Win7 computer.

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

So at the same time File Explorer is saying it can't access the other computer, I can ping the system using the network name:

C:\windows\system32>ping "i7-860"

Pinging i7-860 [fe80::8c99:ab4f:f65b:fefd%13] with 32 bytes of data:
Reply from fe80::8c99:ab4f:f65b:fefd%13: time=4ms
Reply from fe80::8c99:ab4f:f65b:fefd%13: time=4ms
Reply from fe80::8c99:ab4f:f65b:fefd%13: time=4ms
Reply from fe80::8c99:ab4f:f65b:fefd%13: time=4ms

Ping statistics for fe80::8c99:ab4f:f65b:fefd%13:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 4ms, Maximum = 4ms, Average = 4ms

C:\windows\system32>

So what can that tell us?


mmainprize

join:2001-12-06
Houghton Lake, MI
Reviews:
·Charter
reply to Bob4

The issue here is that the User1 account on each machine is not the same user1. If you were in a domain and used a domain login then user1 on any machine would be the same account and only one user1 account could be made.

User1 was made a local account on each machine. Like this
ComputerA\User1 and ComputerB\User1
so to access file on ComputerB from ComputerA you have to do one of these two things.

Either add ComputerA\User1 the the shared folder permissions on ComputerB

Or

When you try and map the drive or shared folder from ComputerB on ComputerA type in the user account from ComputerB like this ComputerB\User1 because ComputerA\User1 does not have access to the files on ComputerB


Bob4
Account deleted

join:2012-07-22
New Jersey

Except that:
1. Win7 can access Win8 with no problems.
2. Win8 can access Win7 after this initial timeout problem.

So access is permitted. If what you say is true, I would never be able to access files in either direction.



mmainprize

join:2001-12-06
Houghton Lake, MI
Reviews:
·Charter

said by Bob4:

Except that:
1. Win7 can access Win8 with no problems.
2. Win8 can access Win7 after this initial timeout problem.

So access is permitted. If what you say is true, I would never be able to access files in either direction.

1. Win7 can access Win8 with no problems.
This could be that Everyone or some other permissions were given that allows other users some access, but if you give the user you want to have access then you will not have problems with that user any more.

2. Win8 can access Win7 after this initial timeout problem.
I am not sure what that means, if it is working then you don't have a problem. If you want the shared folder and files to show up under "NETWORK" in file explorer then you need to have NETBIOS turned on in your network setting on the machine you want to see a listing from. So maybe turn it on on the Win7 machine. If it is on check the firewall setting as it might be blocking it.

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

It means when I access the other PC in File Explorer, I get an 80070035 error. After 30 to 90 seconds, I can then access the files. If it was a permissions problem, I wouldn't be able to access the files no matter how long I waited. Something's going on that's preventing the connection from working initially.

I can then continue to access the files. But if I stop and do other stuff, the access is lost after some period of time (5 minutes?) and I'm back to getting the 80070035 error.

NetBIOS is enabled, and I checked the firewall settings.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS

If I had this problem, I'd install Network Monitor (a network sniffer from Microsoft) and see what was happening on the network. But that requires a little knowledge of what's supposed to happen. How's your fault-finding expertise?

Basic test procedure is to start NetMon capturing all network traffic, do whatever you do and wait for it to fail, then stop capture and peer into the results.

I guess I could take a look at a trace for you, if the results don't say anything to you. I'd want you to post the binary capture file. I don't expect there to be any passwords visible; standard authentication is challenge-response, the actual password is not transmitted and therefore cannot be captured.


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

1 edit

said by dave:

How's your fault-finding expertise?

32 years of debugging real-time, embedded software.

OK, if I go to \\192.168.0.2\Users it works, even when \\I7-860\Users is failing. So that's something that Norwegian mentioned 3 days ago (sorry it took so long to get back to that!).

EDIT: I wonder if I should turn off TCP/IPv6.

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

If I access \\I7-860\Users, I get errors, but it eventually works.

If I access \\192.168.0.2\Users, it always works.

If I ping the Win8 PC from the Win7 PC, it uses IPv4.

If I ping the Win7 PC from the Win8 PC, it uses IPv6.

Hypothesis: The Win7 PC defaults to IPv4 DNS. The Win8 PC defaults to IPv6 DNS; It eventually times-out and reverts to IPv4 DNS, which works.

Proposed solution: Set Win8 to prefer IPv4 over IPv6.

See: http://support.microsoft.com/kb/929852

Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
DisabledComponents to 0x20


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

a reasonable hypothesis - verifiable with a sniffer



aa2k

join:2000-10-06
Damascus, MD
reply to Bob4

If you dont have any need for IPv6 you can disable it just fine but not only on the Network adapter, this just works but it does not actually 'kill' it per say..

To totally get rid of it you need to do a Registry change:

- Disable it first in the Network connection and then do the following:

* The following value will completely disable IPv6...
Value: 41ffffff

from:
http://support.microsoft.com/kb/929852

In Registry Editor, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters \

Key to add name: DisabledComponents
Value: 41ffffff

Note, If the "DisabledComponents" entry is unavailable, you must create it. To do this, follow these steps:

In the Edit menu, point to New , and then click DWORD (32-bit) Value .
Type DisabledComponents , and then press ENTER.
Double-click DisabledComponents .

Reboot

Easy way to test that it worked..
- before you add the registry ping itself, it would answer with the IPv6 IP
- after you add the reg key and rebooted, ping itself again, it should respond with the IPv4 IP.

EDIT: sorry Nyan Cat, you alreday posted it... oops!


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online
reply to Bob4

said by Bob4:

Proposed solution: Set Win8 to prefer IPv4 over IPv6.

See: http://support.microsoft.com/kb/929852

Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
DisabledComponents to 0x20

Well, that didn't work. I know the registry change was effective, because ping now uses IPv4.

I'll put the registry back and see if I can think of anything else.


aa2k

join:2000-10-06
Damascus, MD

Try the value: 41ffffff

this is not listed in the KB from MS but it does the job, done it many times.

More info here:
http://managedsurrender.com/wiki/doku.php?id=windows:ipv6

Dont forget to run this to check after you reboot:

To use the DisabledComponents registry value to check whether IPv6 was disabled, run the following command at a Windows command prompt:

reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters /v DisabledComponents