dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1818
share rss forum feed

Bob4
Account deleted

join:2012-07-22
New Jersey
reply to mmainprize

Re: [WIN8] Homegroup question

Except that:
1. Win7 can access Win8 with no problems.
2. Win8 can access Win7 after this initial timeout problem.

So access is permitted. If what you say is true, I would never be able to access files in either direction.



mmainprize

join:2001-12-06
Houghton Lake, MI
Reviews:
·Charter

said by Bob4:

Except that:
1. Win7 can access Win8 with no problems.
2. Win8 can access Win7 after this initial timeout problem.

So access is permitted. If what you say is true, I would never be able to access files in either direction.

1. Win7 can access Win8 with no problems.
This could be that Everyone or some other permissions were given that allows other users some access, but if you give the user you want to have access then you will not have problems with that user any more.

2. Win8 can access Win7 after this initial timeout problem.
I am not sure what that means, if it is working then you don't have a problem. If you want the shared folder and files to show up under "NETWORK" in file explorer then you need to have NETBIOS turned on in your network setting on the machine you want to see a listing from. So maybe turn it on on the Win7 machine. If it is on check the firewall setting as it might be blocking it.

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

It means when I access the other PC in File Explorer, I get an 80070035 error. After 30 to 90 seconds, I can then access the files. If it was a permissions problem, I wouldn't be able to access the files no matter how long I waited. Something's going on that's preventing the connection from working initially.

I can then continue to access the files. But if I stop and do other stuff, the access is lost after some period of time (5 minutes?) and I'm back to getting the 80070035 error.

NetBIOS is enabled, and I checked the firewall settings.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS

If I had this problem, I'd install Network Monitor (a network sniffer from Microsoft) and see what was happening on the network. But that requires a little knowledge of what's supposed to happen. How's your fault-finding expertise?

Basic test procedure is to start NetMon capturing all network traffic, do whatever you do and wait for it to fail, then stop capture and peer into the results.

I guess I could take a look at a trace for you, if the results don't say anything to you. I'd want you to post the binary capture file. I don't expect there to be any passwords visible; standard authentication is challenge-response, the actual password is not transmitted and therefore cannot be captured.


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

1 edit

said by dave:

How's your fault-finding expertise?

32 years of debugging real-time, embedded software.

OK, if I go to \\192.168.0.2\Users it works, even when \\I7-860\Users is failing. So that's something that Norwegian mentioned 3 days ago (sorry it took so long to get back to that!).

EDIT: I wonder if I should turn off TCP/IPv6.

Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

If I access \\I7-860\Users, I get errors, but it eventually works.

If I access \\192.168.0.2\Users, it always works.

If I ping the Win8 PC from the Win7 PC, it uses IPv4.

If I ping the Win7 PC from the Win8 PC, it uses IPv6.

Hypothesis: The Win7 PC defaults to IPv4 DNS. The Win8 PC defaults to IPv6 DNS; It eventually times-out and reverts to IPv4 DNS, which works.

Proposed solution: Set Win8 to prefer IPv4 over IPv6.

See: http://support.microsoft.com/kb/929852

Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
DisabledComponents to 0x20


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

a reasonable hypothesis - verifiable with a sniffer



aa2k

join:2000-10-06
Damascus, MD
reply to Bob4

If you dont have any need for IPv6 you can disable it just fine but not only on the Network adapter, this just works but it does not actually 'kill' it per say..

To totally get rid of it you need to do a Registry change:

- Disable it first in the Network connection and then do the following:

* The following value will completely disable IPv6...
Value: 41ffffff

from:
http://support.microsoft.com/kb/929852

In Registry Editor, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters \

Key to add name: DisabledComponents
Value: 41ffffff

Note, If the "DisabledComponents" entry is unavailable, you must create it. To do this, follow these steps:

In the Edit menu, point to New , and then click DWORD (32-bit) Value .
Type DisabledComponents , and then press ENTER.
Double-click DisabledComponents .

Reboot

Easy way to test that it worked..
- before you add the registry ping itself, it would answer with the IPv6 IP
- after you add the reg key and rebooted, ping itself again, it should respond with the IPv4 IP.

EDIT: sorry Nyan Cat, you alreday posted it... oops!


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online
reply to Bob4

said by Bob4:

Proposed solution: Set Win8 to prefer IPv4 over IPv6.

See: http://support.microsoft.com/kb/929852

Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
DisabledComponents to 0x20

Well, that didn't work. I know the registry change was effective, because ping now uses IPv4.

I'll put the registry back and see if I can think of anything else.


aa2k

join:2000-10-06
Damascus, MD

Try the value: 41ffffff

this is not listed in the KB from MS but it does the job, done it many times.

More info here:
http://managedsurrender.com/wiki/doku.php?id=windows:ipv6

Dont forget to run this to check after you reboot:

To use the DisabledComponents registry value to check whether IPv6 was disabled, run the following command at a Windows command prompt:

reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters /v DisabledComponents


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS

1 edit

41ffffff seems like it's leavng some things not disabled.

Here Microsoft suggests a value of -1 (ffffffff) to disable everythng.

»support.microsoft.com/kb/929852

Maybe those high-order bits have no assigned meaning, but at least all-ones is easier to understand as "everything is disabled".



norwegian
Premium
join:2005-02-15
Outback
reply to Bob4

said by Bob4:

said by dave:

How's your fault-finding expertise?

32 years of debugging real-time, embedded software.

OK, if I go to \\192.168.0.2\Users it works, even when \\I7-860\Users is failing. So that's something that Norwegian mentioned 3 days ago (sorry it took so long to get back to that!).

EDIT: I wonder if I should turn off TCP/IPv6.

I haven't done any research to say either way, but from the looking around I did there seems to be a local DNS issue with words over numbers, go figure...

However I wonder "how many times" as theorized elsewhere in the topic on this error, the dns cache is attempting 1 thing, where as the ip address does not require dns caching nor the service. There could be hosts files, large uncleaned dns caches etc that maybe influencing the resolving of the connection due to processing all the entries for a couple of theories.

I also wonder if allowing the IP address to be placed in the hosts file may help resolving too. I'm not network geek though.
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke


Bob4
Account deleted

join:2012-07-22
New Jersey
Reviews:
·Optimum Online

said by norwegian:

I also wonder if allowing the IP address to be placed in the hosts file may help resolving too. I'm not network geek though.

I added 192.168.0.2 i7-860 to the Hosts file, but it did not resolve the problem. ('ping', however, did use the specified IP address.)


norwegian
Premium
join:2005-02-15
Outback


It was a long shot.

I wonder if Defender is on in Win 8 too, have you tried disabling the firewalling and or anti virus to see what times are reported for the connection as well. I'm gathering it would have been first but I had to ask.
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke



norwegian
Premium
join:2005-02-15
Outback
reply to dave

said by dave:

41ffffff seems like it's leaving some things not disabled.

Here Microsoft suggests a value of -1 (ffffffff) to disable everything.

»support.microsoft.com/kb/929852

Maybe those high-order bits have no assigned meaning, but at least all-ones is easier to understand as "everything is disabled".

Was this tested at all?
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

I tested nothing - I just pointed out that Microsoft says to leave no bit unset. I don't know where the 41ffffff value originated from.



norwegian
Premium
join:2005-02-15
Outback


A little bit of confusion, your comment was directed at Bob4 See Profile and the topic. It seems a valid question.