dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
15922
share rss forum feed


Guest

@bell.ca
reply to maximeqc

Re: [Internet] Sagemcom 2864 port fowarding no longer working?!?

There was a new firmware that started rolling out this week. Is there any change in this matter?



maximeqc

join:2003-03-06
Quebec, QC
reply to Lucid

Same issue here where I can't access ressources when within the LAN.

Bell doesn't seem in a rush to fix this


sunnyd71

join:2004-05-22
l7z2t4
reply to Lucid

Same problem with me and it seems if I let my router do the PPPOE connection my speed maxes out at 32 Mbps on my Fibe 50 but if I have the router set to DHCP mode it works.


rampagerampa

join:2013-02-05

1 edit
reply to Bestman

Interesting. I get my modem login. I used to get the router log in which I disabled but with this new sagemcom all bets are off. It will not forward at all using dmz or ports or anything. I am just going to switch back to my old modem with old firmware and give this new one two thumbs down. Thanks for info tho.

Just went back to my old sagemcom and checked and it's set up the exact same way as the new one and the port forwarding works fine on the old one, so I think the new firmware is garbage on the 2864.


Bestman

join:2005-04-05
Quebec, QC
reply to rampagerampa

No, I do NOT have my router reserved on the Sagemcom. For some obscure reason I could not get it working when it was reserved. But it is set as DMZ.
I have DHCP enabled on my modem.
If I point a browser to my IP, I can communicate with my router if I enable the remote config option, so all is as I expect. Note that to test this, you need to be on an external network (my cell for example).
Hope this helps


rampagerampa

join:2013-02-05

1 edit
reply to Bestman

So do you have your router reserved? or set as DMZ? I have pretty much tried ever different combination without much success.
Do you have DHCP enabled on the modem?

If I point a browser to my IP also I get the modem log in, which I really do not like to see available to the rest of the world.


Bestman

join:2005-04-05
Quebec, QC
reply to rampagerampa

said by rampagerampa:

I have the sagemcom also with the latest firmware 6740S. It was replacing an older modem but the port forwarding is definitely broken. I use a router behind it and when I set the router as dmz and/or forward all the ports like I used to on my old sagecom it does not work at all. This thing is a piece of junk and suddenly bell wont 'support' port forwarding? very convenient.

I have my modem set as 192.168.2.1 and the router wan port set as 192.168.2.10 and then my router gateway is 192.168.1.1 and all the clients are 192.168.1.x.

This worked fine for years with my old sagemcom modem which I will be keeping.

Anyone have similar issues?

Hmm... Your setup looks a lot like mine, and it works correctly.
If I recall correctly, though, I could not set my router on the DMZ if I made a DHCP reservation for my router. The IP address I set in the DMZ would always be reset to nothing. Weird bug, but oh well... It works now, and I suppose (hope) the Sagemcom won't change my router's DHCP address since it's the only client apart from the set top boxes.

rampagerampa

join:2013-02-05
reply to Bestman

I have the sagemcom also with the latest firmware 6740S. It was replacing an older modem but the port forwarding is definitely broken. I use a router behind it and when I set the router as dmz and/or forward all the ports like I used to on my old sagecom it does not work at all. This thing is a piece of junk and suddenly bell wont 'support' port forwarding? very convenient.

I have my modem set as 192.168.2.1 and the router wan port set as 192.168.2.10 and then my router gateway is 192.168.1.1 and all the clients are 192.168.1.x.

This worked fine for years with my old sagemcom modem which I will be keeping.

Anyone have similar issues?


Bestman

join:2005-04-05
Quebec, QC
reply to Bestman

Forget about my saying that DMZ doesn't work. It's working fine now with BitTorrent...
I guess that'll be enough for me.


Bestman

join:2005-04-05
Quebec, QC
reply to Bestman

OK, so I tried the reset...
Immediately following the reset, my router was able to connect in PPPoE, and the connection stuck instead of being kicked out after a few seconds as before. I was able to browse the Internet using my router. Woo hoo!
So, I then configured the TV portion on the Sagemcom (as Rigor_M said, I selected "WAN Ethernet" and DHCP in the Advanced settings).
From then on, I could watch TV but my router got disconnected! Note that I had NOT entered the PPPoE credentials on the Sagemcom.

I then tried the DMZ setting on the Sagemcom, and that doesn't seem to work either?!? I'm pretty sure I done things correctly... but am I doing something wrong, or is it another bug? Does someone have the DMZ currently working?

Thanks


Bestman

join:2005-04-05
Quebec, QC
reply to Rigor_M

How about the default password? Anyone knows what that will be after a reset?
Also... I now realize that if I don't use the PPPoE credentials on the Sagemcom, We won't be able to use the features that use the Internet on our TVs. Don't know how that will go with the missus...
Damn, can't beleive Bell screwed this up!



Rigor_M

join:2010-09-26
Quebec, QC
reply to Bestman

check the config you have.. regarding the TV side of things, theres only 2 drop box, one on choosing "ethernet" and the other "DHCP"

take a snapshot of every possible page. if it dosent work, just redo the settings.


kovy

join:2009-03-26
kudos:8
reply to Bestman

said by Bestman:

Well... No, I haven't tried that. Are there some settings for the TV that will be lost, or is it risk-free?
Thanks

No idea on that part... sorry.

Bestman

join:2005-04-05
Quebec, QC
reply to kovy

Well... No, I haven't tried that. Are there some settings for the TV that will be lost, or is it risk-free?
Thanks


kovy

join:2009-03-26
kudos:8
reply to Lucid

What happens if you factory default the sagemcom and then try to bridge mode your router ?



Rigor_M

join:2010-09-26
Quebec, QC
reply to Bestman

Thats what happened to me.

you'll be able to connect in dual login for a couple of seconds and then, it wont work after a couple of tries. (your router's MAC must get banned)


Bestman

join:2005-04-05
Quebec, QC
reply to Rigor_M

To be able to circumvent bugs like this port forwarding issue with the Sagemcom, last week I decided to buy a router.
As discussed in another thread, I set up my router in PPPoE mode, setting the proper credentials. This setup seemed to work properly in my initial testing.
Now 2 days ago, I wanted to do my final setup... And it doesn't work anymore?! I saw in that other thread that dual PPPoE logins don't work anymore... So I removed the b1xxx user from the Sagemcom, rebooted everything, still no dice. I can see that the rooter connects, then disconnects after a few seconds.
Is this "normal"? Is there anyway I can get this working?
Thanks!



Rigor_M

join:2010-09-26
Quebec, QC
reply to Breezer

Just called technical support tonight and they said there was no updates to the firmware.

since last night, my stuff is not working anymore.

I have a bridged router on the sagemcom and the PPPoE stopped working. It was fine since june..

BTW, the DMZ IS NOT a solution to the brige mode. be warned. You may think its bridged but your personal router is getting a internal IP from bell's router and then, putting you on a second network.

a bridge mode lets your router have its own public IP (like the sagemcom) with your b1xxxx code installed.

and everything stop working.. again, thank you Bell



Breezer

@qc.ca
reply to Ph1L08642

It looks that the port fowarding works when you foward them to the DMZ.

Ex:
Sagemcom : 192.168.2.1
IP-Camera : 192.168.2.84

DMZ:
Enabled on 192.168.2.84

Port-Fowarding:
publicport(ex:50002) to privateport(8080) destination(192.168.2.84).

But the major problem with this is when you have more than 1 Camera or host you wan't to reach. Ie. RDP on your home computer + 2 IPCamera... you can't acces more than 1 of them.

I've been trying for more than a week to get my Dir-655 authenticate with pppoe and it keeps disconnecting over and over after 2-3 seconds. I've been able to get my internet working yesterday for about 20 minutes, but I only had 40/15 out of my 50/50 Internet's speed.

They have uploaded a new firmware and this is the reason why I want my Dir-655 to control all my internet.

I will try the pppoe (Dir-655) authentication with the real bridging method tonight and I'll keep you informed of the results.



Ph1L08642

@bell.ca
reply to Lucid

ok so here it is i am new with bell fiber 50/50 tried opening ports for ssh,ftp and others none of the ports are opened are opened.. from inside or outside. basically port forwarding is not working at all. tech came and changed the sagmcom router still no change. now i am wondering if i am not on a nated ip .... i have internet,phone and tv on this.. so i cant bridge my sagmcom....

note that i am not new to computers.. :P i know how to Port forward.. i even tried using dyndns,dmz but nothing at all works



rtangwai

@bell.ca
reply to Lucid

I have been experiencing the same problem, which is a royal pain in the ass as it prevents me from testing my SSL certificate for my personal web server. I have put in a call to Bell and they are sending a senior tech over to my place to see the problem and hopefully bring a modem with a newer firmware.

In the meantime, I have figured out a workaround I haven't had to use in 15 years. It's not perfect as it won't work on any device you don't have access to the HOSTS file, but it would work on Windows and Linux computers no problem. Simply put a line in with the internal IP of your server and your external address. For example:

192.168.0.2 myserver.com

This will override the problem because HOSTS files are checked before a DNS lookup is performed.



stx9

join:2005-01-25
Lévis
reply to vdsluser

A workaround is to setup an internal DNS with a tool called dnsmasq and overwrites (by adding an entry to host file) the external fully qualified host name so it resolves to a local IP.

In my environment, file dnsmasq.conf looks like this:
expand-hosts
stop-dns-rebind
bogus-priv
server=8.8.8.8
server=8.8.4.4
no-resolv

Last step is to set static DNS on all local machines so it points to server running dnsmasq.


vdsluser

join:2012-12-20
East York, ON
reply to nlap

Does anyone else have a solution to this problem that does not involve adding an extra device? My router (+ATA) are on a UPS (12vdc, no inverter) so adding an extra device will reduce my battery life by 50% (to first order) unless I upgrade the battery (fairly undesireable due to footprint limitations).

Barring a solution here, I'll try contacting Bell directly. This port forwarding limitation is unbelieavably stupid.


nlap

join:2012-12-19
Lachine, QC

1 edit
reply to Lucid

I'm upset at Bell for doing this firmware upgrade without notifying customers. I spent days trying to figure out why all of a sudden I was getting network connection errors to my IP cameras and other ports. Hours doing "factory resets" on gear, modems and re-configuring applications. It's only once I de-activated my iPhone's wi-fi (it then defaulted to the cellular carrier signal) that I noticed there was nothing wrong with the IP addressing. This lead me to the Sagemcom 2864 port forwarding and more hours of testing different settings on how to re-activate the use of external IP within the network (to no avail...).

Eventually the research led me here and I learn from OP Lucid of Bell's firmware upgrade and he can't forward ports either... over 10 days ago!! It's a good thing the Mayan predicted the end of the world tomorrow (December 21, 2012) otherwise I would have to find alternate means to end this misery !

The solution above by LeaveBell does work! If you use a second router and bridge it to your Bell connection hub (the Sagemcom), your second router will do the job of port forwarding correctly.

I can't thank both Lucid and LeaveBell enough for not only identifying the problem but also solving it. Oddly enough, I can also report that my internet speed is also faster using this methodology. I have Fibe12 and FibeTV. My tested speed is attached: 12.2 Mbps d/l and 1.5 on the upload (wired). I'm getting 11.75 Mbps d/l and 1.4 Mbps u/l on the wireless. Both these results are better than what I was getting from the Sagemcom 2864 prior to their messing up the port forwarding!

Again, thanks!

nlap

join:2012-12-19
Lachine, QC
reply to LeaveBell

I have the exact same problem... can't access ports (using external IP address) from within the network. Spent hours and hours trying to figure out why I was getting errors.

My firmware and rescue versions are exactly like yours and I WISH they would advise when they do an update as that would narrow down the troubleshooting.

My ports are accessible using external IP only when outside of my network. I hope we can regress a firmware upgrade...


ruggs

join:2012-03-26
Ontario

1 edit
reply to Hunter96

Fibe tv will not work in bridge mode, the sagecom needs to issue the set top boxes ip address for them to function properly.

And just because rogers is getting fiber doesn't mean prices are going down...
although that's what we all hope for and NEED



LeaveBell

@bell.ca
reply to Hunter96

Well, first make sure that your netgear is connected properly to the internet. Then take a note of your netgear's ip address. They try the DMZ setting. You may also try port forwarding instead of using DMZ.

Let me know how it goes. Good luck.

I don't know whether fibre tv would work this way as I did not subscribe to fibre tv. But try anyways, if it did not work, you can always revert back to your original setup. (ie, do the pppoe id/password on Sagemcom as your current setup_

Btw, just noticed that Rogers started offering FTTH (Fibre to the Home), which is boasting speed of 250Mbps/250Mbps download/upload in certain regions. I am excited to this new development.

I chose Bell at this stage because I ran home server and want a decent upload speed, download speed is not very crucial to me, as long as it's not below 10Mbps.

With Roger's FTTH, we could have more choices, hopefully better competition is better for us consumers.


Hunter96

join:2012-12-12
Terrebonne, QC

1 edit
reply to LeaveBell

Will the fibe tv still work with the sagecomin bridge mode??
for the DMZ how do you setup this? which ip adresse?
is the sagecom still the DHCP server or that will be also handle by the netgear..
I have the same router than you, netgear 3700v2



LeaveBell

@bell.ca
reply to Hunter96

Just a follow up on my previous message.

It's actually very easy to put SagemCom modem into Bridge mode, as it's described in my previous message. For this to work, you have to have your own router, in my case, I have Netgear 3700v1, I even noticed a slight speed increase over my previous setup.

This is my setup:

SagemCom (in Bridge Mode through factory reset) ===> NetGear 3700v1 Router (enter your pppoe id/password here, but not on SageMCom) ===> Reset of Computers/Server/Devices/TVs...
In SageMCom, I did use DMZ to forward all the traffic to NetGear, but I did nothing else.

I can access my home server both at home and away from home.

The only catch is you need a second Router which supports pppoe setup.


Hunter96

join:2012-12-12
Terrebonne, QC
reply to a_mckie

Btw I'm Mat...

I notice a couple of changes

1- on the internet setup page a new option is available. " DHCP FLUSH" which will clear all the devices that once connected to your network.
2- the default setup for Fibe is now WAN instead of PPOE