dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
15386
share rss forum feed


rtangwai

@bell.ca
reply to Lucid

Re: [Internet] Sagemcom 2864 port fowarding no longer working?!?

I have been experiencing the same problem, which is a royal pain in the ass as it prevents me from testing my SSL certificate for my personal web server. I have put in a call to Bell and they are sending a senior tech over to my place to see the problem and hopefully bring a modem with a newer firmware.

In the meantime, I have figured out a workaround I haven't had to use in 15 years. It's not perfect as it won't work on any device you don't have access to the HOSTS file, but it would work on Windows and Linux computers no problem. Simply put a line in with the internal IP of your server and your external address. For example:

192.168.0.2 myserver.com

This will override the problem because HOSTS files are checked before a DNS lookup is performed.



stx9

join:2005-01-25
Lévis
reply to vdsluser

A workaround is to setup an internal DNS with a tool called dnsmasq and overwrites (by adding an entry to host file) the external fully qualified host name so it resolves to a local IP.

In my environment, file dnsmasq.conf looks like this:
expand-hosts
stop-dns-rebind
bogus-priv
server=8.8.8.8
server=8.8.4.4
no-resolv

Last step is to set static DNS on all local machines so it points to server running dnsmasq.


vdsluser

join:2012-12-20
East York, ON
reply to nlap

Does anyone else have a solution to this problem that does not involve adding an extra device? My router (+ATA) are on a UPS (12vdc, no inverter) so adding an extra device will reduce my battery life by 50% (to first order) unless I upgrade the battery (fairly undesireable due to footprint limitations).

Barring a solution here, I'll try contacting Bell directly. This port forwarding limitation is unbelieavably stupid.


nlap

join:2012-12-19
Lachine, QC

1 edit
reply to Lucid

I'm upset at Bell for doing this firmware upgrade without notifying customers. I spent days trying to figure out why all of a sudden I was getting network connection errors to my IP cameras and other ports. Hours doing "factory resets" on gear, modems and re-configuring applications. It's only once I de-activated my iPhone's wi-fi (it then defaulted to the cellular carrier signal) that I noticed there was nothing wrong with the IP addressing. This lead me to the Sagemcom 2864 port forwarding and more hours of testing different settings on how to re-activate the use of external IP within the network (to no avail...).

Eventually the research led me here and I learn from OP Lucid of Bell's firmware upgrade and he can't forward ports either... over 10 days ago!! It's a good thing the Mayan predicted the end of the world tomorrow (December 21, 2012) otherwise I would have to find alternate means to end this misery !

The solution above by LeaveBell does work! If you use a second router and bridge it to your Bell connection hub (the Sagemcom), your second router will do the job of port forwarding correctly.

I can't thank both Lucid and LeaveBell enough for not only identifying the problem but also solving it. Oddly enough, I can also report that my internet speed is also faster using this methodology. I have Fibe12 and FibeTV. My tested speed is attached: 12.2 Mbps d/l and 1.5 on the upload (wired). I'm getting 11.75 Mbps d/l and 1.4 Mbps u/l on the wireless. Both these results are better than what I was getting from the Sagemcom 2864 prior to their messing up the port forwarding!

Again, thanks!

nlap

join:2012-12-19
Lachine, QC
reply to LeaveBell

I have the exact same problem... can't access ports (using external IP address) from within the network. Spent hours and hours trying to figure out why I was getting errors.

My firmware and rescue versions are exactly like yours and I WISH they would advise when they do an update as that would narrow down the troubleshooting.

My ports are accessible using external IP only when outside of my network. I hope we can regress a firmware upgrade...


ruggs

join:2012-03-26
Ontario

1 edit
reply to Hunter96

Fibe tv will not work in bridge mode, the sagecom needs to issue the set top boxes ip address for them to function properly.

And just because rogers is getting fiber doesn't mean prices are going down...
although that's what we all hope for and NEED



LeaveBell

@bell.ca
reply to Hunter96

Well, first make sure that your netgear is connected properly to the internet. Then take a note of your netgear's ip address. They try the DMZ setting. You may also try port forwarding instead of using DMZ.

Let me know how it goes. Good luck.

I don't know whether fibre tv would work this way as I did not subscribe to fibre tv. But try anyways, if it did not work, you can always revert back to your original setup. (ie, do the pppoe id/password on Sagemcom as your current setup_

Btw, just noticed that Rogers started offering FTTH (Fibre to the Home), which is boasting speed of 250Mbps/250Mbps download/upload in certain regions. I am excited to this new development.

I chose Bell at this stage because I ran home server and want a decent upload speed, download speed is not very crucial to me, as long as it's not below 10Mbps.

With Roger's FTTH, we could have more choices, hopefully better competition is better for us consumers.


Hunter96

join:2012-12-12
Terrebonne, QC

1 edit
reply to LeaveBell

Will the fibe tv still work with the sagecomin bridge mode??
for the DMZ how do you setup this? which ip adresse?
is the sagecom still the DHCP server or that will be also handle by the netgear..
I have the same router than you, netgear 3700v2



LeaveBell

@bell.ca
reply to Hunter96

Just a follow up on my previous message.

It's actually very easy to put SagemCom modem into Bridge mode, as it's described in my previous message. For this to work, you have to have your own router, in my case, I have Netgear 3700v1, I even noticed a slight speed increase over my previous setup.

This is my setup:

SagemCom (in Bridge Mode through factory reset) ===> NetGear 3700v1 Router (enter your pppoe id/password here, but not on SageMCom) ===> Reset of Computers/Server/Devices/TVs...
In SageMCom, I did use DMZ to forward all the traffic to NetGear, but I did nothing else.

I can access my home server both at home and away from home.

The only catch is you need a second Router which supports pppoe setup.


Hunter96

join:2012-12-12
Terrebonne, QC
reply to a_mckie

Btw I'm Mat...

I notice a couple of changes

1- on the internet setup page a new option is available. " DHCP FLUSH" which will clear all the devices that once connected to your network.
2- the default setup for Fibe is now WAN instead of PPOE


a_mckie

join:2012-08-31
East York, ON
reply to LeaveBell

Aside from this unpopular change, does anyone know what the firmware update was actually intended to accomplish?

-A



Mat

@cae.com
reply to Lucid

I'm kind of happy to see that i'm not the only one in this situation..

I my modem got the update over the weekend to:
Firmware version: FAST2864_v6740S
Rescue Version: FAST2864_v7740S

Here is the situation, we have Fibe tele and internat at home.
The wife started a small business so I created a web page that runs on an APACHE server at home and I also setup a HMAIL server on the same computer.

Everything was working fine until last weekend. From behind the modem I was unable to verify the web page (by typing my domain name or IP adress) and we could not connect on the mail server anymore (using outlook or mobile device)..

I logged on the mail server and check the log and saw my wife business partner accessing the server to retreive mail from her home!!

then I enter the local IP adress of the APACHE server, and the page appeared! I also check from my job and confirm the page is up and running without any glitch.

That's when I realized that from behind the modem, acessing a ressource behind the modem from the net, I was block by the modem (a logging page from Bell requesting a username and password)

So last night, in order to fix the email problem I changed the mail server setting.. I replaced the mail.**.ca mail server name by the local IP adress... and it's working!

So it's a temporary fix cause with mobile device will endup changing the mail server everytime we leave home..

nice thing I found out last night also...

Apple product (Ipod Touch) let you setup to account with the same email adress (but with different server name)

while the wife Android smartphone prevent you from creating 2 accounts with the same email address...



Jack_Bauer

join:2012-06-30
Boisbriand, QC
Reviews:
·Bell Sympatico
reply to Lucid

I hope Bell will fix this problem soon, I have the same problem on FTTH in Quebec with my Apache server too.

Fuc**** firmware update!!!
--
Connexion: Bell Internet Fibe 50 Mbps / 50 Mbps
Speedtest Fibrenoire: »www.speedtest.net/result/2308738992.png



LeaveBell

@bell.ca
reply to LeaveBell

Found more information from another internet site, after read that, I happened to talk to someone very knowledgeable from Bell.

[3:34 PM] Casey (260066) I kindly recommend you to bridge the connection hub modem and then connect the netgear router and then connect all the devices.
[3:34 PM] Casey (260066) To attain the bridge modem please click on 'reset' on the factory reset.

So how to do the above? I read the following from redflagdeals dot com:

" How to put the bell modem into bridge mode?
hit the factory reset button at the bottom.
this will clear the username and password fields in the modem for internet and tv and replace it with the default bell tech admin credentials.
wait until the modem reboots and you have 2 solid blue lights on sync and internet.
then plug in your own router which you should have already have put your bell pppoe credentials... into ANY sagencom LAN port and have your router set to autodial.
wait for your router to establish the connection and voila you have net."

There you go, guys. I haven't tried yet, but I will try as soon as I got the time. I have wasted too much time today.



LeaveBell

@bell.ca
reply to LeaveBell

Okay, this is what I have figured out. My wife can access the web server from work with no problem. After dinner, we went to McDonald to have coffee, I accessed the home server, it's working as well. So as some suggested, at home, one cannot access the web server with the external address, it will simply invoke the SageCom administration interface, but from an external ip, one cannot invoke the SageCom administration interface.

Stupid SageCom, just to confirm, are we all on the same firmware?

Firmware version: FAST2864_v6740S
Rescue Version: FAST2864_v7740S

Just to clarify, I never did a firmware update, so it must be done automatically by Bell/SageCom.

Thanks guys.



LeaveBell

@bell.ca
reply to Lucid

Could you please share how to make your port forwarding work?



LeaveBell

@bell.ca
reply to damnre

Yeah, same here. I have been talking to bell tech support whole day, the end result is: "we don't officially support Port Forwarding...Blah Blah Blah..." We only care about whether your internet is working or not...

Hehehe... Very nice response...



damnre

@bell.ca
reply to yds

Me same problem!! Freaking bell!


yds

join:2011-03-31
Toronto, ON
reply to Lucid

I just noticed this problem too. I can't access any of my port-forwarded services (webcams or webserver) when I'm on my network without directly accessing their lan addresses. This is a pain in the butt. Think Bell will fix this?



stx9

join:2005-01-25
Lévis
reply to Lucid

Same problem here. On port 80, I get Sagemcom web interface instead of my local Apache server. From work (through VPN), port forwarding works.



Lucid

@bell.ca
reply to quanin

said by quanin:

You may want to double check to make sure your port forwarding settings are still there. The update, if that's what it was, took mine out. Also, strangely enough, you can't test port forwarding from behind the modem. Or, at least, I can't anymore. Need a purely outside connection a la canyouseeme.org or somesuch to test.

Thanks for the reply. I ended up trouble shooting this issue last night. Port forwarding still works - but (as you stated), it does not work behind the modem. Very annoying when you're trying to test network setting.. Hopefully they fix this bug on the next update.

quanin

join:2008-03-02
Ottawa, ON
reply to Lucid

You may want to double check to make sure your port forwarding settings are still there. The update, if that's what it was, took mine out. Also, strangely enough, you can't test port forwarding from behind the modem. Or, at least, I can't anymore. Need a purely outside connection a la canyouseeme.org or somesuch to test.



Lucid

@bell.ca

[Internet] Sagemcom 2864 port fowarding no longer working?!?!

Seems like my Bell Canada Sagemcom 2864 modem received a firmware update which broke port forwarding. Anyone else experiencing this problem?