dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3053
share rss forum feed

conitssap

join:2012-08-13

[Voip.ms] Cant answer incoming calls

I have an unlocked D-link VTA-VR and using it with Voip.ms
My router is an Linksys E1200 –I have been playing around with my settings for the last month but haven’t had any success
The problem I have is that incoming calls keep ringing on the callers end when I pick it up and all I get is silence on my end – after x amount of rings it goes to voicemail.
If I make an outgoing call or if If the person tries again the 2nd or 3rd time the call will go through. But if the phone is idle say for 15-20 minutes the same thing happens again
I have flashed my router to dd-wrt tried port forwarding, DMZ, qos, triggering – even switched it over to tomato because I thought ddwrt may be a problem – same issues with tomato. I then even tried my backup pap2t NA-V2 ata and has the same exact problem.
Finally I plugged it into modem directly and same thing once again – really don’t know what the deal is here as I think I have tried everything possible
I can make outgoing calls and they are crystal clear – and when someone calls in and I can answer the calls are great too – its just that when the ATA is idle for more than 15 minutes the first 2-3 calls cannot be answered
Voip.ms support hasn’t been of much help - so help would be appreciated as I really don’t know what more I can do.

PX Eliezer70
Premium
join:2008-08-09
Hutt River
kudos:13
Reviews:
·callwithus
·voip.ms
After the 15-20 minutes have gone by, does your ATA show as registered or unregistered?

Both in terms of what the ATA itself reports, and in terms of the device status shown on the Voip.MS dashboard.

And are you using ATA settings such as (if applicable):

Nat Keep Alive: Yes
Nat Mapping/Traversal: Yes
Register Expires: 180
Proxy Fallback Intvl: 180

On the Voip.MS dashboard, under Account Settings--->Advanced, do you have NAT set to Yes?

conitssap

join:2012-08-13
the ATA's always show as registered - I have switched from toronto->montreal->chicago but that hasnt helped
i also feel that its a NAT problem but both ATA's dont have any Nat settings I can play around with
and i have NAT set to yes on voip.ms

PX Eliezer70
Premium
join:2008-08-09
Hutt River
kudos:13
Reviews:
·callwithus
·voip.ms
Hmmm.

Well, try a softphone anyway. If there is no issue there that would even more suggest a NAT problem.

-------------------------

For test purposes you could also sign up for a free "IP Freedom" account from CallCentric.

»www.callcentric.com/rate/plans/ip_freedom/
»www.callcentric.com/support/devi···sys/pap2

You can make outbound test calls by calling 1-777-123-4567.

You can do an inbound test by using SipBroker. Using a DIFFERENT phone line, call the SipBroker access number in Toronto which is 1-647-476-FREE. When you hear the welcome message, dial [*462-1-777-xxxxxxx] which is [*462] followed by your 1777xxxxxxx CallCentric account number, to call your own phone.

See if this problem occurs with CC or not.

conitssap

join:2012-08-13
k...will try that and report back later

conitssap

join:2012-08-13
reply to PX Eliezer70
So far the softphone has been working fine – waited a couple hours in-between calls and all incoming calls have been good
I will let the softphone idle all night and see what happens in the morning just to be sure
Ill give the callcentric route a try tomorrow – all their manuals refer to the Nat keep alive settings etc when both my ATA’s don’t have that feature – it will be interesting to see what happens when I configure the ATA
I have a d-link VTA-VD and a pap2 v2 NA – both of which have very limited settings but reading the boards seem to work fine with voip.ms
If in fact it is a NAT issue is it even possible to fix or get an ATA that has the NAT keep alive function and will it work then?

PX Eliezer70
Premium
join:2008-08-09
Hutt River
kudos:13
Reviews:
·callwithus
·voip.ms
The PAP2T has NAT KeepAlive.

See the CallCentric instructions, step 14.
»www.callcentric.com/support/devi···sys/pap2

(Do you have a PAP2T or a PAP2-V2 ?)

conitssap

join:2012-08-13
It’s a misconception – the V2-NA ( Firmware Version: 1.00.22) dosent have NAT features – all the other versions seems to have them except this one - Its an unlocked Vonage version

PX Eliezer70
Premium
join:2008-08-09
Hutt River
kudos:13
Reviews:
·callwithus
·voip.ms
reply to conitssap
said by conitssap:

If in fact it is a NAT issue is it even possible to fix or get an ATA that has the NAT keep alive function and will it work then?

I'm not a technician nor a prophet, unfortunately.

Fix, I don't know.

But I can tell you that I've used many ATA's with Voip.MS, such as Grandstream 286 and 486, PAP2T, etc....

Also IP phones such as Gigaset A580-IP.

Stewart

join:2005-07-13
kudos:26
reply to conitssap
Does your router get a public IP address on the WAN side? If not, please explain (your modem is configured as a router, your ISP is doing NAT, etc.)

If the router does get a public IP, then when you tested with the direct-to-modem connection and it failed, there was no NAT involved, so you are likely looking in the wrong area for the trouble.

Modem make/model? ISP?

conitssap

join:2012-08-13
"Does your router get a public IP address on the WAN side?"

Yes it does and it shows the same when registered to voip.ms

ISP is Teksavvy

Modem details below
Model Name: SB6121
Vendor Name: Motorola
Firmware Name: SB612X-1.0.5.1-SCM00-NOSH

Stewart

join:2005-07-13
kudos:26
reply to conitssap
This is very puzzling. When connected directly to the modem (even with two different adapters), it is failing without any NAT. In any case, it's not a NAT keep-alive issue; that would cause incoming calls to not ring at all. This smells like a buggy ALG, but there shouldn't be any!

Since the softphone does work, and most use a random local port, try changing the local SIP port (not the server port) on your adapter from 5060 to something else.

If that doesn't help, I suggest capturing traffic to see what is going wrong. Do you have a clean way to do that, e.g. a dumb hub or a USB-to-Ethernet adapter? If not, try connecting a PC to the Internet via Wi-Fi and sharing it to its Ethernet port, into which you plug the ATA. Then, run Wireshark to see how working and failing incoming calls differ.

conitssap

join:2012-08-13
I only tried the d-link direct to the modem - will try the linksys and then switch ports on both of them to see if that helps
I have read to try 5080 on the new linksys ATA's - if that dosent work ill go the wireshark route

conitssap

join:2012-08-13
reply to Stewart
Now both ATA's exhibit the same problem plugged directly into the modem.
Switching ports did not help either
Noticed that when calling sometimes there is silence on my cell while it rings on the voip line but when i answer there is nothing again on the voip line.
the d-link ata - i can replicate the issue in 20 minutes or so - while the PAP takes a couple hours for it to turn buggy
ill go the wireshark route but may need some help as I have no clue about analyzing/capturing data packets

Stewart

join:2005-07-13
kudos:26
Please confirm that you have changed UDP Listen Port from 5060 to something else, e.g. 5678. That's the local port number used by the device and can be anything. On a softphone it's usually just whatever the OS assigns.

In addition, use an alternate proxy port (and registrar port) that VoIP.ms supports, either 5080 or 42872.

Also, what is the value of Reg Expire Timer? If it's long, try setting 60000 milliseconds.

If needed, I'll help with setting up Wireshark captures and/or interpreting the results. But first, you need to get the PC to "see" the packets to be captured. One way to do this is to get the packets to pass through the PC, using Internet Connection Sharing or Bridge Connections. Of course, this requires that the PC have two NICs, one connected to the Internet and one connected to the ATA. The other way involves a dumb hub, e.g. an old 10Mbps one, or a managed switch, allowing the PC to snoop the traffic.

conitssap

join:2012-08-13
I did change the UDP port earlier but not the proxy/registrar port - will try that and see if it makes a difference
should I also change the RTP ports?
the reg expire timer is get to 60000 ms and retry to 20000ms
if that dosent work I will try callcentric and see if their setup causes the same problems - if thats the case then the ATA's are to blame and ill go the wireshark route - I will have to use my laptop for wireshark

Stewart

join:2005-07-13
kudos:26
I don't believe that the RTP ports are involved at all. Since the caller continues to hear ringback tone when you answer, the failure is at the SIP level and RTP has not yet been invoked.

SCADAGeo

join:2012-11-08
N California
kudos:2

1 edit
reply to conitssap
said by conitssap:

toronto->montreal->chicago but that hasnt helped

Please try registering to losangeles.voip.ms, port 5080, and see if it makes any difference.

said by PX Eliezer70:

For test purposes you could also sign up for a free "IP Freedom" account from CallCentric.

Have you had a chance to try this out?

conitssap

join:2012-08-13
I haven't tried the LA Server yet
will be testing out callcentric now

conitssap

join:2012-08-13
reply to SCADAGeo
I tried it with callcentric and have the exact same issues – we now know that the ATA’s are to blame

SCADAGeo

join:2012-11-08
N California
kudos:2
said by conitssap:


we now know that the ATA’s are to blame

:)

fritzthevan

join:2003-09-07
canada
reply to conitssap
I had the same problem on the same provider: every so often answer incoming calls, silence to me, ringing to caller.

Tried two ATAs: a PAP2T and a SPA112. Tried 2 routers: a WRT54GL and WL-520GU. Played with firmware, servers, and registration/NAT parameters in the ATA/router. Spent an insane amount of time on it, with no joy.

I really wanted to stay put but finally gave up and moved on. In the last 8 months using callcentric and anveo on the same equipment, have not seen the problem. Don't know what was at fault, but just saying.

conitssap

join:2012-08-13
Your situation is the exactly the same as what I have been going through for the last month - im going to test it with another ISP just to give it one last kick at the can.
I dont expect any different though

Springbok

join:2002-09-13
Colleyville, TX
Maybe it's the phone handset? Have you tried a different one plugged directly into the ATA?

conitssap

join:2012-08-13
Sometimes you overlook the obvious – I’m using a Panasonic cordless phone. I will try it with a standard wired handset and see if that helps.

conitssap

join:2012-08-13
reply to Springbok
didnt work with a direct line plugged in - it actually got worse - took me 10 tries to get an answer while the cordless would take 2-3.
changed the phone cord and that did not help either.
not sure why it would get worse though - changed impedance and Ren setting but that did not make a difference.

Springbok

join:2002-09-13
Colleyville, TX
Here's my ATA settings with voip.ms and although I dont use the analog phones much these days, it's always working when I try them:

PAP2T Firmware Version: 5.1.6(LS)
NAT Keep Alive Intvl: 15 seconds
Ring Waveform: Sinusoid
Ring Voltage: 90
Ring Frequency: 20
Register Expires: 60

I also remember being advised to use the hard IP address of my voip.ms POP and not the DNS name on this ATA (dont remember the reason).


Dave2

@verizon.net
reply to conitssap
had a load of problems getting incoming calls with voip.ms, I think it is just their system, so I just use them for outgoing only which has been pretty good

Springbok

join:2002-09-13
Colleyville, TX
said by Dave2 :

had a load of problems getting incoming calls with voip.ms, I think it is just their system, so I just use them for outgoing only which has been pretty good

I don't have any problems with incoming voip.ms calls. I think most people set the NAT Keep Alive way to high (mine is at 15).

conitssap

join:2012-08-13
reply to Dave2
im pretty sure its not a problem with voip.ms but with my ATA

anyways i changed my FXS Ren setting to 5 and its been working fine for the last 15 minutes - moved it back to 0 as the same symptoms popped up again. it could be a coincidence so ill test it out for a longer period of time but it looks promising.
i didn't think a self powered phone would need a higher REN setting but it could be something to do with the cordless headset and would also explain why the problem only worsened on the standalone phone