dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
2544
share rss forum feed

Rel82me3

join:2012-06-16
Toronto, ON

Multiple IP's

HI everyone, I'm attempting to use a range of IP's assigned by Teksavvy. I have a TPLINK TD-W896ON DSL modem. The assigned address range is 112 - 116. On the TPK LINK, I've checked the "Configure the second IP address and subnet mask for LAN interface" to the first IP address in the range, with a subnet of 255.255.255.248.

My NIC card has the SECOND ip address in the range with a subnet of 255.255.255.248 and default gateway of my FIRST ip address in the range.

Is this configuration correct? I have a range of IP addresses I used before and am pretty sure this is configured correctly????

Help much appreciated!


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
Not correct. I'm not familiar with your router model, but in principle you should have a static IP address that is outside your assigned subnet. Your PPPoE WAN should get this from TSI. You then assign one of the address from your subnet (NOT the first or last) to your router's LAN interface, and another from this subnet (NOT the first or last) to the hosts on the LAN. You will then want to make sure NAT is disabled in the router, although you should have internet even if you don't.
--
db

Rel82me3

join:2012-06-16
Toronto, ON
Clark,

Its a TP-LINK TD-W8960N.

Oddly enough, I had this working with another range of IP's in the past. On the TP link, under Advanced Setup > LAN, I added the option to "configure a second IP Address and subnet mask for LAN interface", provided the IP address (not first or last) and a subnetmask of 255.255.255.248

On one of the hosts, I configured the IP address info as follows:

ip address: 76.10.179.114 (not first or last in the range), subnet mask of 255.255.255.248 and default gateway as the FIRST ip address in the range. I also tried the default gate as specified after the modem/router obtained the details from Teksavvy. This doesn't seem to work for me and no one at Teksavvy know's how to address this? It really bugs me as I had this working with a diffrient range of IP's.


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
said by Rel82me3:

I added the option to "configure a second IP Address and subnet mask for LAN interface"

It appears to me that the purpose of that option is to give your router's LAN interface more than one IP address. Is that what you want? Does the TP-LINK allow you to configure outbound NAT on the LAN's primary address, and no NAT on its secondary ("alias") address?

If the router's LAN interface has an address of .113, then that will be the default gateway to hosts in that network. You may also want to check your DNS settings.
--
db

Rel82me3

join:2012-06-16
Toronto, ON
Hey Clark,

Outbound NAT on Primary Address:

I'm not seeing anything of this nature, anywhere in the config.

The network config obtained by the TP-LINK, from teksavvy for the default gateway is: 206.248.154.122

My understanding is the range of IP's that I got from Teksavvy needs to be used on subnet: 255.255.255.248

I guess the question I should be asking is, do I use the default gateway that is provided by TSI as the default gateway assigned to my NIC, or should I be using a gatewayy address based on the range of IP's?

-- confused a little.


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
The first address of any subnet is known as the network address and cannot be assigned to a host. The last address is the broadcast address, and likewise cannot be assigned to a host. The only possible exception is if you have a /30 subnet, which you don't.

If you lease a /29 subnet from TSI then you have 8 addresses, with 6 of them being host-assignable. My guess is that your range is 112-119. If so, then assign your router a LAN address of 113. Assign your local hosts addresses of 114-118 and tell them to use a default gateway off 113. Your router is their gateway. TSI`s router is the gateway for your router, not for your local hosts.

If your router doesn`t allow you to turn off NAT, then it will be re-writing the source address of anything leaving your network. To test this, use one of your local machines go to a web host that tells you your public IP address, such as google or ipchicken.com. If it tells you your public IP address is 113, then you know your router is doing NAT. If it tells you your address is the same address you assigned to that host, ie, 114, then you have successfully disabled NAT in your router, and only then is that host reachable from the internet without configuring any port forwarding in the router.

»www.subnet-calculator.com/

--
db

Rel82me3

join:2012-06-16
Toronto, ON
Clark,

The range assigned is 112-119, correct.

As you stated, this is exactly what I have done. I'm using the 113 addy for the tp-link interface card, then using 114 on the nic on one of the hosts with subnet of 255.255.255.248. I'm pointing the default g/w on the hosts interface back to 113 on the host.

The TP link and the host are communicating, but traffic doesn't seem to getting out. is it a possible natíng problem with tsi? I don't think this is the case.

So on the TP Link device I have a subnet of: 255.255.255.248 and IP as 76.10.179.113. On the host I have subnet of 255.255.255.248, ip of 115 and d/g/w of 113.

This sounds logical, no?


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
That looks correct. Do you have more than one address configured on the router's LAN? The "configure a second IP Address and subnet mask for LAN interface" option sounds suspicious to me.
--
db

Rel82me3

join:2012-06-16
Toronto, ON
Weird.. Have factory reset the device but still can't get it working. This appears to be a outside the scope of their support department allthough they do agree that the settings are correct. have also tried using of googles ip addresses to call up the search engine, but nadda.

Anyhow, thanks for your help, much much aprecaited!


clarknova

join:2010-02-23
Grande Prairie, AB
kudos:7
Reviews:
·TekSavvy DSL
Not so fast! What are you going to do about it? Given that your tp-link doesn't appear to support turning off NAT, I would recommend putting it in bridge mode and try another router. In fact, I generally recommend against using any modem-router combination, as the router portion is rarely up to snuff. Case in point.
--
db

Rel82me3

join:2012-06-16
Toronto, ON
I exported the configuration file, found the tag and changed it to FALSE. But still nothing. Since then, I have reset the modem to factory defaults and am going to give this another try. Any more suggestions?

Rel82me3

join:2012-06-16
Toronto, ON
oh great.. Now it's IP conflicts.. LOL. How is this even possible? ya know, I think the issue might be on TSI side.