dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
738
share rss forum feed


nunya
Premium,MVM
join:2000-12-23
O Fallon, MO
kudos:12
Reviews:
·Charter
·voip.ms
·surpasshosting

Wordpress Permalinks

I've just discovered WP. I've tried Drupal and Joomla in the past and I didn't care for them. I finally tried WP and really like it.
Here's my issue. Unless you use the default permalink scheme, every page comes back with a 404 error.
I've scoured google and tried all the fixes I could find. Most seem to revolve around .htaccess, which doesn't seem to be my issue.
I can tell this is a widespread problem, I have yet to find a fix that works.
I started with 3.4.2 and upgraded to 3.5 hoping that would resolve the issue. This is on a debian-6 server.
Has anyone conquered this beast or found a work around? I'd really like my pages to display "post name" rather than the default.
--
If someone refers to herself / himself as a "guru", they probably aren't.



Rob
In Deo speramus.
Premium
join:2001-08-25
Kendall, FL
kudos:2

You need to specify the permalink format in your .htaccess for it to work, otherwise, you will get a 404.



nunya
Premium,MVM
join:2000-12-23
O Fallon, MO
kudos:12
Reviews:
·Charter
·voip.ms
·surpasshosting

Here's what WP writes to the .htaccess file when I have "postname" selected in Permalinks:

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Everything I've found seems to say that is correct, yet all pages are 404.
When I change back to "default", the .htaccess file is essentially empty.

--
If someone refers to herself / himself as a "guru", they probably aren't.



Rob
In Deo speramus.
Premium
join:2001-08-25
Kendall, FL
kudos:2

Can you paste the format you are using?



nunya
Premium,MVM
join:2000-12-23
O Fallon, MO
kudos:12
Reviews:
·Charter
·voip.ms
·surpasshosting

Thanks for the nudge. It was actually apache ignoring it.
/etc/apache2/sites-available

<Directory /var/www/wordpress>
        Options FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
</Directory>
 
Should have been....
 
<Directory /var/www/wordpress>
        Options FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
</Directory>
 

I guess an update overwrote it.

--
If someone refers to herself / himself as a "guru", they probably aren't.


Rob
In Deo speramus.
Premium
join:2001-08-25
Kendall, FL
kudos:2

Great! Works now?



nunya
Premium,MVM
join:2000-12-23
O Fallon, MO
kudos:12

Like a charm.