dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
870
share rss forum feed


onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

[OS X] New issue with Mac

I'm still loving it though.

Ok here's the issue. When I leave the office my connection to exchange will drop. The only way I can reconnect is to edit the server settings to that of the webmail address.

Is there a way I can keep those settings locked?
--
Photoshop these nuts in your mouth.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

Crap no one has an answer for this one. Heck I can't even find an answer on Google.
--
Photoshop these nuts in your mouth.



Thinkdiff
Premium,MVM
join:2001-08-07
Bronx, NY
kudos:11

Sounds like it's specific to your company's setup. What do you mean by "webmail address"?

Typically if Exchange authenticates/self-configures as part of an Active Directory connection, that stops working when not on the private network. You can try manually configuring Exchange with your Exchange Server address, login, password, domain, etc.
--
University of Southern California - Fight On!



donoreo
Premium
join:2002-05-30
North York, ON
reply to onebadmofo

So in the office is it fine. Outside are you connecting to a VPN? If not, of course you will not be able to connect. You would not in Windows either.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1
reply to Thinkdiff

What I mean by webmail is the Outlook Web Access, or OWA address.
It's shown as webmail.domainhere.com
--
Photoshop these nuts in your mouth.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1
reply to donoreo

We have OWA. So yes you can connect without the need of VPN in Windows.
You can also do this in Mac. But you need to copy and paste the Directory Server address, which shows as the OWA address, into the Exchange Server text area. Once this is done, email from exchange works fine all day everyday. Even when you come back into the office, it's fine. It's when you leave again that you lose the connection and then have to copy and paste that OWA address back over the MS Exchange area.

I'll post pics.
--
Photoshop these nuts in your mouth.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1
reply to onebadmofo

Ok here is a shot of what needs to be done to get this working when out of the office.
It's part of a directional I made to give to a user.
It takes like 10 seconds to do. But I'd like to have it so that the user doesn't have to do anything.



--
Photoshop these nuts in your mouth.

Riamen
Premium
join:2002-11-04
Calgary
reply to onebadmofo

Is this with Outlook 2011? I had the same problem where the server address would always change to the internal name while in the office, of course that name would not resolve outside the office and Outlook couldn't connect to the server. The problem is the way Autodiscover is configured on the Exchange server. One possible fix is to disable Autodiscover in Outlook. The following link shows how to do it.

»tomtheitguy.wordpress.com/2012/0···noyance/

For this to work your OWA address must resolve properly inside the office too.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

Yep. Outlook 2011.
And this is all done through a terminal window on the Mac?
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary
reply to onebadmofo

No not in Terminal. Open the AppleScript Editor, copy and paste the script. Change line two to match your OWA server address. Click run.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

If this happens to fail, is there a way to remove what the script wrote?
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary

Just change the word 'false' to 'true' in the 3rd line and run the script again. You can remove the second line if you want to make the server address changes in Outlook yourself.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

Awesome. I'll try it now. I'll let you know the outcome.
--
Photoshop these nuts in your mouth.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1
reply to onebadmofo

Ok...after running it, it displays this error.
error "Microsoft Outlook got an error: The user name of the account is required." number -1715

I'm not sure on where to place this and maybe the pwd if that would be the next error.
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary
reply to onebadmofo

Not sure where to put it either. I'll see if I can find anything on it.

Edit: Try this script

tell application "Microsoft Outlook"
set background autodiscover of exchange account "NameOfAccount" to false
end tell
 
Replace NameOfAccount with your account name.


onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

No dice man. Here's the new error:

error "Microsoft Outlook got an error: Cant set exchange account \"my account name here\" to false." number -10006 from exchange account "my account name here"
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary
reply to onebadmofo

Sorry I wasn't clear, you must have Outlook open when running the script. The account name must match the name in the Account Description field in Outlook's settings.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

said by Riamen:

Sorry I wasn't clear, you must have Outlook open when running the script. The account name must match the name in the Account Description field in Outlook's settings.

Actually I tried it while opened, and closed. And neither way worked.

BUT...I googled "remove auto discovery outlook 2011 for mac" ...or something like, that and found this...
»groups.google.com/forum/?fromgro···DZ0n3vYM

I ran the script they have and it ran successfully. And still works n the building. Now all I have to do is leave and try it outside and that will tell me if it works for sure.

Here's the script in case you don't feel like going to the link..

tell application "Microsoft Outlook"
set background autodiscover of Exchange account 1 to false
end tell

Thanks for the help.

I'll post back with news on if it stays connected outside of the office. I'll reboot and log off, and close and reopen the app. Gotta run it through it's paces.
--
Photoshop these nuts in your mouth.


onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1
reply to onebadmofo

I think I know why it wasn't working with my username.
I found this link:
»mysite.uchicago.edu/personal/bsd···3&ID=175

And based on that I looked at the name of the account and it's named simply Exchange.
Not sure if that would have cleared the error out but, it's working now. So, I'll just let it as is unless it doesn't work outside. Then I'll try something else.
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary

Yes that's what I was referring to. Sorry I may have misled you there.

The only remaining catch would be if the OWA address you use on the outside is different from the one you use on the inside. If the outside address works when you're in the office you should be ok.



onebadmofo
gat gnitsoP
Premium
join:2002-03-30
Reading, PA
kudos:1

Yeah the outside one works inside as well. Hopefully that was the fix.

Let me ask you, Apple mail should work out of the office as well. But it doesn't. Now the difference with this is, that even when typing the webmail address into the areas you would think matter, nothing makes a difference.

Would the fix be similar or should it just work since it's pretty much like mail on the iPhone? (and the phones have no problem staying connected away from the office)
--
Photoshop these nuts in your mouth.


Riamen
Premium
join:2002-11-04
Calgary

said by onebadmofo:

Let me ask you, Apple mail should work out of the office as well. But it doesn't. Now the difference with this is, that even when typing the webmail address into the areas you would think matter, nothing makes a difference.

Would the fix be similar or should it just work since it's pretty much like mail on the iPhone? (and the phones have no problem staying connected away from the office)

You can turn off Autodiscover in the Mail app. It's just a check box in the settings. I just put in the internal and external server names, username and password. I do this on my MBP and have had no problem with it.