dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2277
share rss forum feed

zrob_12

join:2009-01-17

ASR1002 VLAN

I am attempting to upgrade from a Cisco3945 to a ASR1002. On my Cisco3945, I have interfaces associated with VLANs. It appears that with the new IOSX, VLAN configuration has changed. Can someone provide a config to setup a simple VLAN on the ASR1002?


nosx

join:2004-12-27
00000
kudos:5

I have never seen VLANs configured on an ASR1k (its a router, not a switch)

You can do something cryptic and horrible like trying to use bridged virtual interfaces (BVI 123) and use bridge-domains on your ethernet ports to simulate ethernet switching...

Or you could use ethernet subinterfaces on your port facing the switches:
int gig0/0/0.101
encap dot1q 101
ip address 10.101.0.1 255.255.255.0
int gig0/0/0.102
encap dot1q 102
ip address 10.102.0.1 255.255.255.0
int gig0/0/0.N
encap dot1q N
ip address 10.N.0.1 255.255.255.0
etc...


zrob_12

join:2009-01-17

I was able to setup VLANs with my 3945 ISR as a router. Basically, I am needing the multiple interfaces on the ASR1002 to share the same gateway. I don't think I can do this without a VLAN...or can I?


zrob_12

join:2009-01-17

I might also add that I would prefer to NOT have to add a switch. The ASR1002 has multiple available interfaces that I would like to utilize. Many of these interfaces need to share the same gateway.


nosx

join:2004-12-27
00000
kudos:5

The ASR1000 gigabitethernet interfaces are not switch ports, they are routed ports. You have the wrong platform if that is your intent.

The ISRg2 to my knowledge supports switchports as it supports ethernet switch modules. I do not know enough to speak to the limitations of that platform however.


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to zrob_12

Can you post the relevant config(s) you had on the 3945 that you're trying to transplant over to the ASR1002, zrob_12 See Profile?
Also, was this configured on the inbuilt GE interfaces on the 3945 chassis, or was this an add-on module that you did this
configuration you speak of?

If you're trying to do as I think you are, I agree with nosx See Profile in that the ASR1xxx GE interfaces are LAYER3
interfaces, not layer 2; you can do subinterfaces on them but they will NOT take any "switchport access vlan ..."
or similar commands on them.

Providing this link as well for reference -- »www.cisco.com/en/US/docs/ios-xml···ook.html

Regards


zrob_12

join:2009-01-17

See below. Gig0/1/0 through Gig0/1/4 belong to VLAN1. Gig0/1/5 through Gig0/1/7 belong to VLAN2. Both VLANs are configured on the add-on module.

interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
!
interface GigabitEthernet0/1/4
no ip address
!
interface GigabitEthernet0/1/5
switchport access vlan 2
no ip address
!
interface GigabitEthernet0/1/6
switchport access vlan 2
no ip address
!
interface GigabitEthernet0/1/7
switchport access vlan 2
no ip address
!
interface Vlan1
description $FW_INSIDE$
ip address 192.168.200.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip virtual-reassembly in
!
interface Vlan2
description $FW_INSIDE$
ip address 192.168.100.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in


zrob_12

join:2009-01-17
reply to HELLFIRE

On the ASR1000 router, I have a SPA-8X1GE-V2 installed. From what I have been reading, it looks like I can accomplish a similar setup through dot1q encap sub interfacing? If this is correct, do you have any experience with this?



tubbynet
reminds me of the danse russe
Premium,MVM
join:2008-01-16
Chandler, AZ
kudos:1
reply to zrob_12

you're confused.
you've added 'switchports' to your router. your asr1k isn't in the same gimmicky 'everything in a single box' class as the isr/g2. the asr1k is an enterprise edge/sp pop router -- not a switch.

see nosx See Profile's post above. if you want to connect end hosts to this device -- you have to put a switch in place, then move the svi configuration above to tagged subifs on the asr1k.

q.
--
"...if I in my north room dance naked, grotesquely before my mirror waving my shirt round my head and singing softly to myself..."


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to zrob_12

Guessing the specific module you used on the 3945 was this one zrob_12 See Profile -- »www.cisco.com/en/US/prod/collate···808.html ?
In which case, it states specifically in the datasheet it does layer 2 function only which we've already said the
ASR's inbuilt GE ports do not do.

If you want to do subint / dot1q encap, nosx See Profile just gave you a sample config a couple posts above already.

Regards



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5
reply to zrob_12

I am thinking this might need to be accomplished with VPLS.

Thats the only (best) way, other than bridge domains which are uuuuugly, I can think of to share a gateway across multiple routed ports.


nosx

join:2004-12-27
00000
kudos:5

If all he wanted was site to site L2 transport with MPLS in the middle VPLS would be viable, however routed VPLS (VPLS with a routed interface such as a default gateway in the middle on the same PE) is a cripple-tastic feature that barely works on bleeding edge hardware & code. L2VPN setup's are not generally all that interoperable with L3 features and vice versa.

If you want an all-in-one vomit box the ISR's are the answer, otherwise you are back into the world of defined roles on dedicated hardware.



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

Right, so basically what it boils down to with this guy is that he needs to use a switch with his ASR. :-P



tubbynet
reminds me of the danse russe
Premium,MVM
join:2008-01-16
Chandler, AZ
kudos:1

said by TomS_:

Right, so basically what it boils down to with this guy is that he needs to use a switch with his ASR. :-P

or he can ship me his asr1002 and i'll send him my 2851 with an esw. the problem would be solved right there.

;-P

q.
--
"...if I in my north room dance naked, grotesquely before my mirror waving my shirt round my head and singing softly to myself..."

HELLFIRE
Premium
join:2009-11-25
kudos:18

Timeshare it with you tubbynet See Profile and I'll toss in anold 1900-series Catalyst switch

Regards


zrob_12

join:2009-01-17
reply to zrob_12

Just wanted to provide an update.

I did end up using a switch to accomplish the task. I really wanted to avoid having an extra piece of equipment in the mix, but it seems it was the most effective way...

Thanks for all your advice