dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
9077
share rss forum feed

markysharkey
Premium
join:2012-12-20
united kingd

[Config] Cisco 2504 WLC help, long!!!

I have a problem with a brand new Cisco 2504 WLC. I have been through the basic CLI set up and can access the GUI from the management port. I can create interfaces and SSID's just fine and from what I have read in the CCNA Wireless book, it should be working but it isn't.
I have three 1142 LWAP's on a 2960S PoE switch which is also the DHCP server. I have created the appropriate DHCP scopes and VLAN's / SVI's and everything is ping-able except for the WLC. Also wireless hosts are not receiving DHCP responses, so I'm at a real loss. I am thinking that I should try disabling DHCP Proxy and ensuring that all my SSID's appear on the management interface but I just don't know. I'm also not sure if I should be adding IP helper-addresses to the switch but I have no idea why I think that other than desperation!
As this is a test environment I am happy to show the config:

Switch config:
VLAN's 1, 10, 20, 30, 40, 50 with matching DHCP scopes with a few reserved addresses on each.
Ranges are 192.168.x.0/24 with an obvious choice for the third octet.
Links to the AP's and WLC are trunks and all VLAN's are being carried.
IP routing has been enabled (this is a new 2960S with static routing capability. It's sooo good!). AP's receive a DHCP address no problem and are ping-able from the switch but not from the WLC CLI or from any host due to the lack of DHCP offers to host discovery requests.

WLC has 3 SSID's for VLAN 1, 10 and 40. Management VLAN is untagged so it's VLAN 1. I have created an interface for each VLAN
Virtual Interface is the usual 1.1.1.1 mapped to port 4, management Port is Port 1 at 192.168.0.5/24 which is a reserved address so there are no IP address conflicts. The WLC sees the AP's and registers them just fine and I can make changes to them, so there is communication, just not to the hosts via the wireless!

I would appreciate any thoughts.

HELLFIRE
Premium
join:2009-11-25
kudos:19
Without a full config (minus passwords and other sensitive information) from the WLC and 2960 to review, it's going to
be hard to point you in the right direction markysharkey See Profile

Regards

markysharkey
Premium
join:2012-12-20
united kingd
reply to markysharkey
Switch config is easy enough to post. Show run-config on a WLC is extremely long. Any chance you or anyone could let me know what to focus on?
Alternatively I could post screen grabs of the GUI but again there are lots to choose from so a pointer or two may help all of us to narrow down the things to look at.

Delco24

join:2004-02-15
Cary, NC
said by markysharkey:

Switch config is easy enough to post. Show run-config on a WLC is extremely long. Any chance you or anyone could let me know what to focus on?
Alternatively I could post screen grabs of the GUI but again there are lots to choose from so a pointer or two may help all of us to narrow down the things to look at.

show run-config no-ap should shorten it up substantially.

ladino

join:2001-02-24
USA
kudos:1
reply to markysharkey
Here is a sample configuration to help get your WLC & APs working.

But first some assumptions:-
-Management vlan for devices is vlan 2
-WLC managment IP address = 10.0.1.2
-L3 switch uses vlan 2 for management, Vlan2 IP address = 10.0.1.1
-wifi DHCP pools are configured on the switch
-2 SSIDs created, CCNA, CCNP
-WLC connected to switch via port # 1

WLC configuration
config interface port management 1 
config interface port ap-manager 1 
config interface port vlan-10 1 
config interface port vlan-20 1  
config interface address management 10.0.1.2 255.255.255.0 10.0.1.1 
config interface dhcp management primary 10.0.1.1 
config interface vlan management 2 
config interface address virtual 1.1.1.1 
config interface address ap-manager 10.0.1.3 255.255.255.0 10.0.1.1 
config interface dhcp ap-manager primary 10.0.1.1 
config interface vlan ap-manager 2
!
config interface address dynamic-interface vlan-10 10.2.2.224 255.255.255.0 10.2.2.254 
config interface dhcp dynamic-interface vlan-10 primary 10.2.2.254 
config interface vlan vlan-10 10 
config interface create vlan-10 10
!
config interface address dynamic-interface vlan-20 10.3.3.224 255.255.255.0 10.3.3.254 
config interface dhcp dynamic-interface vlan-20 primary 10.3.3.254
config interface vlan vlan-20 20 
config interface create vlan-20 20
!
config mobility group domain ABC
config wlan apgroup add XYZ Wifi-AP-Group
config wlan apgroup interface-mapping add XYZ 1 vlan-10
config wlan apgroup interface-mapping add XYZ 2 vlan-20
!
config wlan security wpa akm psk set-key ascii CCNA-wifi-Password  1 
config wlan security wpa akm psk enable 1 
config wlan security wpa akm 802.1x disable 1 
config wlan security wpa enable 1 
config wlan security wpa akm psk set-key ascii CCNP-wifi-Password  2 
config wlan security wpa akm psk enable 2 
config wlan security wpa akm 802.1x disable 2 
config wlan security wpa enable 2
config wlan interface 1 vlan-10 
config wlan interface 2 vlan-20
config wlan create 1 wlan-profile-1 CCNA 
config wlan create 2 wlan-profile-2 CCNP
config wlan enable 1 
config wlan enable 2
!
 

Switch configuration
ip dhcp pool Management
   network 10.0.1.0 255.255.255.0
   default-router 10.0.1.1 
   option 43 hex f104.0a0a.0105         <<----IP address of WLC management IP in Hex
!                                       <<--- This tells the AP who to connect to
!
ip dhcp pool CCNA-SSID
   network 10.2.2.0 255.255.255.0
   default-router 10.2.2.254
!
ip dhcp pool CCNP-SSID
   network 10.3.3.0 255.255.255.0 
   default-router 10.3.3.254 
!
interface GigabitEthernet0/1
 description  *** Wireless Controller ***
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,10,20,30,40
 switchport mode trunk
!
interface GigabitEthernet0/2
 description *** 1250 AP ***
 switchport access vlan 2
 switchport mode access
!
!
interface Vlan2
 description ** Management vlan ***
 ip address 10.0.1.1 255.255.255.0
!
interface Vlan10
 description *** CCNA SSID vlan ***
 ip address 10.2.2.254 255.255.255.0
!
interface Vlan20
 description *** CCNP SSID vlan ***
 ip address 10.3.3.254 255.255.255.0
!
 

markysharkey
Premium
join:2012-12-20
united kingd
Thanks Ladino. I will pick though that presently because...

I think I may have at least got past the DHCP hurdle which was my main bugbear.
In all the Cisco docs they focus on the 4400 and 5500 WLC's. I'm using a 2504. The Cisco docs all talk about having an AP-Management Interface which the 2504 seems to not have.
The 2504 does have a "normal" management port which I configured as appropriate and yes I realise ports are physical and interfaces are logical.
It seems that if I leave the rest of the config at default settings then once the management port is configured (and I'm using an un-tagged VLAN 'cos I like to make my life difficult...) you need to remove the laptop from the port and plug in the link from the switch to the designated physical management port. With that one simple thing done, my WLAN's all burst in to life and I could connect from a wireless client on any VLAN, through the 2960s and on to any wired or wireless host connected to any VLAN that was configured.

Next up is to create a new AP group, add the AP's and WLAN's to it (excluding the designated management WLAN etc) and map that to a different physical port. If I understand the instructions right (and Cisco don't make it easy!) then I may well have this sorted.

If that works then it will be time to fire up my CUCM 2901 and add some 7925 wireless phones to the designated Voice VLAN and see if I can route some calls! Stand by for more questions!!!