dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
773
share rss forum feed

carefree

join:2012-12-26

Beware of Acanac's terrible/fraudulent service

I subscribed and paid for 12 months of 28mbit cable internet on December 12, 2012 and was given a setup date of December 24, 2012 between 5-8pm. Two weeks passed, the modem arrived by mail but no technician showed up...no call or anything, and surely Acanac was "closed" when I called. I unboxed my modem December 25, plugged it in and got a message saying that the modem could not be registered on the Rogers network. I submitted two tickets to their so-called "support" system, and have received no response in 48 hours to either ticket.

It took Acanac 2 weeks and they haven't even contacted Rogers to get my modem setup. I will try giving them a call tomorrow to reimburse two weeks of non-service from December 12 to now and my activation fee. If they are unwilling to do this, I will send their modem back and demand a full refund.

Chances are they wont answer their phones however, so I will just reverse the payment to these frauds through my credit card company.

I should've read more about Acanac/Distributel before making the switch from Teksavvy.


Fergless
Premium
join:2008-04-19
Toronto, ON
kudos:1

Reimbursement of time lost.

quote:
It took Acanac 2 weeks and they haven't even contacted Rogers to get my modem setup. I will try giving them a call tomorrow to reimburse two weeks of non-service from December 12 to now and my activation fee. If they are unwilling to do this, I will send their modem back and demand a full refund.

Support was closed Christmas and Boxing Day, however when you finally get online, please email billing@acanac.com and let them know and they will extend your renewal date.

Can you post your ticket # for reference to your issue, if you have opened one. If not here's the online form to support.
»www.acanac.com/contactus.php

carefree

join:2012-12-26
Thanks for your reply Fergless. Yesterday the technician showed up unexpectedly at 2pm and installed the modem and activated the modem on the Rogers network. I suppose Rogers is to blame for the late arrival of the tech? Internet is working fine now.