dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3669
share rss forum feed

bvanderhaar

join:2012-07-04

[IPv6] OpenWRT and Comcast IPv6

Plugging my Zoom 5341J directly to my Windows 7 laptop, I have both IPv4 and IPv6 connectivity (according to »test-ipv6.com/). Now I'm trying to get IPv6 working with my router.

Following the OpenWRT docs (»wiki.openwrt.org/doc/howto/ipv6.isp and »wiki.openwrt.org/doc/howto/ipv6.essentials), I've got radvd and dhcp6c setup on my OpenWRT Attitude Adjustment RC1 box (TL-WR1043ND). However, I'm not receiving an IPv6 on my WAN address. I'm comfortable with config files and linux environments, but unfamiliar with radvd and dhcp6c. I have a feeling my configs are not quite right, but I've tried enabling and disabling various settings with no success. Some direction of where I'm going wrong would be very helpful. I'll definitely share what I did when I have success.

Here's my ping6 result:

root@OpenWrt:~# ping6 ipv6.google.com
PING ipv6.google.com (2607:f8b0:400f:801::1011): 56 data bytes
ping6: sendto: Network is unreachable
 

Here's my configs:
/etc/config/network
.
.
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option accept_ra '1'
.
.
 
/etc/config/radvd:
config interface
option interface'lan'
option AdvSendAdvert1
option AdvManagedFlag0
option AdvOtherConfigFlag 0
option ignore0
 
config prefix
option interface'lan'
# If not specified, a non-link-local prefix of the interface is used
list prefix''
option AdvOnLink1
option AdvAutonomous1
option AdvRouterAddr1
option ignore0
 
config route
option interface'lan'
list prefix''
option ignore0
 
config rdnss
option interface'lan'
# If not specified, the link-local address of the interface is used
list addr''
option ignore0
 
config dnssl
option interface'lan'
list suffix''
option ignore1
 
/etc/config/dhcp6c:
config 'dhcp6c' 'basic'
option 'enabled' '1'# 1 = enabled; 0 = disabled
option 'interface' 'wan'# This is the interface the DHCPv6 client will run on
option 'dns' 'dnsmasq'# Which DNS server you run (only dnsmasq currently supported)
option 'debug' '1'# 1 = enable debugging; 0 = disable debugging
 
# Send options (1 = send; 0 = do not send)
option 'pd' '1'# Prefix Delegation
option 'na' '1'# Non-Temporary Address
option 'rapid_commit' '1'# Rapid Commit
 
# Request options (1 = request; 0 = do not request)
option 'domain_name_servers' '1'
option 'domain_name' '0'
option 'ntp_servers' '0'
option 'sip_server_address' '0'
option 'sip_server_domain_name' '0'
option 'nis_server_address' '0'
option 'nis_domain_name' '0'
option 'nisp_server_address' '0'
option 'nisp_domain_name' '0'
option 'bcmcs_server_address' '0'
option 'bcmcs_server_domain_name' '0'
 
# Override the used DUID, by default it is derived from the interface MAC
# The given value must be uppercase and globally unique!
#option 'duid' '00:03:00:06:D8:5D:4C:A5:03:F2'
 
# Script to run when a reply is received
option 'script' '/usr/bin/dhcp6c-state'
 
# Define one or more interfaces on which prefixes should be assigned
config 'interface' 'loopback'
option 'enabled' '1'# 1 = enabled; 0 = disabled
option 'sla_id' '0'# Site level aggregator identifier specified in decimal (subnet)
option 'sla_len' '0'# Site level aggregator length (64 - size of prefix being delegated)
# e.g. /60 from ISP -> 64 - 60 = 4
 
config 'interface' 'lan'
option 'enabled' '1'
option 'sla_id' '1'
option 'sla_len' '0'
 


Clever_Proxy
Premium
join:2004-05-14
Villa Park, IL

I haven't worked with OpenWRT or messed with vanilla Linux for v6 routing yet, but I guess the first thing I would do is see what your addresses your interfaces are getting on OpenWRT.

From what I've typically seen, your WAN will get an address (typically starting with 2001::*) and an interface will be created for your LAN side (typically starting with 2601::* for prefix deligation)

Try executing "ip addr" from the command line and see what you're getting.


bvanderhaar

join:2012-07-04

Here's the result of ifconfig. I'm only getting a link local IPv6 address:

br-lan    Link encap:Ethernet  HWaddr F8:D1:XX:XX:XX:XX  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::fad1:11ff:feb7:3952/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6602034 errors:0 dropped:32 overruns:0 frame:0
          TX packets:13336568 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:342167074 (326.3 MiB)  TX bytes:19987424829 (18.6 GiB)
 
eth0      Link encap:Ethernet  HWaddr F8:D1:XX:XX:XX:XX  
          inet6 addr: fe80::fad1:11ff:feb7:3952/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20368967 errors:0 dropped:0 overruns:59212 frame:0
          TX packets:19921007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3355133511 (3.1 GiB)  TX bytes:3286385479 (3.0 GiB)
          Interrupt:4 
 
eth0.1    Link encap:Ethernet  HWaddr F8:D1:XX:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6633776 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13335960 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:351704919 (335.4 MiB)  TX bytes:19987348141 (18.6 GiB)
 
eth0.2    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          inet addr:98.XXX.XXX.XXX  Bcast:98.XXX.XXX.XXX  Mask:255.255.248.0
          inet6 addr: fe80::fad1:11ff:feb7:3952/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13735140 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6585037 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:19816654107 (18.4 GiB)  TX bytes:399220761 (380.7 MiB)
 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3505 (3.4 KiB)  TX bytes:3505 (3.4 KiB)
 
 

Edit: removed more of the MAC


NetFixer
Freedom is NOT Free
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

One big problem I see from your "ip addr" post is that you only have a link local IP address on your WAN interface (as you have noted).

Here is what I see on my WNR1000v2:


BusyBox v1.4.2 (2012-04-17 12:26:16 EDT) Built-in shell (ash)
Enter 'help' for a list of built-in commands.
 
  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (7.09) -----------------------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@WNR1000v2:/# ip addr
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: sit0: <NOARP> mtu 1480 qdisc noop
    link/sit 0.0.0.0 brd 0.0.0.0
3: br0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue
    link/ether a0:21:b7:9c:06:02 brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.1/24 brd 192.168.10.255 scope global br0
    inet6 2601:5:c80:4a:a221:b7ff:fe9c:602/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::a221:b7ff:fe9c:602/64 scope link
       valid_lft forever preferred_lft forever
4: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether a0:21:b7:9c:06:03 brd ff:ff:ff:ff:ff:ff
    inet 67.177.173.18/22 brd 255.255.255.255 scope global eth0
    inet6 2001:558:6016:19:3d2f:1c35:f21d:4e28/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::a221:b7ff:fe9c:603/64 scope link
       valid_lft forever preferred_lft forever
5: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether a0:21:b7:9c:06:02 brd ff:ff:ff:ff:ff:ff
6: wifi0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether a0:21:b7:9c:06:02 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a221:b7ff:fe9c:602/64 scope link
       valid_lft forever preferred_lft forever
7: ath0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether a0:21:b7:9c:06:02 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a221:b7ff:fe9c:602/64 scope link
       valid_lft forever preferred_lft forever
 


Notice the "2001:558" prefix IPv6 address on the WAN (eth0 for me) interface?

When you tested a standalone PC connected directly to your cable modem, are you sure that you were not seeing a 6to4 tunnel IPv6 connection instead of a native dual stack connection? A 6to4 tunnel would start with a "2002" prefix.

The OpenWRT version that Comcast/Netgear uses on my WNR1000v2 is different than what you are using, so I don't have the same config files (and it appears that Comcast/Netgear is hiding some things even though I have a "root" login). However, here are the .conf files and the dhcp6c-script file that I can see from my telnet interface to that router just in case that information might help you:


root@WNR1000v2:/# cat /var/dhcp6c.conf
interface eth0 {
        send ia-na 1;
        send ia-pd 11;
        request domain-name;
        request domain-name-servers;
        request ntp-servers;
        request sip-server-domain-name;
        request sip-server-address;
        script "/etc/net6conf/dhcp6c-script";
};
 
id-assoc na 1 {
};
 
id-assoc pd 11 {
};
root@WNR1000v2:/# cat /var/radvd.conf
interface br0 {
        AdvSendAdvert on;
        AdvCurHopLimit 64;
        MinRtrAdvInterval 198;
        MaxRtrAdvInterval 600;
        AdvDefaultLifetime 1800;
        AdvReachableTime 0;
        AdvRetransTimer 0;
        AdvDefaultPreference low;
        AdvHomeAgentFlag off;
        AdvOtherConfigFlag on;
        AdvManagedFlag off;
        prefix 2601:5:c80:4a::/64 {
                AdvOnLink on;
                AdvAutonomous on;
                AdvValidLifetime 345370;
                AdvPreferredLifetime 345370;
        };
        RDNSS  fe80::a221:b7ff:fe9c:602 {
                AdvRDNSSPreference 8;
                AdvRDNSSLifetime 1200;
        };
};
root@WNR1000v2:/# cat /var/dhcp6s.conf
option domain-name-servers 2001:558:feed::1;
option domain-name-servers 2001:558:feed::2;
 
option domain-name-servers 2001:558:feed::1 2001:558:feed::2 ;
interface br0 {
        allow rapid-commit;
        address-pool pool_netgear 345370 345370;
};
pool pool_netgear {
        range 2601:5:c80:4a::2 to 2601:5:c80:4a::40;
};
 
root@WNR1000v2:/# cat /etc/net6conf/dhcp6c-script
#!/bin/sh
 
. /etc/net6conf/6data.conf
 
#Fix Bug 23366[IPv6-Auto Config] DUT should disable prefix option in Router Advertisement
#message when the prefix valid lifetime is expired.
prefix_timeout() {
        # Remove the LAN side IPv6 address, which has been expired
        # timeout_prefix would be like: 5600 2800 2000:458:ff01:3800:: 56
        prefix_addr=`echo $timeout_prefix |cut -f3 -d' ' |sed s/:://`
        lan6_ip=`ifconfig $bridge |grep "inet6 addr: $prefix" |grep -v "Link" |awk '{print $3}'`
        echo "Try to delete $lan6_ip from $bridge" > /dev/console
        [ "x$lan6_ip" != "x" ] && $IP -6 addr del $lan6_ip dev $bridge
 
        #when prefix is timeout, remove old prefix info files
        rm /tmp/dhcp6c_script_envs
        rm $DHCP6C_PD
        rm $DHCP6S_PD
 
        #reload the LAN side IPv6 related services:
        #rewrite config file: radvd_write_config, dhcp6s_write_config.
        echo "reload 6service" > /dev/console
        /etc/net6conf/6service reload
}
 
#To do prefix timeout envents.
if [ "x$REASON" = "xprefix_timeout" ] ;then
        lan_prefix_info=`cat $DHCP6S_PD`
        #value $timeout_prefix is got from wide-dhcpv6
        [ "$timeout_prefix" != "$lan_prefix_info" ] && exit
        prefix_timeout
        exit
fi
 
#fix the bug 27061[ST/Netgear-67-71--IPv6 DHCP] There is IPv6 address On LAN port in GUI When DUT send a Decline messag.
if [ "x$REASON" = "xdecline" ] ;then
        lan6_ip=`ifconfig $bridge |grep "inet6 addr" |grep -v "Link" |awk '{print $3}'`
        echo "Try to delete $lan6_ip from $bridge" > /dev/console
        [ "x$lan6_ip" != "x" ] && $IP -6 addr del $lan6_ip dev $bridge
 
        #when duplicate address detected, remove old prefix info files
        rm /tmp/dhcp6c_script_envs
        rm $DHCP6S_PD
 
        #After DUT sending decline packet, stop the DHCPv6 server and autoconfigure address service(radvd)
        killall dhcp6s
        killall radvd
        exit
fi
 
del_dns6() {
        sed '/.:./d' /tmp/resolv.conf > /tmp/resolv.conf$$
        mv /tmp/resolv.conf$$ /tmp/resolv.conf
        echo -n "" > $IPV6_DNS
}
 
#the function about deleting rhe repeating dns info.
write_ra_dns(){
        for xr in  `awk '{print $2}'  $1 `
        do
                flagadd="1"
                for xw in `awk '{print $2}' $2 `
                do
                        if [ "1$xr" == "1$xw" ] ; then
                                flagadd="0"
                                continue
                        fi
                done
                if [ "$flagadd" == "1" ] ; then
                        echo "nameserver $xr " >> $2;
                fi
        done
}
 
#write ra_dns to resolv.conf
write_ra_tmp_dns(){
        sed '/.:./d' /tmp/resolv.conf > /tmp/resolv.conf$$
        mv /tmp/resolv.conf$$ /tmp/resolv.conf
        echo -n "" >  $RA_DNS_FILE
        for loop in $new_ra_dns_servers
                do
                        echo "nameserver $loop" >> $RA_DNS_FILE
                done
        write_ra_dns $IPV6_DNS  /tmp/resolv.conf
        write_ra_dns $RA_DNS_FILE  /tmp/resolv.conf
}
#when received ra packet with RDNSS option
local conn_type=`$CONFIG get ipv6_type`
if [ "x$REASON" = "xra_dns" -a  "x$conn_type" = "xautoConfig" ] ; then
        echo "write ra_dns..."  > /dev/console
        write_ra_tmp_dns
fi
 
lease_changed()
{
        local envs_p_file="/tmp/dhcp6c_script_envs"
 
        [ -f "$envs_p_file" ] && . $envs_p_file
        [ -z "$new_domain_name" ] && new_domain_name="$new_domain_name_p"
        [ -z "$new_sip_name" ] && new_sip_name="$new_sip_name_p"
        [ -z "$new_domain_name_servers" ] && new_domain_name_servers="$new_domain_name_servers_p"
        [ -z "$new_ntp_servers" ] && new_ntp_servers="$new_ntp_servers_p"
        [ -z "$new_sip_servers" ] && new_sip_servers="$new_sip_servers_p"
        cat > $envs_p_file << EOF
new_domain_name_p="$new_domain_name"
new_sip_name_p="$new_sip_name"
new_domain_name_servers_p="$new_domain_name_servers"
new_ntp_servers_p="$new_ntp_servers"
new_sip_servers_p="$new_sip_servers"
EOF
 
        [ "$new_domain_name" != "$new_domain_name_p" ] && return 0
        [ "$new_sip_name" != "$new_sip_name_p" ] && return 0
        [ "$new_domain_name_servers" != "$new_domain_name_servers_p" ] && return 0
        [ "$new_ntp_servers" != "$new_ntp_servers_p" ] && return 0
        [ "$new_sip_servers" != "$new_sip_servers_p" ] && return 0
        if [ "x$REASON" = "xNBI" ] ;then
                [ -f "$DHCP6C_PD" ] && . $DHCP6C_PD
                [ -z "$new_prefix" ] && new_prefix="$prefix_p"
                cat > $DHCP6C_PD << EOF
prefix_p="$new_prefix"
EOF
                [ "$new_prefix" != "$prefix_p" ] && return 0
        fi
 
        return 1
}
 
# if dhcp6c lease is not changed, don't need to do anything.
lease_changed || exit 0
#if the prefix changed, we delete all the ip of the bridge
if [ "$new_prefix" != "$prefix_p" ];then
        pre_ip=`ifconfig $bridge |grep "inet6 addr" |grep -v "Link" |awk '{print $3}'`
        for loop in $pre_ip
        do
                $IP -6 addr del $loop dev $bridge
        done
fi
 
echo "dhcp6c lease changed !" > /dev/console
 
# wirte the dhcp6s_pd and dhcp6s_dsn file
 
        if [ "x$new_prefix" != "x" ]; then
                echo $new_prefix > $DHCP6S_PD
                echo "DHCP" > /tmp/ipv6_auto_output
        fi
 
        # for avoid adding more line
        echo " " > $DHCP6S_DSN
 
        for loop in $new_domain_name
        do
                echo "option domain-name \"$loop\";" >> $DHCP6S_DSN
        done
 
        for loop in $new_sip_name
        do
                echo "option sip-server-domain-name \"$loop\";" >> $DHCP6S_DSN
        done
 
# According to NTGR Router Spec:
# The domain-name-servers should be DUT's IPv6 LAN interface's link local address.
# The link local address could be added in net6conf/6service script, so comment below code.
#       if [ "x$new_domain_name_servers" != "x" ]; then
#               echo "option domain-name-servers $new_domain_name_servers;" >> $DHCP6S_DSN
#       fi
# Comcast requires us to fill domain-name-servers with Comcast provisioning Server.
        if [ "x$new_domain_name_servers" != "x" ]; then
                echo "option domain-name-servers $new_domain_name_servers;" >> $DHCP6S_DSN
        fi
 
        del_dns6
        for loop in $new_domain_name_servers
        do
                echo "nameserver $loop" >> $IPV6_DNS
        done
        if [ "x$conn_type" = "xautoConfig" ] ; then
                write_ra_dns $RA_DNS_FILE  /tmp/resolv.conf
        fi
        write_ra_dns $IPV6_DNS  /tmp/resolv.conf
 
        if [ "x$new_ntp_servers" != "x" ]; then
                echo "option ntp-servers $new_ntp_servers;" >> $DHCP6S_DSN
        fi
 
        if [ "x$new_sip_servers" != "x" ]; then
                echo "option sip-server-address $new_sip_servers;" >> $DHCP6S_DSN
        fi
 
if [ -s $DHCP6S_PD ] && [ -s $DHCP6S_CONF ]; then
        if ! grep "address-pool " >&- 2>&- $DHCP6S_CONF; then
                echo "Got the prefix, reload the config file" > /dev/console
                echo "The prefix for LAN is $new_prefix" > /dev/console
                srv_reload="1"
        fi
fi
 
        if ps | grep dhcp6s | grep -v grep >&- 2>&- ; then
                echo "dhcpv6 server is running, reload dhcp6s config file !"
                /etc/net6conf/6service reload
        fi
 



--
We can never have enough of nature.
We need to witness our own limits transgressed, and some life pasturing freely where we never wander.


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
reply to bvanderhaar

I see a few problems with your dhcp6c.conf that would prevent PD from working. (I'll give you some guidance tomorrow).

Don't think it would prevent dhcp6 from working on the on-link interface though.

One silly thing to check for right now is to make sure the dhcp6c client is actually running.

ps aux | grep 'dhcp6c'


bvanderhaar

join:2012-07-04

dhcp6c appears to be running:
1071 root 928 S /usr/sbin/dhcp6c -c /var/etc/dhcp6c.conf -D eth0.2


CMoore2004
Premium
join:2003-02-06
Jonesville, MI

4 edits

If you're absolutely sure they have proper IPv6 instead of 6to4 tunneling in your area... here's my working dhcp6c.conf

root@WZR-HP-AG300H:~# cat /var/etc/dhcp6c.conf
interface eth1 {
        send ia-pd 0;
        send ia-na 0;
        script "/usr/bin/dhcp6c-state";
        request domain-name-servers;
};
 
id-assoc pd 0 {
        prefix-interface br-lan {
                sla-id 1;
                sla-len 0;
        };
};
 
id-assoc na 0 {
};
 

Here are my installed packages
base-files - 117-r34185
busybox - 1.19.4-5
detect-new-ip6 - 0.7-1
dhcp6-client - 1.0-1
dnsmasq - 2.62-2
dropbear - 2011.54-2
firewall - 2-53
hotplug2 - 1.0-beta-4
ip - 3.3.0-1
ip6tables - 1.4.10-4
iptables - 1.4.10-4
iputils-traceroute6 - 20101006-1
iw - 3.6-1
jshn - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
kernel - 3.3.8-1-5440da3a2c45184a32da6bba25b8dd2a
kmod-ath - 3.3.8+2012-09-07-3
kmod-ath9k - 3.3.8+2012-09-07-3
kmod-ath9k-common - 3.3.8+2012-09-07-3
kmod-cfg80211 - 3.3.8+2012-09-07-3
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-gpio-button-hotplug - 3.3.8-1
kmod-ip6tables - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-ipv6 - 3.3.8-1
kmod-leds-gpio - 3.3.8-1
kmod-ledtrig-default-on - 3.3.8-1
kmod-ledtrig-netdev - 3.3.8-1
kmod-ledtrig-timer - 3.3.8-1
kmod-ledtrig-usbdev - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-mac80211 - 3.3.8+2012-09-07-3
kmod-nls-base - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-pppoe - 3.3.8-1
kmod-pppox - 3.3.8-1
kmod-usb-core - 3.3.8-1
kmod-usb-ohci - 3.3.8-1
kmod-usb2 - 3.3.8-1
kmod-wdt-ath79 - 3.3.8-1
libblobmsg-json - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libc - 0.9.33.2-1
libdaemon - 0.14-2
libgcc - 4.6-linaro-1
libip4tc - 1.4.10-4
libip6tc - 1.4.10-4
libiwinfo - 36
libiwinfo-lua - 36
libjson - 0.9-2
liblua - 5.1.4-8
libncurses - 5.7-5
libnl-tiny - 0.1-3
libpcap - 1.1.1-2
libpthread - 0.9.33.2-1
librt - 0.9.33.2-1
libubox - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libubus-lua - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libuci - 2012-03-28.1-1
libuci-lua - 2012-03-28.1-1
libxtables - 1.4.10-4
lua - 5.1.4-8
luci - 0.11+svn9425-1
luci-app-firewall - 0.11+svn9425-1
luci-i18n-english - 0.11+svn9425-1
luci-lib-core - 0.11+svn9425-1
luci-lib-ipkg - 0.11+svn9425-1
luci-lib-lmo - 0.11+svn9425-1
luci-lib-nixio - 0.11+svn9425-1
luci-lib-sys - 0.11+svn9425-1
luci-lib-web - 0.11+svn9425-1
luci-mod-admin-core - 0.11+svn9425-1
luci-mod-admin-full - 0.11+svn9425-1
luci-proto-core - 0.11+svn9425-1
luci-proto-ppp - 0.11+svn9425-1
luci-sgi-cgi - 0.11+svn9425-1
luci-theme-base - 0.11+svn9425-1
luci-theme-openwrt - 0.11+svn9425-1
mtd - 18.1
netifd - 2012-10-19-a9fd870450e82f31cba681651656276dfc1c39ac
opkg - 618-2
ppp - 2.4.5-7
ppp-mod-pppoe - 2.4.5-7
radvd - 1.9.1-2
swconfig - 10
tcpdump - 4.2.1-2
terminfo - 5.7-5
uboot-envtools - 2012.04.01-1
ubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
ubusd - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
uci - 2012-03-28.1-1
uhttpd - 2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd
wide-dhcpv6-client - 20080615-11
wide-dhcpv6-server - 20080615-11
wpad-mini - 20120910-1

Make sure to enable the proper packages so they're run at startup and be sure they're running.

Here's my ifconfig output:
br-lan    Link encap:Ethernet  HWaddr 10:6F:3F:XX:XX:XX
          inet addr:172.16.1.1  Bcast:172.16.1.255  Mask:255.255.255.0
          inet6 addr: 2601:4:3500:35:126f:3fff:fe28:xxxx/64 Scope:Global
          inet6 addr: fe80::126f:3fff:fe28:xxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11410697 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21575426 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:874781380 (834.2 MiB)  TX bytes:30647430101 (28.5 GiB)
 
eth0      Link encap:Ethernet  HWaddr 10:6F:XX:XX:XX:XX
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5679448 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12544092 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:379629909 (362.0 MiB)  TX bytes:1452172592 (1.3 GiB)
          Interrupt:4
 
eth1      Link encap:Ethernet  HWaddr 10:6F:XX:XX:XX:XX
          inet addr:68.41.11.10  Bcast:68.41.11.255  Mask:255.255.252.0
          inet6 addr: 2001:558:6007:6a:20c9:35a5:xxxx:xxxx/128 Scope:Global
          inet6 addr: fe80::126f:3fff:xxxx:xxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32058132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11283941 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1261719809 (1.1 GiB)  TX bytes:1023844820 (976.4 MiB)
          Interrupt:5
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:799 errors:0 dropped:0 overruns:0 frame:0
          TX packets:799 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:135540 (132.3 KiB)  TX bytes:135540 (132.3 KiB)
 
wlan0     Link encap:Ethernet  HWaddr 10:6F:XX:XX:XX:XX
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2329399 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3816588 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:289777427 (276.3 MiB)  TX bytes:363251825 (346.4 MiB)
 
wlan1     Link encap:Ethernet  HWaddr 10:6F:3F:XX:XX:XX
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3435344 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5848396 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:374814256 (357.4 MiB)  TX bytes:3313698523 (3.0 GiB)
 

And... my RADVD configuration:
root@WZR-HP-AG300H:~# cat /var/etc/radvd.conf
interface br-lan
{
        AdvSendAdvert on;
        AdvManagedFlag off;
        AdvOtherConfigFlag off;
 
        prefix 2601:4:3500:35:126f:3fff:xxxx:xxxx/64
        {
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr off;
        };
};
 

And lastly, my /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '172.16.1.1'
#       option broadcast '1'
#       option accept_ra '0'
#       option send_rs '1'
 
config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option hostname 'WZR-HP-AG300H'
        option broadcast '1'
        option accept_ra '1'
        option send_rs '0'
        option ipv6 '1'
 
config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'
 

I wasn't aware there was some script to update the prefix, I'll look into modifying the script posted above earlier so I don't have anything configured static.

Edit: Fixed things, masked a few things... like 3 times.

bvanderhaar

join:2012-07-04

Thanks for posting your configuration. I only have subtle differences in configuration - /var/etc/radvd.conf does not have the prefix section and /var/etc/dhcp6c.conf has an additional section within id-assoc pd 0.

id-assoc pd 0 {
        prefix-interface lo {
                sla-id 0;
                sla-len 0;
        };
        prefix-interface br-lan {
                sla-id 1;
                sla-len 0;
        };
};
 

I'm thinking my area is 6to4 and not native IPv6 as I originally thought. I'll have to hookup my laptop again when I get home to verify.

bvanderhaar

join:2012-07-04

It appears my area is not native IPv6 (or at least not anymore).

When I first hooked up Comcast about 4 months ago, I remember scoring a 10/10 on test-ipv6 and verifying I had native IPv6. I've switched modems since then, but that is all that has changed. Thanks everyone for your help, at least I know I'm ready when native IPv6 arrives.



aefstoggaflm
Open Source Fan
Premium
join:2002-03-04
Bethlehem, PA
kudos:7
Reviews:
·PenTeleData
·Verizon Online DSL

said by bvanderhaar:

It appears my area is not native IPv6 (or at least not anymore).

When I first hooked up Comcast about 4 months ago, I remember scoring a 10/10 on test-ipv6 and verifying I had native IPv6. I've switched modems since then, but that is all that has changed.

What is the brand and model of your new modem?
--
Please use the "yellow (IM) envelope" to contact me and please leave the URL intact.

bvanderhaar

join:2012-07-04

Zoom 5341J. My modem died about 30 days after installation. Zoom sent me a replacement. So I swapped for the same model & brand, just a different physical modem.



whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast

said by bvanderhaar:

Zoom 5341J. My modem died about 30 days after installation. Zoom sent me a replacement. So I swapped for the same model & brand, just a different physical modem.

You should give NetDog a PM to have him check your CMTS for v6. Just provide him with your modem's MAC and your IPv4 address.

bvanderhaar

join:2012-07-04

PM sent. I'll let you know what he finds.