dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
4155
share rss forum feed

bvanderhaar

join:2012-07-04

[IPv6] OpenWRT and Comcast IPv6

Plugging my Zoom 5341J directly to my Windows 7 laptop, I have both IPv4 and IPv6 connectivity (according to »test-ipv6.com/). Now I'm trying to get IPv6 working with my router.

Following the OpenWRT docs (»wiki.openwrt.org/doc/howto/ipv6. ··· ipv6.isp and »wiki.openwrt.org/doc/howto/ipv6. ··· sentials), I've got radvd and dhcp6c setup on my OpenWRT Attitude Adjustment RC1 box (TL-WR1043ND). However, I'm not receiving an IPv6 on my WAN address. I'm comfortable with config files and linux environments, but unfamiliar with radvd and dhcp6c. I have a feeling my configs are not quite right, but I've tried enabling and disabling various settings with no success. Some direction of where I'm going wrong would be very helpful. I'll definitely share what I did when I have success.

Here's my ping6 result:

Here's my configs:
/etc/config/network
/etc/config/radvd:
/etc/config/dhcp6c:


Clever_Proxy
Premium
join:2004-05-14
Villa Park, IL
I haven't worked with OpenWRT or messed with vanilla Linux for v6 routing yet, but I guess the first thing I would do is see what your addresses your interfaces are getting on OpenWRT.

From what I've typically seen, your WAN will get an address (typically starting with 2001::*) and an interface will be created for your LAN side (typically starting with 2601::* for prefix deligation)

Try executing "ip addr" from the command line and see what you're getting.

bvanderhaar

join:2012-07-04
Here's the result of ifconfig. I'm only getting a link local IPv6 address:

Edit: removed more of the MAC


NetFixer
Bah Humbug
Premium
join:2004-06-24
The Boro
Reviews:
·Vonage
·Comcast Business..
·Cingular Wireless
One big problem I see from your "ip addr" post is that you only have a link local IP address on your WAN interface (as you have noted).

Here is what I see on my WNR1000v2:




Notice the "2001:558" prefix IPv6 address on the WAN (eth0 for me) interface?

When you tested a standalone PC connected directly to your cable modem, are you sure that you were not seeing a 6to4 tunnel IPv6 connection instead of a native dual stack connection? A 6to4 tunnel would start with a "2002" prefix.

The OpenWRT version that Comcast/Netgear uses on my WNR1000v2 is different than what you are using, so I don't have the same config files (and it appears that Comcast/Netgear is hiding some things even though I have a "root" login). However, here are the .conf files and the dhcp6c-script file that I can see from my telnet interface to that router just in case that information might help you:





--
We can never have enough of nature.
We need to witness our own limits transgressed, and some life pasturing freely where we never wander.


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
reply to bvanderhaar
I see a few problems with your dhcp6c.conf that would prevent PD from working. (I'll give you some guidance tomorrow).

Don't think it would prevent dhcp6 from working on the on-link interface though.

One silly thing to check for right now is to make sure the dhcp6c client is actually running.

ps aux | grep 'dhcp6c'

bvanderhaar

join:2012-07-04
dhcp6c appears to be running:
1071 root 928 S /usr/sbin/dhcp6c -c /var/etc/dhcp6c.conf -D eth0.2

CMoore2004
Premium
join:2003-02-06
Jonesville, MI

4 edits
If you're absolutely sure they have proper IPv6 instead of 6to4 tunneling in your area... here's my working dhcp6c.conf

Here are my installed packages
base-files - 117-r34185
busybox - 1.19.4-5
detect-new-ip6 - 0.7-1
dhcp6-client - 1.0-1
dnsmasq - 2.62-2
dropbear - 2011.54-2
firewall - 2-53
hotplug2 - 1.0-beta-4
ip - 3.3.0-1
ip6tables - 1.4.10-4
iptables - 1.4.10-4
iputils-traceroute6 - 20101006-1
iw - 3.6-1
jshn - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
kernel - 3.3.8-1-5440da3a2c45184a32da6bba25b8dd2a
kmod-ath - 3.3.8+2012-09-07-3
kmod-ath9k - 3.3.8+2012-09-07-3
kmod-ath9k-common - 3.3.8+2012-09-07-3
kmod-cfg80211 - 3.3.8+2012-09-07-3
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-gpio-button-hotplug - 3.3.8-1
kmod-ip6tables - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-ipv6 - 3.3.8-1
kmod-leds-gpio - 3.3.8-1
kmod-ledtrig-default-on - 3.3.8-1
kmod-ledtrig-netdev - 3.3.8-1
kmod-ledtrig-timer - 3.3.8-1
kmod-ledtrig-usbdev - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-mac80211 - 3.3.8+2012-09-07-3
kmod-nls-base - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-pppoe - 3.3.8-1
kmod-pppox - 3.3.8-1
kmod-usb-core - 3.3.8-1
kmod-usb-ohci - 3.3.8-1
kmod-usb2 - 3.3.8-1
kmod-wdt-ath79 - 3.3.8-1
libblobmsg-json - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libc - 0.9.33.2-1
libdaemon - 0.14-2
libgcc - 4.6-linaro-1
libip4tc - 1.4.10-4
libip6tc - 1.4.10-4
libiwinfo - 36
libiwinfo-lua - 36
libjson - 0.9-2
liblua - 5.1.4-8
libncurses - 5.7-5
libnl-tiny - 0.1-3
libpcap - 1.1.1-2
libpthread - 0.9.33.2-1
librt - 0.9.33.2-1
libubox - 2012-10-31.1-407f7a0bb3272ee03f2eb05391ce8b94238fa92e
libubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libubus-lua - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libuci - 2012-03-28.1-1
libuci-lua - 2012-03-28.1-1
libxtables - 1.4.10-4
lua - 5.1.4-8
luci - 0.11+svn9425-1
luci-app-firewall - 0.11+svn9425-1
luci-i18n-english - 0.11+svn9425-1
luci-lib-core - 0.11+svn9425-1
luci-lib-ipkg - 0.11+svn9425-1
luci-lib-lmo - 0.11+svn9425-1
luci-lib-nixio - 0.11+svn9425-1
luci-lib-sys - 0.11+svn9425-1
luci-lib-web - 0.11+svn9425-1
luci-mod-admin-core - 0.11+svn9425-1
luci-mod-admin-full - 0.11+svn9425-1
luci-proto-core - 0.11+svn9425-1
luci-proto-ppp - 0.11+svn9425-1
luci-sgi-cgi - 0.11+svn9425-1
luci-theme-base - 0.11+svn9425-1
luci-theme-openwrt - 0.11+svn9425-1
mtd - 18.1
netifd - 2012-10-19-a9fd870450e82f31cba681651656276dfc1c39ac
opkg - 618-2
ppp - 2.4.5-7
ppp-mod-pppoe - 2.4.5-7
radvd - 1.9.1-2
swconfig - 10
tcpdump - 4.2.1-2
terminfo - 5.7-5
uboot-envtools - 2012.04.01-1
ubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
ubusd - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
uci - 2012-03-28.1-1
uhttpd - 2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd
wide-dhcpv6-client - 20080615-11
wide-dhcpv6-server - 20080615-11
wpad-mini - 20120910-1

Make sure to enable the proper packages so they're run at startup and be sure they're running.

Here's my ifconfig output:

And... my RADVD configuration:

And lastly, my /etc/config/network

I wasn't aware there was some script to update the prefix, I'll look into modifying the script posted above earlier so I don't have anything configured static.

Edit: Fixed things, masked a few things... like 3 times.

bvanderhaar

join:2012-07-04
Thanks for posting your configuration. I only have subtle differences in configuration - /var/etc/radvd.conf does not have the prefix section and /var/etc/dhcp6c.conf has an additional section within id-assoc pd 0.


I'm thinking my area is 6to4 and not native IPv6 as I originally thought. I'll have to hookup my laptop again when I get home to verify.

bvanderhaar

join:2012-07-04
It appears my area is not native IPv6 (or at least not anymore).

When I first hooked up Comcast about 4 months ago, I remember scoring a 10/10 on test-ipv6 and verifying I had native IPv6. I've switched modems since then, but that is all that has changed. Thanks everyone for your help, at least I know I'm ready when native IPv6 arrives.


aefstoggaflm
Open Source Fan
Premium
join:2002-03-04
Bethlehem, PA
kudos:8
Reviews:
·PenTeleData
·Verizon Online DSL
said by bvanderhaar:

It appears my area is not native IPv6 (or at least not anymore).

When I first hooked up Comcast about 4 months ago, I remember scoring a 10/10 on test-ipv6 and verifying I had native IPv6. I've switched modems since then, but that is all that has changed.

What is the brand and model of your new modem?
--
Please use the "yellow (IM) envelope" to contact me and please leave the URL intact.

bvanderhaar

join:2012-07-04
Zoom 5341J. My modem died about 30 days after installation. Zoom sent me a replacement. So I swapped for the same model & brand, just a different physical modem.


whfsdude
Premium
join:2003-04-05
Washington, DC
Reviews:
·Comcast
said by bvanderhaar:

Zoom 5341J. My modem died about 30 days after installation. Zoom sent me a replacement. So I swapped for the same model & brand, just a different physical modem.

You should give NetDog a PM to have him check your CMTS for v6. Just provide him with your modem's MAC and your IPv4 address.

bvanderhaar

join:2012-07-04
PM sent. I'll let you know what he finds.