dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2579
share rss forum feed

spudz72

join:2010-03-25
Belleville, ON

[Voip.ms] Panasonic KX-TGP551 that keeps flipping out!

Yes that is a strange subject I know, but it's true! I purchased this Base with 1 handset to test for my business as the Gigaset DECT Sip phones have been just way to buggy for me. I have been using this Panasonic for about a month now and other then this strange situation with the base flipping out every so often I find it is much better then the comparable Gigaset. I just need to know if anyone else have ever experience my issues?

What happens is randomly the base and the handset will starting ringing all 3 lines non stop! I have voicemail setup with voip.ms for my toll free line an that is the only sip account setup on the phone. The thing is the call doesn't seem to be coming from voip.ms. The CID always seems to show something different on the display, I have seen 1000 or yesterday it said IPPhone on the display. The only way to stop it from ringing non stop is to pickup up the handset and then hang it up 3 times for each of the 3 incoming calls. The annoying thing is it will do this sometimes at say 3 or 4 in the morning and it wakes me up! I made a quick video showing this happening and will upload it to youtube and attach it here so you can see what I mean. I have checked the call logs at voip.ms and there is nothing there, so I know it's not coming from them. Just wish I knew where it was coming from!

Has anyone else with this phone or the KX-TGP550 had this issue?

toro

join:2006-01-27
Scarborough, ON
kudos:7
Reviews:
·Rogers Hi-Speed
·Bell Sympatico
Do you have port 5060 open (forwarded to your panasonic phone) ? It sounds like someone is probing your ip address hoping to find an unsecured ip pbx.
Try setting the phone to listen on a port other than 5060.
--
Providers (through asterisk): voip.ms, freephoneline, smartcall.ro. Hardware: Vonage VDV21, Moto VT2x42, Linksys SPA series, Grandstream HT series, Panasonic KX-TGP5x0
»www.voipfan.net

Stewart

join:2005-07-13
kudos:25
reply to spudz72
This sounds like the malformed hacker probes are somehow confusing the phone. Try changing SIP Source Port for Line 1 from 5060 to e.g. 5064. If you had to forward UDP port 5060 in your router (to work around an unrelated problem), then forward the new port instead.

DaveSin

join:2009-07-17
reply to spudz72
The same thing is happening to a OBi ATA user:

Hi, 
 
I have a problem, for a couple of day now, we keep getting call with weird id 'ipphone', 'test', 'smallgw', 'user1'.
We get some in the night while we sleep, it call one time, nobody on the line then it call again 30 seconds after we hang.
 
On my obi110, I have my voip.ms account and an outbound only google voice.
I doesn't come from my voip.ms account since it would register them.
 
Here is an xml export of the call 
http://www.pastebin.ca/2298053
 
 

»www.obitalk.com/forum/index.php?topic=4922.0

zapattack

join:2012-07-02
CANADA
In the setup help for PBXes.org is a section called Alternative Ports:
"53, 69, 80, 135, 161, 443, 500, 1433, 1701, 1812, 3389, 4500, 5061, 5900, 16999, 26999, 36999 (recommended)"
I run a DD-WRT router and use 26999 and 36999 (random assignments) for both GV and PBXes with no problems.
No port forwarding used.


Trimline
Premium
join:2004-10-24
Windermere, FL
Reviews:
·ObiVoice
·Bright House
·Callcentric
·voip.ms
reply to spudz72
I had this happen to me when the LENGTH of the incoming caller ID and number exceeded the characters allotted on the phone. It would ring like crazy, then the handset reboot. The caller ID was not really recognizable.

I'll have to dig around, but I do remember changing a setting somewhere....either on the phone, MS or Asterisk. Perhaps someone else has seen this too.

PX Eliezer70
Premium
join:2008-08-09
Hutt River
kudos:13
Reviews:
·callwithus
·voip.ms
reply to spudz72
said by spudz72:

Has anyone else with this phone or the KX-TGP550 had this issue?

I have the Panasonic KX-TGP551 and have never had this issue.

Curious, is your phone behind a router?


rollerblader7

join:2004-01-11
Burlington, ON
reply to spudz72
said by spudz72:

Has anyone else with this phone or the KX-TGP550 had this issue?

no problem here. Same phone.... voip.ms and callcentric. behind a router using non-standard port but only UDP ports are forwarded.

spudz72

join:2010-03-25
Belleville, ON
reply to toro
said by toro:

Do you have port 5060 open (forwarded to your panasonic phone) ? It sounds like someone is probing your ip address hoping to find an unsecured ip pbx.
Try setting the phone to listen on a port other than 5060.

I checked and yes I do have port 5060 open and forwarded to my Panasonic Phone. I did notice however that it was forwarded to 192.168.0.135 and the when checking the ip of the panasonic base I see it had changed at some point to 192.168.0.136 so to get around that just now I turned off DHCP on the base and gave it a static IP of 192.168.0.162 so it will stay this way forever. On my router I changed the 5060 port from the old ip to the new static IP of the phone.

To add some more info I also have a Gigaset DX800A base which I'm using at the same time as I only have 1 handset for the panasonic so only using the panasonic for my toll free (business) line and the gigaset is still be using for the residence. I recall I had to have each base with different ports so I could get them both to work at the same time as I was having some problems with the phone not ringing. So the Panasonic is set for 5060 and the Gigaset it set for 5061. I have never now or in the past (before I had the Panasonic) saw the Gigaset have this problem.

spudz72

join:2010-03-25
Belleville, ON
reply to PX Eliezer70
Hmm. Yes my phone is behind a router. With voip.ms I have my toll free did setup with the hours enabled, so the phone shouldn't ring weekdays after 7pm and never on weekends since we aren't open then, and this problem still happens on weekends and after hours so that's how I know it's not an actual customer calling through voip.ms.

I check the CID on the phone and the calls so far this weekend are shown as...

Dec 30th 12:34am with CID = ipphone
Dec 30th 12:33am with CID = ipphone
Dec 29th 6:07pm with CID = as12345
Dec 29th 2:23am with CID = user1
Dec 28th 8:29pm with CID = 1000

So problem is very similar to what the person using the OBi ATA that DaveSin mentioned above.


Trimline
Premium
join:2004-10-24
Windermere, FL
Reviews:
·ObiVoice
·Bright House
·Callcentric
·voip.ms

1 recommendation

reply to spudz72
said by spudz72:

said by toro:

Do you have port 5060 open (forwarded to your panasonic phone) ? It sounds like someone is probing your ip address hoping to find an unsecured ip pbx.
Try setting the phone to listen on a port other than 5060.

. On my router I changed the 5060 port from the old ip to the new static IP of the phone.

I'm not sure you need to port forward 5060 to your phone. This may be the issue when port scanners are looking for an open vulnerability. Could you try without a port forward?

spudz72

join:2010-03-25
Belleville, ON
said by Trimline:

said by spudz72:

said by toro:

Do you have port 5060 open (forwarded to your panasonic phone) ? It sounds like someone is probing your ip address hoping to find an unsecured ip pbx.
Try setting the phone to listen on a port other than 5060.

. On my router I changed the 5060 port from the old ip to the new static IP of the phone.

I'm not sure you need to port forward 5060 to your phone. This may be the issue when port scanners are looking for an open vulnerability. Could you try without a port forward?

I think I needed to port forward or else I couldn't get my Gigaset to work at the same time. However since I received another annoying ringing this morning at 2:40am waking me up (this time CID showed test1 on the display), I want to get this fixed as it is driving me nuts.

So I tried changing the ports on the web interface of the Panasonic from the default of 5060, but no matter what port I change it to I cannot get it to register with voip.ms! It just keeps saying registering but will never register. I tried some of the recommended ports above but no go. I tried 16999, 5900, and then 5062, and no matter what it won't register?

I should mention that I am changing a bunch of the sections from 5060 to another port according to the wiki at voip.ms for the Panasonic below...

»wiki.voip.ms/article/Panasonic_KX-TGP_550

So I changed Registrar Server Port, Proxy Server Port, Presence Server Port, and SIP Source Domain. I assume i need to change every one of those to the new port I want?

The instant I changed all those ports back to 5060 on SIP Settings Line 1 it instantly registered with voip.ms again.

Any ideas?

grand total

join:2005-10-26
Mississauga
kudos:2
Change ONLY the SIP Source Port to something else e.g. 12345. All the others should be 5060. Do not set up a port forward to it unless you need to.

spudz72

join:2010-03-25
Belleville, ON
said by grand total:

Change ONLY the SIP Source Port to something else e.g. 12345. All the others should be 5060. Do not set up a port forward to it unless you need to.

Thanks. I wondered about that. I set the SIP Source Port to 16999 and it's still registered.

So will leave off port forwarding for now and see if this still happens.. fingers crossed... Thanks.

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo
said by spudz72:

Thanks. I wondered about that. I set the SIP Source Port to 16999 and it's still registered.

So will leave off port forwarding for now and see if this still happens.. fingers crossed... Thanks.

The real test is whether you can receive a call or not. More specifically whether you can receive a call after the phone has remained unused for a period, for example, overnight. If you can then you do not need to port forward.

What value do you have for "Keep Alive Interval"?
--
DPC3825 (bridged mode) - WRT610N + Tomato - Panasonic KX-TGP500 - Asterisk 11.0.2 on Virtual Server
Anveo - FreePhoneLine - Voxbeam - Numbergroup - Callcentric - VoIP.MS - Localphone - UKDDI

spudz72

join:2010-03-25
Belleville, ON
said by grand total:

said by spudz72:

Thanks. I wondered about that. I set the SIP Source Port to 16999 and it's still registered.

So will leave off port forwarding for now and see if this still happens.. fingers crossed... Thanks.

The real test is whether you can receive a call or not. More specifically whether you can receive a call after the phone has remained unused for a period, for example, overnight. If you can then you do not need to port forward.

What value do you have for "Keep Alive Interval"?

Actually now that you mention that I can't get the panasonic phone to ring at all now wether the 16999 port is forwarded or not. When it wasn't forwarded if I called my toll free line which is what's set on the panasonic for SIP Line 1 it's doesn't ring and go straight to voicemail. Even after forwarding port 16999 to the ip of the panasonic phone it still won't ring and goes straight to voicemail.

Very frustrating..

DaveSin

join:2009-07-17

1 edit
reply to PX Eliezer70
I also have the Panasonic KX-TGP551 and haven't experienced this so far. I have no port forwarding to the KX-TGP551 and have multiple ATAs on the same LAN.

If these calls had "standard" Callerid, you could block them using the Call Control option under Telephone. I tried using letters (or combination of letters and numbers), but it would not accept these as a "Phone Numbers". It did accept "1000" as one of the Call Rejection Phone Numbers, but I have no way at thhis time to check incoming calls with a callerid as "1000" to see if it works.

The OBi ATA has the ability to block just about anything, not the Panasonic.

EDIT: You could block the IP address at the your Router if these "calls" are coming in from a specific IP address (or IP range).

said by PX Eliezer70:

said by spudz72:

Has anyone else with this phone or the KX-TGP550 had this issue?

I have the Panasonic KX-TGP551 and have never had this issue.

Curious, is your phone behind a router?


grand total

join:2005-10-26
Mississauga
kudos:2
reply to spudz72
What sort of router do you have (make and model)?

spudz72

join:2010-03-25
Belleville, ON
reply to grand total
Forgot to answer about the keep alive setting. I checked and it appears to be set for the default of 0 which says it is disabled.

spudz72

join:2010-03-25
Belleville, ON
reply to grand total
said by grand total:

What sort of router do you have (make and model)?

My router is a Linksys E2000.

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo
reply to spudz72
said by spudz72:

Forgot to answer about the keep alive setting. I checked and it appears to be set for the default of 0 which says it is disabled.

Set it to 15. You will need to do this if you are to stand any chance of not needing to forward ports because your registration interval is 3600 seconds by default. I'm assuming you have not changed the phone's registration interval (not configurable in the web UI).

But first, before we go any further, try connecting your phone directly to your modem, i.e. without your router, and check that you can get the phone to ring.
--
DPC3825 (bridged mode) - WRT610N + Tomato - Panasonic KX-TGP500 - Asterisk 11.0.2 on Virtual Server
Anveo - FreePhoneLine - Voxbeam - Numbergroup - Callcentric - VoIP.MS - Localphone - UKDDI

DaveSin

join:2009-07-17

1 edit
reply to spudz72
Below is the working Port settings I have for VOIP.ms on the Panasonic KX-TGP551.

Registrar Server Port         [5070]
Proxy Server Port             [5070]
Presence Server Port          [5070]
Outbound Proxy Server Port    [5060] ***
Source Port                   [5070]
 

*** I think this needs to be set to 5060 in order to get the device to registered.

spudz72

join:2010-03-25
Belleville, ON
said by DaveSin:

Below is the working Port settings I have for VOIP.ms on the Panasonic KX-TGP551.

Registrar Server Port         [5070]
Proxy Server Port             [5070]
Presence Server Port          [5070]
Outbound Proxy Server Port    [5060] ***
Source Port                   [5070]
 

*** I think this needs to be set to 5060 in order to get the device to registered.

No go for me. Won't even let me save those settings. Gives the error in red "Failed (Parameter Error)" after clicking the save button.

spudz72

join:2010-03-25
Belleville, ON

1 edit
reply to grand total
said by grand total:

said by spudz72:

Forgot to answer about the keep alive setting. I checked and it appears to be set for the default of 0 which says it is disabled.

Set it to 15. You will need to do this if you are to stand any chance of not needing to forward ports because your registration interval is 3600 seconds by default. I'm assuming you have not changed the phone's registration interval (not configurable in the web UI).

But first, before we go any further, try connecting your phone directly to your modem, i.e. without your router, and check that you can get the phone to ring.

Ok I set the Keepalive to 15. I have not changed the phones registration interval ever.

Just now I changed only the SIP Source Port to 16999 and all other ports are still set for 5060 and after changing keepalive to 15 I tried calling my toll free number and the phone rang. This is without port forwarding and the phone is plugged into the router. So we will see if this remains this way after a while. If I have problems I will connect it directly to my modem and report back.. Thanks.


XCOM
digitalnUll
Premium
join:2002-06-10
Spring, TX
del
--
[nUll@dcypher ~]$

zapattack

join:2012-07-02
CANADA
reply to grand total
The V.MS Wiki notes the recommended Reg Expire of 180s can only be set with a config. file for a Panasonic.
Can someone explain the relationship between Registration Period and RegisterExpires settings?
The OBi defaults are 60/3600.

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo
reply to spudz72
said by spudz72:

Ok I set the Keepalive to 15. I have not changed the phones registration interval ever.

Just now I changed only the SIP Source Port to 16999 and all other ports are still set for 5060 and after changing keepalive to 15 I tried calling my toll free number and the phone rang. This is without port forwarding and the phone is plugged into the router. So we will see if this remains this way after a while. If I have problems I will connect it directly to my modem and report back. Thanks.

It looks like I was careless with my terms, I wrote "registration interval" but what I should have written is "REG_EXPIRE_TIME" which defaults to 3600 seconds and is the length of time that registration remains valid.

I'm glad it's working now.
--
DPC3825 (bridged mode) - WRT610N + Tomato - Panasonic KX-TGP500 - Asterisk 11.0.2 on Virtual Server
Anveo - FreePhoneLine - Voxbeam - Numbergroup - Callcentric - VoIP.MS - Localphone - UKDDI

spudz72

join:2010-03-25
Belleville, ON
reply to grand total
said by grand total:

said by spudz72:

Forgot to answer about the keep alive setting. I checked and it appears to be set for the default of 0 which says it is disabled.

Set it to 15. You will need to do this if you are to stand any chance of not needing to forward ports because your registration interval is 3600 seconds by default. I'm assuming you have not changed the phone's registration interval (not configurable in the web UI).

But first, before we go any further, try connecting your phone directly to your modem, i.e. without your router, and check that you can get the phone to ring.

Just an update that it is now Jan 8th so 9 days since I made the changes you requested and so far have not had the phone randomly start ringing all 3 lines like it was before. So will keep my fingers crossed that the problem has been licked. Thanks again.

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·VMedia
·Anveo
said by spudz72:

Just an update that it is now Jan 8th so 9 days since I made the changes you requested and so far have not had the phone randomly start ringing all 3 lines like it was before. So will keep my fingers crossed that the problem has been licked. Thanks again.

Glad to hear it.
--
DPC3825 (bridged mode) - WRT610N + Tomato - Panasonic KX-TGP500 - Asterisk 11.0.2 on Virtual Server
Anveo - FreePhoneLine - Voxbeam - Numbergroup - Callcentric - VoIP.MS - Localphone - UKDDI