dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
10
share rss forum feed

ruiner

join:2012-03-10
Canada
reply to TiberiusX

Re: [AB] How do I forward ports?

0 - 65535 probably won't work since the Actiontec will have at least 1 port bound to itself.

This is what DMZ is for, but you are better off restricting the port range the debugger is using. See here: »files.zend.com/help/PDT/installe···gers.htm


Shanester

join:2010-10-04
Banff, AB
I tried to specify "0" for the remote port, but the Actiontec just says that its invalid.

The instructions (below) says "Zend Debugger opens a random port on the server and connects to port 10137" on the client. The "random" port is actually between 1,024 and 65,535.

»forums.zend.com/viewtopic.php?f=···62#p3551

I didn't know that a router had a port bound to itself. Is it easy to find out what it is?

I tried putting my machine's IP address in the DMZ, but the Zend Debugger still couldn't connect back to me. My machine should have been exposed to the Internet, but Windows Firewall wasn't logging any dropped packets.

Telus has customised the firmware on this router. For example, you can't turn the Firewall off. You can still put a computer into the DMZ, but when I went to ShieldsUP! on grc.com, it still seemed like there was a firewall in place. Is there another way to test if the DMZ is working?

Shane.

ruiner

join:2012-03-10
Canada
0 is a reserved port so it probably won't let you select it because of that. The Actiontec can also be pretty glitchy about actually doing what you tell it to.

The remote and LAN port in the Actiontec's settings don't do what you think. Remote is the port that the external machine connects to on the Actiontec, and then if you want the Actiontec to redirect it to a different internal port then you enter a different port range in the LAN section.

An example would be remote port 8080, LAN port 80 to get around the port 80 block that Telus does.

So what you need to do is forward 10137 TCP to the LAN IP of the PC you want. If that's not working, welcome to the wonderful world of the Actiontec.

Sometimes a restart can fix it, or it can also do that if you're using a different DHCP server or a static IP. Basically, if you're not getting the DHCP lease from the Actiontec, or if you set a static lease outside of its normal DHCP range.