dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
820
share rss forum feed


disconnected

@snet.net

[motherboard] Checking Interruption of Realtime Processes?

I have two Gigabyte P35-DQ6 motherboards which comprise my two editing workstations. One of them has had an unsolveable problem with gaps in audio playback, no matter what sound hardware is being used. It also affects video playback.

The symptom is a brief pause in audio playback at random intervals. Internal sound card on the affected machine is an Auzentec X-fi. Also used for multitrack work is a MOTU 896mk3H connected by IEEE1394. Today's playback session was terrible, with audio stopping every 2-3 minutes for about a second on the MOTU, usually with a 8KHz tone being emitted from the MOTU audio output during the pause period.

I have been through this system so many ways in the past 4 years, tried every optimization, had tech support from Adobe try to assist 2 years ago with getting CS4 running, but to no avail. I suspect a defect in the motherboard, as my other identical system doesn't have this problem.

Task Manager in Win XP doesn't show the culprit because during the 'pause' event it doesn't update. Something is causing the whole system to halt for brief periods, every so often, but with XP stripped to bare essentials to conserve RAM, there's nothing running that can affect realtime playback.

I wonder if there is a utility that can run and monitor CPU interrupts or the various busses and find out what the bottleneck is and maybe give me a clue as to what might be done to fix this once and for all?



norwegian
Premium
join:2005-02-15
Outback

1 edit

Use the utilities at Microsoft:

Process Monitor, Process Explorer, or Diskmon
»technet.microsoft.com/en-us/sysi···bb545027

How long has this bug occurred?
What of a bios update?
Are the systems identical down to the hardware/bios etc?
Graphics card swapped out reproduced the the same result?
A different slot - does it happen still?
Fresh O/S install still replicates the bug?

Maybe give a little more in what was done to help avoid doubling up of help questions?
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke



aurgathor

join:2002-12-01
Lynnwood, WA
kudos:1
Reviews:
·Frontier Communi..
reply to disconnected

This is probably happening at the HW level, and the usual utilities probably won't be much of a help there. I'd think a scope and a logic analyzer would be needed to solve this (and you should have those ) but you would also need to know the ins and outs of that mobo, including the chips and buses. (which you probably don't)

I'm not sure what you've done -- the first thing I'd look is all the event logs -- more often than not, if there is an issue, something will be there.

Based on the symptoms, something probably hogs some bus, or some other critical resource for an excessive amount of time, and without the necessary knowledge, pinpointing the root cause is not going to be easy.

In any case, since you have 2 identical mobos, you can exchange everything that removable and verify that they work fine in the other mobo, or not. At some point you either find a defective part, or left with the mobo, and since you've tried everything else, the mobo must be defective.
--
Wacky Races 2012!


bbear2
Premium
join:2003-10-06
94045
kudos:5

I agree with aurgathor. Swap the MBs and see if the problem stays or moves with it. That seems like the best and easiest thing to do at this point.



mmainprize

join:2001-12-06
Houghton Lake, MI
Reviews:
·Charter

1 edit
reply to disconnected

Does the Audio hardware share an IRQ with other hardware ?
If so how many other items share it and what are they. Do any of these items also run during the audio pause ?
Are you running USB drives and do they go to sleep and have to be woke up. If so disconnect them and try again.
Do you have Speed Step enabled in the BIOS for the CPU. If so turn it off and try again.

As far a two system being the same
Are the BIOS setting all the same.
Are the Cards plugged into the same slot in each system.



disconnected

@snet.net
reply to aurgathor

For one thing, this second system is a 'clone' of the first system I built in 2008 based on the DQ6 board. As I recall, I was unable to complete a clean install with Windows setup on the second system due to some failure or BSOD occuring, so I cloned the drive and set it up that way. All the memory tests good with MEMTEST86 and the system passed all the diagnostics I could find to test with.
I think aurgathor has a point: this is probably some low level hardware problem. I also replaced all the plugin components, such as sound and video cards, but the problem continues.
Swapping the mainboards is about the only thing I did not do. I'm reluctant to mess with my editing workstation, which is my 'bread and butter' machine.
The problem varies depending on several factors which have been observed but may only be correlations not causes:
System behavior is worse after booting up from a powered off state--system off for a day or more. Upon bootup, severe problems with system pausing with multimedia operations. Seems to clear up after about 30 days of 24/7 power on state.
Windows bootup is inconsistent. Sometimes system is behaving well, but then I restart Windows and it behaves poorly until I restart again.
I'm not sure what the problem is, but this motherboard was purchased from a previous owner on eBay in 2009. Maybe the owner did not disclose that there was a subtle problem.



aurgathor

join:2002-12-01
Lynnwood, WA
kudos:1
Reviews:
·Frontier Communi..

Did you look into the event log?

Also, if it blue screens and dumps core, the .dmp file can be analyzed, and more often than not, that can help you to determine what's wrong.

You can also try installing Linux on it for troubleshooting. (it's more verbose, and may just tell you that xyz malfunctions)

Personally, if I can't fix something in a few months, or at least figure out what's wrong with it -- then I usually just stop wasting my time on it.
--
Wacky Races 2012!


royhandy

join:2012-11-05
USA
reply to disconnected

Since the system is cloned, just put the second machine's drive into the first system and see if the problem still appears. If not...there's a hardware issue to track down. If so, could be your drive.

As a stretch...DPC latency, maybe? That'd be a driver issue.