dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1195
share rss forum feed


Chris1028

@bluewin.ch

USG100 self signed certificate in certificate chain

I have two USG100 (home & office).
Neither has been rebooted or had config edits for many months.
This morning, both of them are showing certif errors: this looks like ZyXel's fault if it happened on two independent boxes. Is there anything I can do?

TIA Chris


Starting IDP signature update.
11 2013-01-09 04:23:01
error myzyxel-dot-com myZyXEL.com
Certification verification failed: Depth: 1, Error Number(19):self signed certificate in certificate chain.
12 2013-01-09 04:23:01
error myzyxel-dot-com myZyXEL.com
Self signed certificate in certificate chain.
13 2013-01-09 04:23:01
error myzyxel-dot-com UPDATE
Verify server's certificate has failed. Update stop.
14 2013-01-09 04:23:01
error myzyxel-dot-com UPDATE
Connect to update server has failed.



Brano
I hate Vogons
Premium,MVM
join:2002-06-25
Burlington, ON
kudos:10

1 edit

Probably some certificate in the certificate path expired.
The updated goes to »myupdate.zywall.zyxel.com



chris1028

@bluewin.ch

FIXED

Both my USG were running old firmware ...it took a few hours to step through the firmware revisions, but when I finally got to 3.00(AQQ.0) the AV/IDP updates worked fine.

Currently sitting on 3.00(AQQ.2) with no issues.

Chris



Brano
I hate Vogons
Premium,MVM
join:2002-06-25
Burlington, ON
kudos:10

You didn't have to do all the upgrades, just the latest one. USG upgrades are full upgrades, not incremental.



Chris1028

@bluewin.ch

Possibly you are correct, but here is an extract from 3.00(AQQ.2) support notes:
Please first jump to 2.20Patch2 C0, 2.20Patch3 C0 or 2.20Patch4 C0 before upgrade firmware from above 2.20Patch2 C0 to 2.20Patch5 C0 and later.

Zyxel support were doubtful that I could retain configuration on the older of my two USG and wanted me to do a factory-default reset before stepping through the updates. I tried without reset anyway: it worked.

Now I will never know if reset & go straight to 3.00 & reconfigure would have been faster or easier.