dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
902
share rss forum feed

matthewh16

join:2010-05-21
Middletown, DE

MI424WR As Ethernet Switch?

I need some extra ports on my network, and I have a spare MI424WR (later rev). Can I disable the coax and whatnot, and just have it act as a 4 port switch and connect the WAN to my network directly?

I'm sorry if this was asked before, "Switch" is too generic a term for the search engine and the FAQ didn't seem to have anything directly related.


Springbok

join:2002-09-13
Colleyville, TX

Do not use the WAN port. Just disable DHCP on the LAN side. Here is what you do:

Navigate to My Network: Network Connections: Network (Home/Office): Settings.

Change the drop down selections on the following 2 lines:

Internet Protocol: Obtain an IP address automatically

IP address distribution: Disabled.

Apply the changes. Connect a LAN port on the box to your router or network and the box will pull a IP address through which you can manage it. The other 3 LAN ports are now just switch ports and available for other devices. Any device you plug in there will also pull DHCP config data from the main router.


matthewh16

join:2010-05-21
Middletown, DE

Okay I did this, and the printer and my laptop (as a test) can connect perfectly fine. The iMac (Running 10.8) on the otherhand (using the same cable and port as the laptop) just says "Cable Unplugged". If I connect the line going into the switch directly to the imac (bypassing the switch), it works fine. Any clues?



Thinkdiff
Premium,MVM
join:2001-08-07
Bronx, NY
kudos:11

Make sure your Mac is set for auto negotiation on the ethernet port.

System Preferences > Network > Ethernet > Advanced > Hardware tab. Configure should say Automatically.

If that doesn't work, try a different port and/or cable between the iMac and the 2nd Actiontec (switch).
--
University of Southern California - Fight On!


matthewh16

join:2010-05-21
Middletown, DE

It was, and I had tried different ports and cables. I'm not sure if it'll help but Basically heres the setup and what i'm trying to do:

I have a rev I in my bedroom connected to the ONT via Coax. I have a few devices connected to it. Downstairs in the den I have I think a rev F, connected via moca to provide ethernet to that part of the house (this switch has no issues and has worked fine for a few years). An ethernet line runs from the den to the dining room where the imac is. Connecting this line straight to the imac works fine and has for a few years. Adding another switch (in this case a rev C in switch mode) so I can network the printer in the dining room which is ethernet only, makes the mac fail to connect. Yet other devices (the printer, and a laptop in ethernet only mode as a test), connect fine using the same jacks and ethernet cables that the imac fails on. Ive tried swapping jacks for both the WAN and LAN connection (tho not using wan port), and cables, and the mac either says "NO CONNECTION", or works till it's rebooted.

Note: Yes, I have a few routers from when Verizon refused to believe me that it was a bad ONT and not a bad router, and they didn't want them back even though they sent like 4. :P



Thinkdiff
Premium,MVM
join:2001-08-07
Bronx, NY
kudos:11

Only thing I can suggest is that perhaps that Rev C actually is a bad router/switch. Maybe try swapping the rev F and rev C to see if the iMac works when the rev F is the dining room switch and the rev C is handling MoCA/ethernet bridging.
--
University of Southern California - Fight On!


Springbok

join:2002-09-13
Colleyville, TX
reply to matthewh16

You can try resetting the router to default settings (little hole on the back, paperclip, hold 20 seconds) and then repeat the instructions for disabling DHCP. You must also ensure your iMac does not hold or obtain an IP address already dispensed to another device on your network.


Springbok

join:2002-09-13
Colleyville, TX

BTW, you mention a MOCA LAN connection, did you remember to disable DHCP on that router, too? You should have only one DHCP server anywhere on your local area network, most often the main router.


matthewh16

join:2010-05-21
Middletown, DE

said by Springbok:

BTW, you mention a MOCA LAN connection, did you remember to disable DHCP on that router, too? You should have only one DHCP server anywhere on your local area network, most often the main router.

Yeah the moca router's been find for a few years and is DHCP disabled. The thing is the mac doesn't even TRY to grab an IP as it says no cable connected :\.

Springbok

join:2002-09-13
Colleyville, TX

Did you set the speed on you iMac to Auto as Thinkdiff said? I believe port speed on those older Actiontecs is 100 mbs and your iMac probably has a 10/100/1000 NIC. If it was me I would not bother with the Actiontec but just get a GigE switch, a cheap one is around 20-30 bucks.


matthewh16

join:2010-05-21
Middletown, DE

Yeah it's on Auto, I'll probably grab a cheap switch though, for now it's just using my N Wireless.