dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1659
share rss forum feed


chachazz
Premium
join:2003-12-14
kudos:9
Reviews:
·TELUS

1 edit

[Updated]Foxit Advanced Editor 3.0.4.0/PDF Reader 5.4.5.0114

Foxit PDF Advanced Editor 3.0.4.0 - Jan 14, 2013
Fixed a security issue where hackers can run arbitrary code by repairing a STATUS_STACK_BUFFER_OVERRUN exception.

Foxit Reader (free) 5.4.5.0114 - Jan 16, 2013
(with updated plugin)
»cdn04.foxitsoftware.com/pub/foxi ··· 5.4/enu/

(Regular d/l does not have new version yet)






therube

join:2004-11-11
Randallstown, MD
Again, almost certainly there is no functional change in 5.4.5.0114 except for the junk extras packaged within.

Be aware.


chachazz
Premium
join:2003-12-14
kudos:9
Reviews:
·TELUS
said by therube:

Again, almost certainly there is no functional change in 5.4.5.0114 except for the junk extras packaged within.
Be aware.

From the previous Foxit topic....
quote:
Note that that exploit deals with the Plugin (npFoxitReaderPlugin.dll),
In fact, the plugin has been upgraded as noted above (image).

The plugin in the previous version has been blocked by Mozilla......
so users should update without delay.








As to extras packaged, like the Foxit Toolbar, or other, that's just a fact of life with free software, including open source, ...going back to 2007-2008, it became common practice with many developers offering free versions/editions.

redwolfe_98
Premium
join:2001-06-11
kudos:1
Reviews:
·Time Warner Cable

2 edits
reply to chachazz
from foxit's security-advisory, regarding foxit reader build 5.4.5.0114:

»www.foxitsoftware.com/support/se ··· p#FRD-18

Foxit Reader 5.4.5 fixed a security issue where attackers can exploit a web browser plugin vulnerability to execute arbitrary code. The vulnerability is caused by a boundary error in the Foxit Reader plugin for web browsers (npFoxitReaderPlugin.dll) when processing a URL and can be exploited to cause a stack-based buffer overflow via an overly long file name in the URL.

Affected Versions
Foxit Reader 5.4.4 and earlier.

Fixed in Version
Foxit Reader 5.4.5
----------------------------
i only install the foxit reader program-files and don't install the "shell extensions" or other "addons".. foxit reader works fine for me without the "shell extensions"..


chachazz
Premium
join:2003-12-14
kudos:9
Reviews:
·TELUS
Thanks redwolfe_98 See Profile - that was posted today.
The usual download link shows the version now; no MSI though.
»www.foxitsoftware.com/downloads/
Expand your moderator at work


therube

join:2004-11-11
Randallstown, MD
Reviews:
·Comcast
·Verizon Online DSL
reply to chachazz

Re: [Updated]Foxit Advanced Editor 3.0.4.0/PDF Reader 5.4.5.0114

quote:
almost certainly there is no functional change in 5.4.5.0114

I was certainly wrong in this case.

At the time, they offered both this 5.4.5 plus the earlier, not updated MSI. Given that's what they've done in the past, & there was no program related differences in the past, I based my assumption on that.

Correct, no MSI shown, at all, any longer nor seemingly available.

Diffs that I can see from this 5.4.5 & the last MSI.

Foxit Reader.exe.man
Foxit Reader.exe
/plugins/FRMSPlg.fpi, Foxit Reader RMS Plugin, dated 10-30-12

I would (will) put this updated version in, just beware any extras.


therube

join:2004-11-11
Randallstown, MD
reply to chachazz
Looks like Foxit Firefox Plugin has also been updated to a version 2.2.3.111.


therube

join:2004-11-11
Randallstown, MD
Reviews:
·Comcast
·Verizon Online DSL
reply to chachazz
Here: EnterpriseFoxitReader545.0114_enu.msi (I haven't looked at it yet).

Also note they show FoxitReader545.01141_enu_Setup.exe can't say what any differences are.


therube

join:2004-11-11
Randallstown, MD
> EnterpriseFoxitReader545.0114_enu.msi (I haven't looked at it yet)

Looks good.

> note they show FoxitReader545.01141_enu_Setup.exe can't say what any differences are

Only related to the "junk" (toolbars or whatnot).

Massie

join:2013-01-28
New York, NY
reply to chachazz
Thanks for sharing. I've updated my Foxit Reader.


therube

join:2004-11-11
Randallstown, MD

1 edit
reply to chachazz
They are now showing Foxit Reader 5.4.5.0124.
(I'll leave it for others to tell the difference between .0114 & .0124.)

Still not showing the MSI, & the MSI that is there is what was there before, .0114.


chachazz
Premium
join:2003-12-14
kudos:9
Reviews:
·TELUS

Got it but no new changelog in the file.




therube

join:2004-11-11
Randallstown, MD
Reviews:
·Comcast
·Verizon Online DSL
So you're going to make me do it ...

What was PIPClock.exe looks to be now known as FoxitTool.exe.
What was CheckPIP.exe looks to be now known as FoxitStub.exe.
Those two & the file, PIPDetect.exe are changed.

What any of them do, I haven't a clue?
I'm guessing that the only change has to do with the "Copyright" string within the file?

Foxit Reader.exe & Foxit Reader.exe.man are both changed, very slightly.
Again no idea, but guessing that it has to do with an update to the Digital Signatures.