dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
15
share rss forum feed


Snakeoil
Ignore Button. The coward's feature.
Premium
join:2000-08-05
Mentor, OH
kudos:1
reply to Maxo

Re: Halp. (Drivers)

How can I tell if I am using lightdm vs gdm? One of those prevents the GUI for launching. Instead I get the console. Reason why I ask is because steam is complaining that I don't have updated gl drivers.
Currently have nvidia 304.48 experimental running.

Not to hijack a thread.
--
Is a person a failure for doing nothing? Or is he a failure for trying, and not succeeding at what he is attempting to do? What did you fail at today?.


Maxo
Your tax dollars at work.
Premium,VIP
join:2002-11-04
Tallahassee, FL
said by Snakeoil:

How can I tell if I am using lightdm vs gdm? One of those prevents the GUI for launching. Instead I get the console.

If gdm is not in /etc/init.d/ then you are not using gdm. If both show up then I'm not sure how to tell. You could always run `sudo stop gdm && sudo start lightdm` which should guaruntee you are in lightdm and not gdm.


Pjr
Don't Panic

join:2005-12-11
UK
sudo service gdm status
gdm: unrecognized service
sudo service lightdm status
[ ok ] lightdm is running.
 
or if Ubuntu doesn't have /usr/sbin/service then use
sudo /etc/init.d/gdm status
-su: /etc/init.d/gdm: No such file or directory
sudo /etc/init.d/lightdm status
[ ok ] lightdm is running.
 
It's probably the best method but there are others such as grepping "ps aux". I assume Ubuntu hasn't deviated so far from Debian that the above won't work.

--
Overflow error in /dev/null


Snakeoil
Ignore Button. The coward's feature.
Premium
join:2000-08-05
Mentor, OH
kudos:1
Thank you. I used the first block that you posted. I'm running gdm. So lightdm is the one that shuts off my gui.


Snakeoil
Ignore Button. The coward's feature.
Premium
join:2000-08-05
Mentor, OH
kudos:1
reply to Maxo
Thanks. Turns out I'm running gdm.
I recall when I first upgraded to 12.04 LTS, I had the same situation.

Steam doesn't like the 304.48 nvidia driver. I need to figure out how to update it, and the gl packages. I would have thought it would have been done through the software/update manager.
--
Is a person a failure for doing nothing? Or is he a failure for trying, and not succeeding at what he is attempting to do? What did you fail at today?.


Maxo
Your tax dollars at work.
Premium,VIP
join:2002-11-04
Tallahassee, FL

1 edit
In 12.04 I was able to get the latest nvidia drivers through Jockey by installing the "NVIDIA accelerated graphics driver (**experimental**beta) (version experimental-310)" drivers.

Update: Added exact wording from Jocky.

Uraki
Uraki
Premium
join:2003-06-22
Belle Plaine, KS
reply to Snakeoil
Under 12.10, you can install "nvidia-experimental-310" & "nvidia-settings-experimental-310" to get a later version.

Not sure if that works under 12.04