dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
9
share rss forum feed


Subaru
1-3-2-4
Premium
join:2001-05-31
Greenwich, CT
kudos:1
reply to pende_tim

Re: Old kerosense does this?

said by pende_tim:

The kerosene was probably good. It takes these devices a minute or so to get hot enough to allow the fuel to completely burn, until then they will flare and smoke.

If the fuel was bad, the problem would have continued for the whole tankful.

I have an old model Kerosun heater that behaves as you describe.

I've had it off for a month or longer and it never did this before, matter of fact from my 40 times of using it this is the first time I saw this.
--
It's NOT Ni-kon It's NE-KON!




LG is NOT Lifes Good It's Lucky Goldstar!


garys_2k
Premium
join:2004-05-07
Farmington, MI

It's likely you just got a little extra dust in the combustion chamber and it took a minute to burn off.



tp0d
yabbazooie
Premium
join:2001-02-13
Carnegie, PA
kudos:5

It probably needs--- 1- cleaned, 2- new oil filter, 3- new oil nozzle, 4- new oil pump

listed in order of complexity.. any oil burner will get dirty with usage..

the two torpedo heaters I have will smoke and flame for the first 30secs, then heat up and run fine.. sounds pretty normal

-j
--
if it aint broke, tweak it!!
currently on FiOS (kick aZZ!)



Subaru
1-3-2-4
Premium
join:2001-05-31
Greenwich, CT
kudos:1

I opened it about 2 months ago before I used the rest of the old kerosene up and cleaned inside, it hardly has that many hours on it but anyways it's fine now.

Video

»www.youtube.com/watch?v=UGqQzE3bPAU