dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
65
share rss forum feed


NetFixer
Bah Humbug
Premium
join:2004-06-24
The Boro
Reviews:
·Vonage
·Comcast Business..
·Cingular Wireless

1 recommendation

reply to jkj860

Re: [IPv6] IPv6 and Netgear WNDR 3700-100NAS issues

said by jkj860:

When I run the test it always fails. I have a sb6121 and a Netgear WNDR3700v3 router with stock firmware. The modem says IPv4 only but in the routers IPv6 tab I show this.
Router's IPv6 Address On WAN
2001:............./64
Router's IPv6 Address On LAN
2601:............./64
Internet connection type is set to DHCP and IP address assignment is set to Auto config.

It sounds is if your router is properly getting the IPv6 information from Comcast and is properly setting up its LAN.

What OS are you running on your PC(s)? If Windows, open a command prompt and post the results of "ipconfig /all" and "netsh int ipv6 show addr" commands. If it is *nix based, try opening up a terminal window and post the results of "ifconfig" or "ip addr" commands. Assuming that you do have IPv6 configured and active on at least one PC, can you ping the 2601:xx:xx:xx:xx LAN IP address of the router? If you do a ping to an IPv6 Internet site (such as ipv6.speedtest.comcast.net) do you see a response from the router's LAN interface? Actually posting the results of the ping and traceroute tests would be helpful, and just for good faith, here are my results for all of the above from the Windows XP workstation I am currently using:





And FWIW, my SB6121 shows as IPv4 too, but that is only for the management interface and has nothing to do with payload traffic (if it did, your router would not be getting IPv6 information).

--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


jkj860
The Final Frontier

join:2002-01-10
Valparaiso, IN
>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : homeoffice-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) Family PCI-E
Gigabit Ethernet NIC (NDIS 6.0)
Physical Address. . . . . . . . . : 00-........-BD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.16(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Tuesday, January 22, 2013 1:27:07 AM
Lease Expires . . . . . . . . . . : Thursday, January 24, 2013 1:27:10 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enable
--
I know you think you understand what you thought I said, but I am not sure you realize what you heard is not what I meant. Nixon


jkj860
The Final Frontier

join:2002-01-10
Valparaiso, IN
reply to NetFixer

C:\Users\home office>netsh int ipv6 show addr

Interface 1: Loopback Pseudo-Interface 1

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Other Preferred infinite infinite ::1

C:\Users\home office>
--
I know you think you understand what you thought I said, but I am not sure you realize what you heard is not what I meant. Nixon


jkj860
The Final Frontier

join:2002-01-10
Valparaiso, IN
reply to NetFixer
Oops...double post.


owlyn
Premium,MVM
join:2004-06-05
Newtown, PA
reply to jkj860
My suggestion above takes about 10 seconds and should work. Worked on my Netgear router, where, like yours, setting it to DHCP didn't work. Don't know why you haven't tried it.


NetFixer
Bah Humbug
Premium
join:2004-06-24
The Boro
Reviews:
·Vonage
·Comcast Business..
·Cingular Wireless
reply to jkj860
Are you sure that you have the MS TCPIP6 protocol stack installed and enabled for that NIC?

As a test, I just disabled IPv6 in my Netgear WNR1000v2-VC guest router, and connected my notebook to it. Shown below is the NIC properties screen showing that the MS TCPIP6 protocol is installed and enabled, and also what I get for the "ipconfig /all" command under those conditions:








Please note from the above, that the NIC still gets a link-local IPv6 address [fe80::21a:73ff:fe67:2cdc%9] even with no IPv6 enabled in the router. Also the pseudo IPv6 tunnels are still showing (but they do not appear in your post).

Next, I disabled the MS TCPIP6 protocol for that NIC and reconnected it to the Netgear router. Shown below is the NIC properties screen showing that the MS TCPIP6 protocol is installed and disabled, and also what I get for the "ipconfig /all" command under those conditions:







Please note from the above, that the NIC no longer gets a link-local IPv6 address, but the pseudo IPv6 tunnels are still showing (but they do not appear in your post).

The only way I could duplicate the "ipconfig /all" results you posted was to uninstall the MS TCPIP6 protocol stack as shown below.








--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


jkj860
The Final Frontier

join:2002-01-10
Valparaiso, IN


NetFixer
Bah Humbug
Premium
join:2004-06-24
The Boro
Reviews:
·Vonage
·Comcast Business..
·Cingular Wireless
Well, since you do seem to have the MS TCPIP6 protocol installed and enabled, I have no definite explanation for why you are not at least seeing a link local [fe00::xx:xx:xx:xx] IPv6 address for that NIC. I don't think that you have a chance for getting IPv6 connectivity until you get that resolved.

You might start by looking at the Symantec firewall setup (look for something related to ICMPv6, since that might block even setting up basic IPv6 for the NIC). If you don't find anything in the Symantec firewall that is blocking IPv6, then uninstalling the MS TCPIP6 protocol stack, rebooting, and then reinstalling it would be the next step.
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


NetDog
Premium,VIP
join:2002-03-04
Parker, CO
kudos:81
said by NetFixer:

Well, since you do seem to have the MS TCPIP6 protocol installed and enabled, I have no definite explanation for why you are not at least seeing a link local [fe00::xx:xx:xx:xx] IPv6 address for that NIC. I don't think that you have a chance for getting IPv6 connectivity until you get that resolved.

I would agree with this.. You need to see the FE80 before IPv6 will work, it is how all the starting traffic works..

Link-local IPv6 Address . . . . . : fe80::708a:eeee:5566:1234%12

Maybe uninstall the stack and reinstall it, what OS was this on?


jkj860
The Final Frontier

join:2002-01-10
Valparaiso, IN
reply to NetFixer
Ok i will give that a try.
Edit. Vista OS