dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
627
share rss forum feed

flyzilla

join:2013-01-02

Two questions

I have gotten almost everything to work as I wanted on my USG 20W, but these I haven't been able to figure out yet:

- I have a server on my LAN; I can connect to it from WAN, but not from LAN, using my WAN address. How can I make this work? Nothing shows up in the logs. (the reason I don’t just use internal IP is that my phone is set up to ping the server automatically and fails to do so once the phone connects to LAN)

- My Squeezebox (WLAN) used to wake up my server (wired) using WoL. It doesn’t anymore, even though I can successfully wake the server (from WLAN using my phone) with a WoL packet. What gives? WLAN and LAN are bridged and on the same subnet.

Any and all help will be appreciated.


Kirby Smith

join:2001-01-26
Derry, NH
Reviews:
·Fairpoint Commun..

There is a "loopback" [forget the actual name, and I'm not near my router at present] capability that has to have its checkbox checked for a LAN sourced packet to get to the WAN interface and be allowed back in. I also don't remember which menu it is on.

If no one clarifies this, I'll hunt it down several hours from now.

kirby



Brano
I hate Vogons
Premium,MVM
join:2002-06-25
Burlington, ON
kudos:10
Reviews:
·TekSavvy DSL
·Bell Fibe
reply to flyzilla

1) Use NAT loopback or use DNS pointing to internal servers IP. I prefer the latter, see #12 here issue with loopback here »Secure your USG - quick how-to

2) There are some known issues with USG not passing the WoL broadcast packet across the interfaces, but since it's working from your phone and not other server I have no idea.
If you can enable packet capture to see if the WoL packet is actually delivered to the target server.


flyzilla

join:2013-01-02

1 edit

Click for full size
Thanks for the replys.

1) I enabled the loopback checkbox, but that doesn't seem to help; I've included a screenshot of my NAT settings.

edit: I'll take that back, it does work. For some reason my desktop PC hasn't woken up to the reality yet, but my phone connects succesfully.

When you talk about DNS, where and how exactly would I configure this? Would this have to be set up on the connecting device or is it possible to tell USG to do this? I don't think I can add custom DNS values to unrooted Android devices.

2) I've included a screenshot from Wireshark showing the relevant lines. I captured interfaces WLAN & LAN. 192.168.100.6 is the Squeezebox and 192.168.100.4 is the server. These lines just keep repeating. I guess the conclusion is that no magic packet is being sent because the Squeezebox receives no answer to the ARP request?

On the bottom is an example of my desktop PC asking USGs MAC address and USG responding.

I'm really no expert with these things, so if you require more information just tell me and I'll try to provide.

flyzilla

join:2013-01-02

Updates:
1) This works now with the loopback option. I would still love to hear how to setup this through DNS.
2) I added the server MAC address to the USG through console, works now (only 80% sure that this was the cause though, tried all kinds of other things too and am too lazy to test more now that it works.. )