dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
891
share rss forum feed

Xarath

join:2013-01-27

[HELP] Cisco 3660 Comcast Config help

I am trying to configure a Cisco 3660 router for my fraternity. We have Comcast Business, and I am CCNA certified. I have, however, forgotten some of my knowledge as I haven't had the opportunity to practice networking for a few years.

I successfully set up the router a week ago, but for some reason the running-config was never properly saved, so I re-setup the router a couple days ago. While it does work, I'm getting speeds that are a fraction of what they were when I configured it last week. I'm not sure if I'm just missing a simple setting, or what.

Here is my startup-config:

Using 1222 out of 129016 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3660_EDGE
!
boot-start-marker
boot-end-marker
!
enable secret 5 **********************
no aaa new-model
memory-size iomem 25
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.0.0 172.16.11.255
!
ip dhcp pool insideDHCP
   network 172.16.0.0 255.255.0.0
   default-router 172.16.10.1
   dns-server 68.87.72.130 68.87.77.130
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Facing Modem
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description Facing Triangle LAN
 ip address 172.16.10.1 255.255.0.0
 ip nat inside
 ip virtual-reassembly
 speed 100
 full-duplex
 no mop enabled
!
!
ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 password *****
 logging synchronous
 login
line aux 0
 password ******
 login
line vty 0 4
 password *******
 login
 transport input none
!
!
end
 

Thank you for your help, and let me know if there's any other info I can provide

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9

Don't hardcode speed and duplex. That's the only obvious thing I can see.

If you're running a /16 worth of college kids through it, I know for a fact it will fall over and die. (we had a customer ~8 years ago try that @ UNCG... we loaned them a 7200 to replace it.) Check the number of nat translations ("sh ip nat st") and cpu ("sh proc cpu" and "sh proc cpu h")



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

I agree. I have a feeling that by hard coding the speed and duplex, youve forced the other end to fail at auto negotiation, and its running half duplex, which probably explains the drop in speed.

3660 is pretty old now, I'd imagine that it will be absolutely hammered by a bunch of college students. CPU and RAM will disappear pretty quickly with all the file sharing that will no doubt go on.


Xarath

join:2013-01-27
reply to Xarath

I changed the speed and duplex to auto, and it worked perfectly! Now I'm getting up to 30x faster connection speeds. We only have around 50 people who will be using the network, and I'm currently in the process of applying for a grant to get the cash to upgrade. Thank you so much for your help, I knew it was going to be something simple like this.


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to Xarath

See this FAQ item for basic steps to try.

Glad it's working better now. By the way, what's your package rated as? You could probably pick up and older G1 series
router for cheap that'd pack alot more punch than the 3660.

Regards


aryoba
Premium,MVM
join:2002-08-22
kudos:4
reply to Xarath

said by Xarath:

I am trying to configure a Cisco 3660 router for my fraternity.

I assume the frat guys and gals would mind of the router's fan noise.

How did you manage to keep the noise down then?