dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
28
share rss forum feed


M in Cobourg

@cgocable.net
reply to got_milk

Re: [INTERNET] Cannot update to new version of Cogeco Security S

When I upgraded to Windows 8, I got a message that F-Secure wasn't compatible and would be removed. I don't know if the new version is compatible, but I figured I was OK with Windows Firewall and Defender.



RedMageX

join:2011-10-06
Oakville, ON

From what I heard, the newest version of Security Services IS compatible with Windows 8, you may have had the old one still installed.



Asawulf
Ignorance is bliss
VIP
join:2005-08-17
Trois-Rivieres, QC
kudos:4
reply to M in Cobourg

said by M in Cobourg :

When I upgraded to Windows 8, I got a message that F-Secure wasn't compatible and would be removed. I don't know if the new version is compatible, but I figured I was OK with Windows Firewall and Defender.

The new version is indeed Win8 compatible


M in Cobourg

@cgocable.net

Thanks for the info. I don't have anything installed at the moment, but I'll give the new version a try.