dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
867
share rss forum feed

germ65

join:2009-10-27

Continuous problems with U-verse DSL service

I was forced to switch from Elite DSL service to the new U-verse VDSL about three months ago. The new service is faster, about twice as fast, but I have been having continuous problems from the beginning.

The issue is this: Web surfing is OK, but downloads start, then stall after a few minutes. This happens with large downloads, those that last more than a few minutes. It happens regardless of the site I am downloading from, and regardless of whether I am using a wired or wireless computer.

My configuration: DSL line -- 2Wire 3600HGV in "DMZ Plus" mode -- Linksys wireless router running DD-WRT -- D-link gigabyte switch for the wired connections. I also have another wireless router and an Ooma device. Wireless is disabled on the 2Wire. I am using the Linksys on a separate subnet as the home gateway. With the previous Elite DSL service I had the exact same configuration and never had such problems with downloads.

Please see configuration screenshots here:
»s982.beta.photobucket.com/user/g···/U-verse

In those screenshots "Unknown...411" device is the Linksys router.

At first, I thought that AT&T is playing some games with traffic shaping etc. But then I tried attaching a computer directly to the 2Wire modem/router via Ethernet, and then I can download perfectly. If I attach the same computer to the Linksys and download the same file, it stops in the middle. 100% reproducible. This would seem to point to the Linksys router as the culprit.

OTOH, I never had such problems with the previous DSL service. So, there seems to be some sort of incompatibility between the 2Wire in DMZ mode and the Linksys router, or the DMZ mode does not work properly. I am starting to think that I need a new router.

I think I am going to try removing the Linksys router and running everything from the 2Wire. This can only be an interim solution, though, because the 2Wire does not have n WiFi.

Any suggestion welcome.



Mangix

join:2012-02-16
united state

with dd-wrt, there's a specific 2wire tweak that must be made. I believe [code]
iptables -I INPUT -p udp --sport 67 --dport 68 -j ACCEPT
[/code] must be added to the Firewall settings.


germ65

join:2009-10-27

Thanks Mangix for your suggestion.

I am aware of that tweak. I did not apply it because it's related to the short lease time (10 min.) that was set in earlier versions of the 2Wire device. But now the 2Wire can be set to lease times of 24h. That's how I set mine and so I thought this tweak does not apply.

Nevertheless, today I tried applying the command you suggested.

Unfortunately, the situation hasn't changed and my downloads still stop.



Mangix

join:2012-02-16
united state
reply to germ65

No idea. FWIW When I did a setup like this, I had more issues with the stock Linksys firmware than I did with dd-wrt. You may try putting Tomato on your router and see if it works.

Honestly, dd-wrt forum is a better place for this.