dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1095
share rss forum feed

fvcs

join:2013-02-11
Gilberts, IL

[Unlock] Unlock Cisco SPA2102 from RingCentral

Hi,
I'm trying to unlock a SPA2102 from RingCentral. I can get into the device page, but do not know the Administrator name or password to change the config. Have tried a lot of the things here, but no luck. One thing I read said it should show in Wireshark, but I am a nube to Wireshark and did not see it. Any help / clues would be appreciated. I hate to throw it out and could use it with other VOIP projects.


DaveSin

join:2009-07-17

I do not know the default password, but from my limited experience, I don't think those RingCentral units are locked. I brought a fairly new SPA2102 for $20 from a RingCentral Customer and it came unlocked. Have you tried resetting the unit?


fvcs

join:2013-02-11
Gilberts, IL

I did the user reset (which it took but did not seem to do much), but if I try the factory reset it asks for a password. I tried many of the online passwords with no luck. I can get to the administration login, but it asks for a user name and password. I tried a bunch of them with no luck. In a post I read it said the password would be in plain text in Wireshark, but I did not see it (although I don't know Wireshark enough to be confident it is not there).


Stewart

join:2005-07-13
kudos:25

Your Wireshark connection needs to "see" all the traffic to/from the ATA. This can be done with a PC with two NICs, e.g. connect by Wi-Fi to the Internet, share connection to Ethernet port, into which you plug the ATA. Or, you can use a old (10 Mbps) hub, or a managed switch.

If you have this properly set up, start a capture with the ATA powered off. Power it up and continue capturing for at least two minutes. Report what packets you see, which would normally start with a DHCP Discover. You will be looking for data fetched (by TFTP, FTP, HTTP or HTTPS) from a RingCentral server.