dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1814
share rss forum feed

sandman_1

join:2011-04-23
11111

Router behind a router

I got my Gateway Router set to use channel 13. Every device in our home works with it except our HP wireless printer. So I hooked up a second router to the main one and set it to channel 1. My PC and Android phone see the printer just fine. I can even access the Embedded Web Server through the printers LAN address. However my wife's phone (iPhone 4s) can't see the printer for some reason. I DMZd the printer and disabled firewall on 2nd router and the phone still won't see it. Any ideas why it won't?

One solution was to connect the phone using the 2nd routers SSID. However this isn't my ideal choice as it places the phone on a crowded channel and requires switching back to the main routers SSID after printing has been completed. It would be nice to somehow get the printer to use channel 13 but my research has produced zilch in that department.



SoonerAl
Premium,MVM
join:2002-07-23
Norman, OK
kudos:5

1 edit

1 recommendation

Click for full size
Wireless router as wireless access point
Here is a FAQ that describes how to setup a second router as a wireless access point...

»Wireless Networking Forum FAQ »Using a Wireless Router as an Access Point

The screen shot illustrates this...

EDIT: Corrected screen shot to illustrate a wireless router acting as a wireless access point.


eibgrad

join:2010-03-15
reply to sandman_1

Only wish that diagram had called router #1 as #2, and vice versa, router #2 as #1. I know, a bit picky, but I think ppl see their primary router (the one connected to the internet) as #1. Or even call it "primary". Instead it looks like a wired-only router followed by a second wireless router. A bit weird.


sandman_1

join:2011-04-23
11111
reply to SoonerAl

Ok I had that setup in the diagram. I read over the document and it appeared I didn't have a few things in the right config. Went step by step and checked off each one and now it works. Thanks!

@eibgrad

Agree 100%


sandman_1

join:2011-04-23
11111
reply to sandman_1

One final problem actually remains, is it possible to access the 2nd router's (router 1 in map above) configuration page? If so, then how?



eibgrad

join:2010-03-15
reply to sandman_1

If you configured it correctly, then both routers should be linked via LAN ports, and therefore the second router should have an IP address (e.g., 192.168.1.2) in the same network as the primary router(e.g., 192.168.1.1). So there's nothing special about the second router in that respect. It's just another device on your network and fully addressable no matter which SSID you're using.


sandman_1

join:2011-04-23
11111

I have both routers linked through LAN ports. The second router has an ip address statically assigned 192.168.1.2. My DHCP server setting on 1st router is 192.168.1.3-254.

In Windows 7 Pro Network map, Windows sees the 2nd router as having an address of 10.0.0.1. My Asus router, WAN router, sees it as 192.168.1.2.

I have tried both of those IP addresses and none work. IDK what is preventing me from accessing the other routers config page. Puzzled...



eibgrad

join:2010-03-15
reply to sandman_1

10.0.0.1?? Where did that come from? You disabled DHCP on the second router, right?


sandman_1

join:2011-04-23
11111

Yep it is disabled (DHCP) on my Netgear WPN824N.

For some reason, after I manually set the basic settings on its configuration page, it says "other network detected." and then the login address for the config page changes to that 10.0.0.1 address.

Basic settings being:

router ip: 192.168.1.2
subnet : 255.255.255.0
Gateway: 192.168.1.1

DNS : 192.168.1.1



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1

Are you sure there is nothing connected to the netgear internet/wan port?


sandman_1

join:2011-04-23
11111

100% sure.



eibgrad

join:2010-03-15
reply to sandman_1

This is a pretty simple configuration. It's done all the time. I get the feeling there's something missing in terms of information that's making this configuration different, but I can't figure out what. As I said, I have no clue where this reference to 10.0.0.1 is coming from. Perhaps it’s time to reset both routers and start over.


sandman_1

join:2011-04-23
11111

Got it to work.

What I was doing is defining the router LAN settings in the "Basic Settings" menu. The "Basic Settings" menu is for the WAN port. I was confused and thought I had to define all my settings there like I posted above. When I set the "Basic Settings" to "Auto", I then went to the LAN page and set the router access page to 192.168.1.2, same as it is defined on my Asus Router. Now I can access both the routers' config pages.

Thanks for the help and sorry for the confusion. I have never done this before and it has a been quite a learning experience.



Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5

Glad its resolved - it did sound like a misconfiguration on the non DHCP router.



SoonerAl
Premium,MVM
join:2002-07-23
Norman, OK
kudos:5
reply to eibgrad

said by eibgrad:

Only wish that diagram had called router #1 as #2, and vice versa, router #2 as #1. I know, a bit picky, but I think ppl see their primary router (the one connected to the internet) as #1. Or even call it "primary". Instead it looks like a wired-only router followed by a second wireless router. A bit weird.

I corrected the drawing. I am not at all sure why I had it like that in the first place. Blame on old age...


eibgrad

join:2010-03-15
reply to sandman_1

^^ Thanks!



wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1
reply to sandman_1

said by sandman_1:

For some reason, after I manually set the basic settings on its configuration page, it says "other network detected." and then the login address for the config page changes to that 10.0.0.1 address.

You should never have the same subnet on the lan and wan side of the router.
With a netgear router it will automatically change the subnet of the lan along with the lan ip address.